aboutsummaryrefslogtreecommitdiff
path: root/lang/gjs
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /lang/gjs
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
downloadports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.tar.gz
ports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.zip
Notes
Diffstat (limited to 'lang/gjs')
-rw-r--r--lang/gjs/Makefile24
-rw-r--r--lang/gjs/distinfo4
-rw-r--r--lang/gjs/files/patch-modules_overrides_GLib.js79
-rw-r--r--lang/gjs/pkg-plist45
4 files changed, 15 insertions, 137 deletions
diff --git a/lang/gjs/Makefile b/lang/gjs/Makefile
index efbbe8d248ee..b30b882851d7 100644
--- a/lang/gjs/Makefile
+++ b/lang/gjs/Makefile
@@ -1,10 +1,9 @@
# Created by: Pawel Worach <pawel.worach@gmail.com>
# $FreeBSD$
-# $MCom: ports/trunk/lang/gjs/Makefile 18581 2013-06-23 10:50:00Z kwm $
+# $MCom: ports/trunk/lang/gjs/Makefile 19944 2014-10-15 05:33:09Z gusi $
PORTNAME= gjs
-PORTVERSION= 1.34.0
-PORTREVISION= 2
+PORTVERSION= 1.42.0
CATEGORIES= lang gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -13,21 +12,16 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME Javascript binding
LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
- libmozjs185.so:${PORTSDIR}/lang/spidermonkey185
+ libmozjs-24.so:${PORTSDIR}/lang/spidermonkey24
-CONFLICTS_BUILD=spidermonkey17-1.7.*
-
-USES= gettext gmake libtool:keepla pathfix pkgconfig python:2,build \
- shebangfix tar:xz
-USE_GNOME= cairo glib20 gnomeprefix introspection:build intlhack
+USES= compiler:c11 gettext gmake libtool pathfix pkgconfig \
+ python:build tar:xz
+USE_GNOME= cairo glib20 gnomeprefix introspection:build \
+ intlhack
+GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-GNU_CONFIGURE= yes
+LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
-python_OLD_CMD= /usr/bin/env python
-python_CMD= /usr/bin/env python2
-SHEBANG_FILES= scripts/make-tests
-
.include <bsd.port.mk>
diff --git a/lang/gjs/distinfo b/lang/gjs/distinfo
index 25d125ca9618..4ec110ba8e18 100644
--- a/lang/gjs/distinfo
+++ b/lang/gjs/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome3/gjs-1.34.0.tar.xz) = 3d62c717a0522a36c6faa1eb021872255e3cd285a72786afe23b7cca2e3084cb
-SIZE (gnome3/gjs-1.34.0.tar.xz) = 474004
+SHA256 (gnome3/gjs-1.42.0.tar.xz) = 0c9afb7d5be6ead5b68059596f08eb7c3902b1676ee9c8846aa8df09647dba13
+SIZE (gnome3/gjs-1.42.0.tar.xz) = 449264
diff --git a/lang/gjs/files/patch-modules_overrides_GLib.js b/lang/gjs/files/patch-modules_overrides_GLib.js
deleted file mode 100644
index 5bf70a844a74..000000000000
--- a/lang/gjs/files/patch-modules_overrides_GLib.js
+++ /dev/null
@@ -1,79 +0,0 @@
---- modules/overrides/GLib.js.orig 2011-12-15 16:10:34.000000000 +0100
-+++ modules/overrides/GLib.js 2011-12-15 16:23:47.000000000 +0100
-@@ -25,27 +25,27 @@ let originalVariantClass;
- const SIMPLE_TYPES = ['b', 'y', 'n', 'q', 'i', 'u', 'x', 't', 'h', 'd', 's', 'o', 'g'];
-
- function _read_single_type(signature, forceSimple) {
-- let char = signature.shift();
-+ let xchar = signature.shift();
- let isSimple = false;
-
-- if (SIMPLE_TYPES.indexOf(char) == -1) {
-+ if (SIMPLE_TYPES.indexOf(xchar) == -1) {
- if (forceSimple)
- throw new TypeError('Invalid GVariant signature (a simple type was expected)');
- } else
- isSimple = true;
-
-- if (char == 'm' || char == 'a')
-- return [char].concat(_read_single_type(signature, false));
-- if (char == '{') {
-+ if (xchar == 'm' || xchar == 'a')
-+ return [xchar].concat(_read_single_type(signature, false));
-+ if (xchar == '{') {
- let key = _read_single_type(signature, true);
- let val = _read_single_type(signature, false);
- let close = signature.shift();
- if (close != '}')
- throw new TypeError('Invalid GVariant signature for type DICT_ENTRY (expected "}"');
-- return [char].concat(key, val, close);
-+ return [xchar].concat(key, val, close);
- }
-- if (char == '(') {
-- let res = [char];
-+ if (xchar == '(') {
-+ let res = [xchar];
- while (true) {
- if (signature.length == 0)
- throw new TypeError('Invalid GVariant signature for type TUPLE (expected ")")');
-@@ -60,10 +60,10 @@ function _read_single_type(signature, fo
- }
-
- // Valid types are simple types, arrays, maybes, tuples, dictionary entries and variants
-- if (!isSimple && char != 'v')
-- throw new TypeError('Invalid GVariant signature (' + char + ' is not a valid type)');
-+ if (!isSimple && xchar != 'v')
-+ throw new TypeError('Invalid GVariant signature (' + xchar + ' is not a valid type)');
-
-- return [char];
-+ return [xchar];
- }
-
-
-@@ -71,8 +71,8 @@ function _pack_variant(signature, value)
- if (signature.length == 0)
- throw new TypeError('GVariant signature cannot be empty');
-
-- let char = signature.shift();
-- switch (char) {
-+ let xchar = signature.shift();
-+ switch (xchar) {
- case 'b':
- return GLib.Variant.new_boolean(value);
- case 'y':
-@@ -160,7 +160,7 @@ function _pack_variant(signature, value)
-
- return GLib.Variant.new_dict_entry(key, child);
- default:
-- throw new TypeError('Invalid GVariant signature (unexpected character ' + char + ')');
-+ throw new TypeError('Invalid GVariant signature (unexpected character ' + xchar + ')');
- }
- }
-
-@@ -258,4 +258,4 @@ function _init() {
- this.Variant.prototype.toString = function() {
- return '[object variant of type "' + this.get_type_string() + '"]';
- }
--}
-\ No newline at end of file
-+}
diff --git a/lang/gjs/pkg-plist b/lang/gjs/pkg-plist
index 83d375c3ae13..a583616dcc2f 100644
--- a/lang/gjs/pkg-plist
+++ b/lang/gjs/pkg-plist
@@ -6,6 +6,7 @@ include/gjs-1.0/gi/closure.h
include/gjs-1.0/gi/enumeration.h
include/gjs-1.0/gi/foreign.h
include/gjs-1.0/gi/function.h
+include/gjs-1.0/gi/fundamental.h
include/gjs-1.0/gi/gerror.h
include/gjs-1.0/gi/gtype.h
include/gjs-1.0/gi/interface.h
@@ -16,59 +17,21 @@ include/gjs-1.0/gi/param.h
include/gjs-1.0/gi/repo.h
include/gjs-1.0/gi/union.h
include/gjs-1.0/gi/value.h
-include/gjs-1.0/gjs-dbus/dbus-proxy.h
-include/gjs-1.0/gjs-dbus/dbus.h
include/gjs-1.0/gjs/byteArray.h
include/gjs-1.0/gjs/compat.h
include/gjs-1.0/gjs/context.h
-include/gjs-1.0/gjs/gjs.h
+include/gjs-1.0/gjs/coverage.h
include/gjs-1.0/gjs/gjs-module.h
+include/gjs-1.0/gjs/gjs.h
include/gjs-1.0/gjs/importer.h
include/gjs-1.0/gjs/jsapi-util.h
include/gjs-1.0/gjs/mem.h
include/gjs-1.0/gjs/native.h
+include/gjs-1.0/gjs/runtime.h
include/gjs-1.0/gjs/type-module.h
-lib/gjs-1.0/cairoNative.la
-lib/gjs-1.0/cairoNative.so
-lib/gjs-1.0/console.la
-lib/gjs-1.0/console.so
-lib/gjs-1.0/dbusNative.la
-lib/gjs-1.0/dbusNative.so
-lib/gjs-1.0/debugger.la
-lib/gjs-1.0/debugger.so
-lib/gjs-1.0/formatNative.la
-lib/gjs-1.0/formatNative.so
-lib/gjs-1.0/gettextNative.la
-lib/gjs-1.0/gettextNative.so
-lib/gjs-1.0/langNative.la
-lib/gjs-1.0/langNative.so
-lib/gjs-1.0/mainloop.la
-lib/gjs-1.0/mainloop.so
-lib/gjs-1.0/system.la
-lib/gjs-1.0/system.so
lib/gjs/girepository-1.0/GjsPrivate-1.0.typelib
-lib/libgjs-dbus.la
-lib/libgjs-dbus.so
-lib/libgjs-dbus.so.0
-lib/libgjs-dbus.so.0.0.0
-lib/libgjs.la
lib/libgjs.so
lib/libgjs.so.0
lib/libgjs.so.0.0.0
libdata/pkgconfig/gjs-1.0.pc
-libdata/pkgconfig/gjs-dbus-1.0.pc
libdata/pkgconfig/gjs-internals-1.0.pc
-share/gjs-1.0/cairo.js
-share/gjs-1.0/dbus.js
-share/gjs-1.0/gettext.js
-share/gjs-1.0/format.js
-share/gjs-1.0/jsUnit.js
-share/gjs-1.0/lang.js
-share/gjs-1.0/overrides/GLib.js
-share/gjs-1.0/overrides/GObject.js
-share/gjs-1.0/overrides/Gio.js
-share/gjs-1.0/promise.js
-share/gjs-1.0/signals.js
-share/gjs-1.0/tweener/equations.js
-share/gjs-1.0/tweener/tweenList.js
-share/gjs-1.0/tweener/tweener.js