aboutsummaryrefslogtreecommitdiff
path: root/lang/gnat-aux/Makefile
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2012-04-09 11:28:22 +0000
committerFrederic Culot <culot@FreeBSD.org>2012-04-09 11:28:22 +0000
commit75934f90db805b44ca329eae42597f9810e2ec82 (patch)
tree26fdbede72473def761fd292530c7098776c440a /lang/gnat-aux/Makefile
parent8e432b60af890fbd01d0004bfc2cc59ce62b9bb8 (diff)
downloadports-75934f90db805b44ca329eae42597f9810e2ec82.tar.gz
ports-75934f90db805b44ca329eae42597f9810e2ec82.zip
Notes
Diffstat (limited to 'lang/gnat-aux/Makefile')
-rw-r--r--lang/gnat-aux/Makefile32
1 files changed, 13 insertions, 19 deletions
diff --git a/lang/gnat-aux/Makefile b/lang/gnat-aux/Makefile
index 6dc86cd6783c..30751ad0683b 100644
--- a/lang/gnat-aux/Makefile
+++ b/lang/gnat-aux/Makefile
@@ -17,27 +17,10 @@ DISTFILES= gcc-core-${GCC_VERSION}.tar.bz2
MAINTAINER= draco@marino.st
COMMENT= GNAT Ada compiler based on GCC ${GCC_BRANCH}
-LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
-LIB_DEPENDS+= mpfr.4:${PORTSDIR}/math/mpfr
-LIB_DEPENDS+= mpc.2:${PORTSDIR}/math/mpc
-
-ONLY_FOR_ARCHS= i386 amd64
-
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_BZIP2= yes
-USE_ICONV= yes
-USE_PERL5_BUILD= yes
-ALL_TARGET= default
-MAKE_JOBS_SAFE= yes
-
-SNAPSHOT= 20111026
-GCC_BRANCH= 4.6
-GCC_POINT= 2
-GCC_VERSION= ${GCC_BRANCH}.${GCC_POINT}
+.include "${.CURDIR}/Makefile.common"
+
LANGS= c
APPLY_DIFFS= core
-
INTENDED_COMPILER= NATIVE
BOOTSTRAP_COMPILER= NOT_REQUIRED
BOOTSTRAP_TRIPLET= NOT_SET
@@ -287,5 +270,16 @@ post-install:
${ECHO_CMD} "@unexec ${RMDIR} %D/include/c++ 2>/dev/null || true" >> ${WRKDIR}/PLIST.lib
cd ${WRKDIR}; ${SED} -i -e "/PLIST.lib/ r PLIST.lib" ${TMPPLIST}
+.if ${OSVERSION} > 900000
+ @${ECHO_MSG} "========================================================"
+ @${ECHO_MSG} " NOTICE REGARDING ADA TASKING ON FREEBSD 9.x:"
+ @${ECHO_MSG} " Due to a new resource check in the threading library"
+ @${ECHO_MSG} " starting with FreeBSD 9.0, an exiting task panics with"
+ @${ECHO_MSG} " the message 'thread exits with resources held!'."
+ @${ECHO_MSG} " Essentially this behavior breaks Ada tasking and 23"
+ @${ECHO_MSG} " ACATS tests fail on FreeBSD 9.x. A solution is being"
+ @${ECHO_MSG} " sought, but the necessary patches will not be trivial."
+ @${ECHO_MSG} "========================================================"
+.endif
.include <bsd.port.post.mk>