aboutsummaryrefslogtreecommitdiff
path: root/lang/gnat-aux
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2013-11-09 22:26:45 +0000
committerJohn Marino <marino@FreeBSD.org>2013-11-09 22:26:45 +0000
commita6b1c69e9169c2ecdaa6d075950a109fdb062207 (patch)
treedc22de73a45730d5090c0574bfee2ae2f3171d8e /lang/gnat-aux
parent5ae4beee9f91f07e6e8201302ed50d2bf29907d5 (diff)
downloadports-a6b1c69e9169c2ecdaa6d075950a109fdb062207.tar.gz
ports-a6b1c69e9169c2ecdaa6d075950a109fdb062207.zip
Notes
Diffstat (limited to 'lang/gnat-aux')
-rw-r--r--lang/gnat-aux/Makefile41
-rw-r--r--lang/gnat-aux/pkg-plist1
2 files changed, 16 insertions, 26 deletions
diff --git a/lang/gnat-aux/Makefile b/lang/gnat-aux/Makefile
index 5cf483c7df2b..d215a08b5168 100644
--- a/lang/gnat-aux/Makefile
+++ b/lang/gnat-aux/Makefile
@@ -13,7 +13,8 @@ DISTFILES= gcc-core-${GCC_VERSION}.tar.bz2
MAINTAINER= marino@FreeBSD.org
COMMENT= GNAT Ada compiler based on GCC ${GCC_BRANCH}
-NO_STAGE= yes
+LICENSE= GPLv3
+
.include "${.CURDIR}/Makefile.common"
LANGS= c
@@ -24,6 +25,8 @@ BOOTSTRAP_TRIPLET= NOT_SET
FULL_GNATGCC= NOT_SET
GARCH= ${ARCH:S/amd64/x86_64/}
OS_LABEL4VERS= [${OPSYS}${GARCH:C,^.*(64),\1,}]
+NO_LICENSES_INSTALL= yes
+NO_MTREE= yes
OPTIONS_DEFINE= ADA CXX FORT OBJC TESTSUITE
OPTIONS_DEFAULT= ADA CXX FORT OBJC
@@ -55,13 +58,8 @@ BUILDDIR= ${WRKDIR}/build
CFG_SCRIPT= ${WRKSRC}/configure
REVFILE= ${WRKSRC}/gcc/REVISION
BOOTSTRAP_PREFIX= ${WRKDIR}/bootstrap
-DESTINY= ${WRKDIR}/destdir
PKG_PREFIX= ${PREFIX}
-USE_LDCONFIG= ${PREFIX}/lib/gcc
-MAN1= gnatcpp.1 gnatgcc.1 gnatgcov.1
-MAN1PREFIX= ${PREFIX}/share
-MAN7PREFIX= ${PREFIX}/share
-NO_MANCOMPRESS= yes
+AWKMANPAGE= '{if ($$0 ~ /^man\/man[1-9]\/.+[1-9]$$/) print $$0 ".gz"; else print $$0}'
# If we find gnatgcc and friends in standard location, then we'll use this
# compiler instead of downloading the bootstrap.
@@ -102,7 +100,6 @@ DISTFILES+= gcc-ada-${GCC_VERSION}.tar.bz2
LANGS+= c++
APPLY_DIFFS+= cxx
DISTFILES+= gcc-g++-${GCC_VERSION}.tar.bz2
-MAN1+= gnatg++.1
.endif
###############
@@ -113,7 +110,6 @@ MAN1+= gnatg++.1
LANGS+= fortran
APPLY_DIFFS+= fortran
DISTFILES+= gcc-fortran-${GCC_VERSION}.tar.bz2
-MAN1+= gnatgfortran.1
QUADOPT= --enable-libquadmath
.else
QUADOPT= --disable-libquadmath
@@ -216,7 +212,7 @@ do-configure:
${CFG_SCRIPT} ${CONFIGURE_ARGS}
do-build:
- cd ${BUILDDIR} && ${SETENV} ${ADA_MAKE_ENV} ${GMAKE} ${_MAKE_JOBS} all
+ cd ${BUILDDIR} && ${SETENV} ${ADA_MAKE_ENV} ${GMAKE} -j${MAKE_JOBS_NUMBER} all
test: build test-ada test-fortran test-objc test-cxx test-c
@@ -247,23 +243,18 @@ test-c:
.endif
do-install:
- cd ${BUILDDIR} && ${SETENV} ${ADA_MAKE_ENV} ${GMAKE} install-strip DESTDIR=${DESTINY}
- ${RM} ${DESTINY}${PREFIX}/lib/libiberty.a
- ${CP} -pR ${DESTINY}${PREFIX}/ ${PREFIX}/
+ cd ${BUILDDIR} && ${SETENV} ${ADA_MAKE_ENV} ${GMAKE} install-strip DESTDIR=${STAGEDIR}
+ ${RM} ${STAGEDIR}${PREFIX}/lib/libiberty.a
post-install:
- ${RM} -f ${WRKDIR}/PLIST.all
- ${RM} -rf ${DESTINY}/man
- ${MV} ${DESTINY}${PREFIX}/share/man ${DESTINY}/
- cd ${DESTINY}; ${FIND} man -type d \
- -exec ${MKDIR} ${DESTINY}${PREFIX}/share/{} \;
- cd ${DESTINY}${PREFIX}; ${FIND} * \( -type f -or -type l \) | \
- ${SORT} >> ${WRKDIR}/PLIST.all
- cd ${DESTINY}${PREFIX}; ${FIND} * -type d | ${SORT} -r | \
- ${SED} -E '/^(bin|sbin|lib|libexec|share)$$/d' | \
- ${SED} -e 's/^/@dirrm /g' >> ${WRKDIR}/PLIST.all
-
- cd ${WRKDIR}; ${SED} -i -e "/PLIST.all/ r PLIST.all" ${TMPPLIST}
+ ${MV} ${STAGEDIR}${PREFIX}/share/man ${STAGEDIR}/${PREFIX}
+ cd ${STAGEDIR}${PREFIX}; ${FIND} * -type d -empty | \
+ ${SORT} -dr | ${XARGS} ${RMDIR}
+ cd ${STAGEDIR}${PREFIX}; ${FIND} * \( -type f -or -type l \) | \
+ ${AWK} ${AWKMANPAGE} | ${SORT} >> ${TMPPLIST}
+ cd ${STAGEDIR}${PREFIX}; ${FIND} * -type d | ${SORT} -r | \
+ ${SED} -E -e '/^(bin|sbin|lib|libexec|share|man|include)$$/d' \
+ -e '/^man\/man[1-9]$$/d' -e 's/^/@dirrm /g' >> ${TMPPLIST}
.if ${OPSYS} == FreeBSD
. if ${OSVERSION} > 900000 && ${OSVERSION} < 900507
@${ECHO_MSG} "===================================================================="
diff --git a/lang/gnat-aux/pkg-plist b/lang/gnat-aux/pkg-plist
deleted file mode 100644
index b85ef4cd295d..000000000000
--- a/lang/gnat-aux/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-@comment PLIST.all attached afterwards (entire PLIST generated)