aboutsummaryrefslogtreecommitdiff
path: root/lang/gnat/Makefile
diff options
context:
space:
mode:
authorDaniel Eischen <deischen@FreeBSD.org>2002-02-10 00:57:45 +0000
committerDaniel Eischen <deischen@FreeBSD.org>2002-02-10 00:57:45 +0000
commit068880021430396650339297afbe6e059c8e6a88 (patch)
tree9fac418121b3c7a1748d46322d8f6ec0f27cf7a8 /lang/gnat/Makefile
parent5eb1bd5f81a1a4aa36a7f8d8f1c800ab7bda85df (diff)
Notes
Diffstat (limited to 'lang/gnat/Makefile')
-rw-r--r--lang/gnat/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/lang/gnat/Makefile b/lang/gnat/Makefile
index 6b257156123c..7a7f6a17a1ec 100644
--- a/lang/gnat/Makefile
+++ b/lang/gnat/Makefile
@@ -138,12 +138,14 @@ pre-patch:
@${ECHO} "===> Making way for FreeBSD GNAT support files"
-( ${RM} -f ${WRKSRC}/ada/[45]f* )
-# Copy any additional files required into the correct locations.
+# Copy any additional files required into the correct locations, and also
+# remove .orig files leftover from patching so they won't get installed.
post-patch:
(cd ${FILESDIR}; \
for i in *.adb *.ads ; do \
${CP} $$i ${WRKSRC}/ada; \
done )
+ ${RM} ${WRKDIR}/gnat-3.14p-src/examples/*.orig
pre-configure:
@(cd ${WRKSRC}/config/${ARCH}/ ; \
@@ -188,9 +190,6 @@ do-build:
${RM} ${WRKSRC}/stamp-gnatlib2
(cd ${WRKSRC}; \
${GMAKE} CFLAGS="${GNATCFLAGS}" GNATLIBCFLAGS="${GNATLIBCFLAGS}" gnatlib )
-.ifndef(NOPORTDOCS)
- ${RM} ${WRKDIR}/gnat-3.14p-src/examples/*.orig
-.endif
do-install:
(cd ${WRKSRC}; \