aboutsummaryrefslogtreecommitdiff
path: root/lang/gnatdroid-armv7/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-03-16 14:36:10 +0000
committerJohn Marino <marino@FreeBSD.org>2016-03-16 14:36:10 +0000
commitf2189c0f299251f922324304f58bb85f4b1d14ca (patch)
tree5e9b4af4f550ec744d78f2278048f1d30742e724 /lang/gnatdroid-armv7/Makefile
parentd3749b069bb3cab343958f79c7b0ab2e153d9623 (diff)
downloadports-f2189c0f299251f922324304f58bb85f4b1d14ca.tar.gz
ports-f2189c0f299251f922324304f58bb85f4b1d14ca.zip
Notes
Diffstat (limited to 'lang/gnatdroid-armv7/Makefile')
-rw-r--r--lang/gnatdroid-armv7/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/lang/gnatdroid-armv7/Makefile b/lang/gnatdroid-armv7/Makefile
index 2c601662485d..6b31aaffeacd 100644
--- a/lang/gnatdroid-armv7/Makefile
+++ b/lang/gnatdroid-armv7/Makefile
@@ -20,14 +20,15 @@ BUILD_DEPENDS= ${SYSROOT}>=19:${PORTSDIR}/lang/${SYSROOT} \
RUN_DEPENDS:= ${BUILD_DEPENDS}
NO_LICENSES_INSTALL= yes
+AUXPORT= gcc6-aux
-.include "${.CURDIR}/../gcc-aux/Makefile.common"
+.include "${.CURDIR}/../${AUXPORT}/Makefile.common"
-USES+= ada:49 gmake
+USES+= ada:6 gmake
LANGS= c c++ ada
APPLY_DIFFS= core ada cxx ada-testsuite
NO_MTREE= YES
-DISTINFO_FILE= ${.CURDIR}/../gcc-aux/distinfo
+DISTINFO_FILE= ${.CURDIR}/../${AUXPORT}/distinfo
OPTIONS_DEFINE= FORT OBJC
OPTIONS_SUB= yes
@@ -45,7 +46,7 @@ BITS= ${GARCH:S/x86_64/64/:S/i386/32/}
OS_LABEL4VERS= [${OPSYS}${BITS} x Android ${CPUVERSION}]
WRKSRC= ${WRKDIR}/${IDENTIFICATION}
BUILD_WRKSRC= ${WRKDIR}/build
-PATCHDIR= ${.CURDIR}/../gcc-aux/files
+PATCHDIR= ${.CURDIR}/../${AUXPORT}/files
CFG_SCRIPT= ${WRKSRC}/configure
REVFILE= ${WRKSRC}/gcc/REVISION
SRPREFIX?= ${LOCALBASE}/android
@@ -89,6 +90,7 @@ ADA_CONFIG_ARGS+= ${ARG_FPU}
ADA_CONFIG_ARGS+= --enable-target-optspace
ADA_CONFIG_ARGS+= --enable-threads=posix
ADA_CONFIG_ARGS+= --enable-cxx-flags=-frtti
+ADA_CONFIG_ARGS+= --enable-checking=release
ADA_CONFIG_ARGS+= --disable-bootstrap
ADA_CONFIG_ARGS+= --disable-shared
ADA_CONFIG_ARGS+= --disable-libssp
@@ -148,12 +150,12 @@ post-stage:
acats: build
(cd ${BUILD_WRKSRC}/gcc && ${SETENV} \
- PATH=${LOCALBASE}/gcc-aux/bin:${PATH}:${PREFIX}/bin \
+ PATH=${LOCALBASE}/${AUXPORT}/bin:${PATH}:${PREFIX}/bin \
${GMAKE} -sk check-acats)
gnatdg: build
(cd ${BUILD_WRKSRC}/gcc && ${SETENV} \
- PATH=${LOCALBASE}/gcc-aux/bin:${PATH}:${PREFIX}/bin \
- ${GMAKE} -sk check-gnat RUNTESTFLAGS=--target_board=gnatdroid)
+ PATH=${LOCALBASE}/${AUXPORT}/bin:${PATH}:${PREFIX}/bin \
+ ${GMAKE} -sk check-gnat RUNTESTFLAGS=--target_board=gnatdroid6)
.include <bsd.port.mk>