aboutsummaryrefslogtreecommitdiff
path: root/lang/gnatdroid-binutils
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-04-06 11:32:56 +0000
committerJohn Marino <marino@FreeBSD.org>2014-04-06 11:32:56 +0000
commit8ad355d86566b13b2b2d6b758bf251126f56c641 (patch)
tree084ae005309d42167e73ce2b5ba0872787ef3d7d /lang/gnatdroid-binutils
parentebfba9aea823ba8b9a843f67b9631a47e4db6ddb (diff)
downloadports-8ad355d86566b13b2b2d6b758bf251126f56c641.tar.gz
ports-8ad355d86566b13b2b2d6b758bf251126f56c641.zip
lang/gnatdroid-*: Update sysroot to Android API level 9 -> level 19
This is the first of two steps to update the gnatdroid ARM cross- compilers. The sysroot was 10 versions behind the current API level of 19. The latest API level drops ARMv5 support, but the API is backwards compatible, so if applications restrict themselves to level 18 features, then ARMv5 should still be usable. The next step is to base the cross compilers on GCC 4.9 instead of the GCC 4.7-based gcc47-aux port.
Notes
Notes: svn path=/head/; revision=350350
Diffstat (limited to 'lang/gnatdroid-binutils')
-rw-r--r--lang/gnatdroid-binutils/Makefile15
-rw-r--r--lang/gnatdroid-binutils/pkg-plist1
2 files changed, 8 insertions, 8 deletions
diff --git a/lang/gnatdroid-binutils/Makefile b/lang/gnatdroid-binutils/Makefile
index 5c6442ae3154..05b8183d754a 100644
--- a/lang/gnatdroid-binutils/Makefile
+++ b/lang/gnatdroid-binutils/Makefile
@@ -3,7 +3,7 @@
PORTNAME= binutils
PORTVERSION= 2.24
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
MASTER_SITE_SUBDIR= binutils/releases
@@ -15,18 +15,19 @@ COMMENT= Infrastructure for C/Ada Android cross-compiler
LICENSE= GPLv3 LGPL3
LICENSE_COMB= multi
-BUILD_DEPENDS= gnatdroid-sysroot>=9:${PORTSDIR}/lang/gnatdroid-sysroot \
+BUILD_DEPENDS= gnatdroid-sysroot=19:${PORTSDIR}/lang/gnatdroid-sysroot \
${LOCALBASE}/lib/libgmp.so:${PORTSDIR}/math/gmp \
${LOCALBASE}/lib/libmpfr.so:${PORTSDIR}/math/mpfr
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= gmake
-USE_BZIP2= YES
-HAS_CONFIGURE= YES
-NO_MTREE= YES
+USES= gmake tar:bzip2
+HAS_CONFIGURE= yes
+NO_MTREE= yes
+
+NO_LICENSES_INSTALL= yes
WRKSRC= ${WRKDIR}/binutils-${PORTVERSION}
-PREFIX= ${LOCALBASE}/android9
+PREFIX= ${LOCALBASE}/android19
BRANCH1= ARMv5
BRANCH2= ARMv7
BR1_PREFIX= ${PREFIX}/${BRANCH1}
diff --git a/lang/gnatdroid-binutils/pkg-plist b/lang/gnatdroid-binutils/pkg-plist
index 70d273aa4f39..3f8ee020efca 100644
--- a/lang/gnatdroid-binutils/pkg-plist
+++ b/lang/gnatdroid-binutils/pkg-plist
@@ -112,4 +112,3 @@
@dirrm %%BRANCH2%%/%%TARGET%%
@dirrm %%BRANCH2%%/bin
@dirrm %%BRANCH2%%
-@dirrmtry share