aboutsummaryrefslogtreecommitdiff
path: root/lang/gnomebasic/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-06-28 16:09:15 +0000
committerAde Lovett <ade@FreeBSD.org>2000-06-28 16:09:15 +0000
commit4f33a6ccab59f1ed5e9cb743bf5f4d667dc4c2a9 (patch)
tree155d42006d861150c98272d4cc0d432000fa6477 /lang/gnomebasic/Makefile
parente71e1fb70f1a5e776a2aaaf83b7e04b18f1a738e (diff)
Gnome Basic is an embryonic attempt to provide VB compatible functionality
for the GNOME project, particularly with respect to office (VBA) compatibility.
Notes
Notes: svn path=/head/; revision=29944
Diffstat (limited to 'lang/gnomebasic/Makefile')
-rw-r--r--lang/gnomebasic/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/lang/gnomebasic/Makefile b/lang/gnomebasic/Makefile
new file mode 100644
index 000000000000..ff48bc2877e6
--- /dev/null
+++ b/lang/gnomebasic/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: gnomebasic
+# Date created: 28th June 2000
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomebasic
+PORTVERSION= 0.0.12
+CATEGORIES= lang gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= unstable/sources/gb
+DISTNAME= gb-${PORTVERSION}
+
+MAINTAINER= ade@FreeBSD.org
+
+LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs
+
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ GLIB_CONFIG="${GLIB_CONFIG}" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>