aboutsummaryrefslogtreecommitdiff
path: root/lang/gnustep-guile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2008-03-23 16:09:01 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2008-03-23 16:09:01 +0000
commit3f94295b9a6c6ed4fa5ddc9a03b440d8206b1775 (patch)
tree4059b3114eabf6670108bcccf2dbb9e9c210569e /lang/gnustep-guile
parentb31beba8fcece40f9054f0e209d4c50992785483 (diff)
downloadports-3f94295b9a6c6ed4fa5ddc9a03b440d8206b1775.tar.gz
ports-3f94295b9a6c6ed4fa5ddc9a03b440d8206b1775.zip
Notes
Diffstat (limited to 'lang/gnustep-guile')
-rw-r--r--lang/gnustep-guile/Makefile8
-rw-r--r--lang/gnustep-guile/files/patch-Library_gg_class.m13
-rw-r--r--lang/gnustep-guile/files/patch-ScriptKit_Library_GuileInterpreter.m26
3 files changed, 8 insertions, 39 deletions
diff --git a/lang/gnustep-guile/Makefile b/lang/gnustep-guile/Makefile
index 5c79cd2d33e1..ca8d6cd9fa7c 100644
--- a/lang/gnustep-guile/Makefile
+++ b/lang/gnustep-guile/Makefile
@@ -34,6 +34,8 @@ PLIST_SUB+= GUILE_VER="${GUILE_VER}"
MAN1= greg.1
+FIXME= Library/gg_class.m ScriptKit/Library/GuileInterpreter.m
+
.if defined(WITHOUT_X11)
NOX11_SUFFIX?= -nox11
USE_GNUSTEP_BASE= yes
@@ -52,6 +54,12 @@ GUILE_VER!= (cd ${PORTSDIR}/lang/guile && make -V GUILE_VER)
post-patch:
${REINPLACE_CMD} -e 's|echo aout|echo elf|' \
${WRKSRC}/Greg/configure
+.for i in ${FIXME}
+ ${REINPLACE_CMD} -e 's|scm_catch_body_t|scm_t_catch_body|' \
+ -e 's|scm_catch_handler_t|scm_t_catch_handler|' \
+ -e 's|scm_intern|scm_c_define|' \
+ ${WRKSRC}/${i}
+.endfor
pre-configure:
${TOUCH} ${WRKSRC}/Greg/ac_nonexistent.h
diff --git a/lang/gnustep-guile/files/patch-Library_gg_class.m b/lang/gnustep-guile/files/patch-Library_gg_class.m
deleted file mode 100644
index e5e4367e6c1a..000000000000
--- a/lang/gnustep-guile/files/patch-Library_gg_class.m
+++ /dev/null
@@ -1,13 +0,0 @@
---- Library/gg_class.m.orig 2008-03-02 14:19:31.000000000 -0500
-+++ Library/gg_class.m 2008-03-02 14:20:22.000000000 -0500
-@@ -414,8 +414,8 @@ gstep_send_msg_to_guile(id rcv, SEL sel,
- data.selname = gh_str02scm((char*)selname);
- data.argslist = argsList;
-
-- val = gh_catch(SCM_BOOL_T, (scm_catch_body_t)proc_wrapper, (void*)&data,
-- (scm_catch_handler_t)proc_error, (void*)procname);
-+ val = gh_catch(SCM_BOOL_T, (scm_t_catch_body)proc_wrapper, (void*)&data,
-+ (scm_t_catch_handler)proc_error, (void*)procname);
-
- /*
- * Now decode the Guile return value into the correct ObjectiveC
diff --git a/lang/gnustep-guile/files/patch-ScriptKit_Library_GuileInterpreter.m b/lang/gnustep-guile/files/patch-ScriptKit_Library_GuileInterpreter.m
deleted file mode 100644
index ec3dd799deae..000000000000
--- a/lang/gnustep-guile/files/patch-ScriptKit_Library_GuileInterpreter.m
+++ /dev/null
@@ -1,26 +0,0 @@
---- ScriptKit/Library/GuileInterpreter.m.orig 2008-03-16 01:31:01.000000000 -0400
-+++ ScriptKit/Library/GuileInterpreter.m 2008-03-16 01:31:26.000000000 -0400
-@@ -349,9 +349,9 @@ add_let_script(NSMutableString * script,
- NS_DURING
- {
- ret = gh_catch (SCM_BOOL_T,
-- (scm_catch_body_t) eval_str_wrapper,
-+ (scm_t_catch_body) eval_str_wrapper,
- c_script,
-- (scm_catch_handler_t) gopenstep_batch_handler,
-+ (scm_t_catch_handler) gopenstep_batch_handler,
- // Pass a script as nsstring to the handler
- script);
- }
-@@ -365,9 +365,9 @@ add_let_script(NSMutableString * script,
- {
- // Only print message
- ret = gh_catch (SCM_BOOL_T,
-- (scm_catch_body_t) eval_str_wrapper,
-+ (scm_t_catch_body) eval_str_wrapper,
- c_script,
-- (scm_catch_handler_t) gopenstep_interactive_handler,
-+ (scm_t_catch_handler) gopenstep_interactive_handler,
- // Pass a script as cstring to the handler
- c_script);
- }