aboutsummaryrefslogtreecommitdiff
path: root/lang/groovy
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2005-02-21 11:21:18 +0000
committerHerve Quiroz <hq@FreeBSD.org>2005-02-21 11:21:18 +0000
commit9d40ec21127a874dea1d9021313262947b8d2c25 (patch)
tree59f128d6605cdf960ed4aa9406929392c926f9bb /lang/groovy
parent801ea5582e882cf1da7aeaa6a7b6bf9068049c37 (diff)
downloadports-9d40ec21127a874dea1d9021313262947b8d2c25.tar.gz
ports-9d40ec21127a874dea1d9021313262947b8d2c25.zip
Notes
Diffstat (limited to 'lang/groovy')
-rw-r--r--lang/groovy/Makefile67
-rw-r--r--lang/groovy/distinfo2
-rw-r--r--lang/groovy/files/set-groovy_home.sed.in3
-rw-r--r--lang/groovy/pkg-descr24
4 files changed, 96 insertions, 0 deletions
diff --git a/lang/groovy/Makefile b/lang/groovy/Makefile
new file mode 100644
index 000000000000..f467f8695a8b
--- /dev/null
+++ b/lang/groovy/Makefile
@@ -0,0 +1,67 @@
+# New ports collection makefile for: groovy
+# Date created: 2005-02-21
+# Whom: Herve Quiroz <hq@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= groovy
+DISTVERSION= 1.0-beta-9
+CATEGORIES= lang java
+MASTER_SITES= http://dist.codehaus.org/groovy/distributions/
+
+MAINTAINER= hq@FreeBSD.org
+COMMENT= Agile dynamic language for the JVM
+
+USE_REINPLACE= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+NO_BUILD= yes
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+DATAFILES= LICENSE.txt conf ${PORTNAME}-${DISTVERSION}.jar lib
+SCRIPTFILES= grok groovy groovyConsole groovyc groovysh
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= changelog-report.html cvs-usage.html dependencies.html \
+ developer-activity-report.html downloads.html faq.html \
+ file-activity-report.html groovy-jdk.html images index.html \
+ issue-tracking.html jdepend-report.html junit-report.html \
+ license.html mail-lists.html maven-reports.html \
+ pmd-report.html project-info.html style team-list.html xref \
+ xref-test
+.endif
+PLIST_FILES= ${SCRIPTFILES:S,^,bin/,}
+SUB_FILES= set-groovy_home.sed
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${PORTNAME}.jar..."
+ @${INSTALL_DATA} ${WRKSRC}/embeddable/${PORTNAME}-all-${DISTVERSION}.jar ${JAVAJARDIR}/${PORTNAME}.jar
+ @${ECHO_MSG} " [ DONE ]"
+ @${ECHO_MSG} -n ">> Installing data files in ${DATADIR}..."
+ @cd ${WRKSRC} \
+ && ${FIND} ${DATAFILES} -type d -exec ${MKDIR} ${DATADIR}/{} \; \
+ && ${FIND} ${DATAFILES} -type f -exec ${INSTALL_DATA} {} ${DATADIR}/{} \;
+ @${ECHO_MSG} " [ DONE ]"
+ @${ECHO_MSG} -n ">> Installing executables in ${PREFIX}/bin..."
+.for file in ${SCRIPTFILES}
+ @${ECHO_MSG} -n " ${file}"
+ @${REINPLACE_CMD} -f ${WRKDIR}/set-groovy_home.sed ${WRKSRC}/bin/${file}
+ @${INSTALL_SCRIPT} ${WRKSRC}/bin/${file} ${PREFIX}/bin/
+.endfor
+ @${ECHO_MSG} " [ DONE ]"
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
+ @cd ${WRKSRC}/docs \
+ && ${FIND} . -type d -exec ${MKDIR} ${DOCSDIR}/{} \; \
+ && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
+ @${ECHO_MSG} " [ DONE ]"
+.endif
+
+post-install:
+ @${FIND} -s ${DATAFILES:S,^,${WRKSRC}/,} -not -type d 2>/dev/null | \
+ ${SED} -ne 's,^${WRKSRC},${DATADIR:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+ @${FIND} -s -d ${DATAFILES:S,^,${WRKSRC}/,} -type d 2>/dev/null | \
+ ${SED} -ne 's,^${WRKSRC},@dirrm ${DATADIR:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+ @${ECHO_CMD} '@dirrm ${DATADIR:S,^${PREFIX}/,,}' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/lang/groovy/distinfo b/lang/groovy/distinfo
new file mode 100644
index 000000000000..ab229eb4b6bb
--- /dev/null
+++ b/lang/groovy/distinfo
@@ -0,0 +1,2 @@
+MD5 (groovy-1.0-beta-9.tar.gz) = 57388024da87033418790d9b3157a3a7
+SIZE (groovy-1.0-beta-9.tar.gz) = 8068150
diff --git a/lang/groovy/files/set-groovy_home.sed.in b/lang/groovy/files/set-groovy_home.sed.in
new file mode 100644
index 000000000000..c29a9e3e00ef
--- /dev/null
+++ b/lang/groovy/files/set-groovy_home.sed.in
@@ -0,0 +1,3 @@
+# $FreeBSD$
+14i\
+GROOVY_HOME=%%DATADIR%%
diff --git a/lang/groovy/pkg-descr b/lang/groovy/pkg-descr
new file mode 100644
index 000000000000..ff70581884f1
--- /dev/null
+++ b/lang/groovy/pkg-descr
@@ -0,0 +1,24 @@
+Groovy is an agile dynamic language for the Java 2 Platform that has many of
+the features that people like so much in languages like Python, Ruby and
+Smalltalk, making them available to Java developers using a Java-like syntax.
+
+Groovy is designed to help you get things done on the Java 2 Platform in a
+quick, concise and fun way. Groovy brings the power of a scripting language
+directly into the Java 2 Platform. For example:
+
+- Shell scripting using Groovy allows the full power of the Java Platform to be
+ brought to bear to the task at hand.
+- Groovy can be used (and indeed is already being used) as a replacement for
+ Java for small and medium sized applications to execute on the Java 2
+ Platform.
+- Groovy can be used as an embedded language for dynamic business rules or
+ extension points utilizing the agility of Groovy and saving the cost of
+ redeploying applications for each change of rule (especially when the rules
+ are stored in a database).
+- Groovy makes writing test cases for unit tests very easy.
+
+As well as being a powerful language for scripting Java objects, Groovy can be
+used as an alternative compiler to javac to generate standard Java bytecode to
+be used by any Java project.
+
+WWW: http://groovy.codehaus.org/