aboutsummaryrefslogtreecommitdiff
path: root/lang/guile/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-19 07:42:17 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-19 07:42:17 +0000
commit5ece18d9ce5eab94fbf6184de9bfb53add9ea578 (patch)
tree871ee621fae73697d8b7913a5f8fd99688b8d9d1 /lang/guile/Makefile
parent217cbb106fcc93c257f9fee269c58812557bca28 (diff)
downloadports-5ece18d9ce5eab94fbf6184de9bfb53add9ea578.tar.gz
ports-5ece18d9ce5eab94fbf6184de9bfb53add9ea578.zip
Notes
Diffstat (limited to 'lang/guile/Makefile')
-rw-r--r--lang/guile/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/lang/guile/Makefile b/lang/guile/Makefile
index 13d82783976f..e367fa7555a0 100644
--- a/lang/guile/Makefile
+++ b/lang/guile/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= guile
-PORTVERSION= 1.4
+PORTVERSION= 1.4.1
CATEGORIES= lang
-MASTER_SITES= ${MASTER_SITE_GNU} \
- ftp://ftp.guile.org/pub/
+MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= guile
MAINTAINER= ports@FreeBSD.org
@@ -21,4 +20,9 @@ CONFIGURE_ARGS= --with-threads
PLIST_SUB= GUILE_VER=${PORTVERSION}
+post-patch:
+ @(cd ${WRKSRC} ; \
+ ${FIND} * -name "*.c" | ${XARGS} ${REINPLACE_CMD} -e \
+ "s|<malloc.h>|<stdlib.h>|g")
+
.include <bsd.port.mk>