aboutsummaryrefslogtreecommitdiff
path: root/lang/haskell-mode.el
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-09-01 17:12:32 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-09-01 17:12:32 +0000
commita80c31a5dda807dcedb2391dc3e2c6f578f8ce3d (patch)
tree821835ef871d8d5f876233f0c9ca25b093d3811d /lang/haskell-mode.el
parent12546f05aa1009108d42460e99796c0ac3cefffa (diff)
downloadports-a80c31a5dda807dcedb2391dc3e2c6f578f8ce3d.tar.gz
ports-a80c31a5dda807dcedb2391dc3e2c6f578f8ce3d.zip
Notes
Diffstat (limited to 'lang/haskell-mode.el')
-rw-r--r--lang/haskell-mode.el/Makefile50
-rw-r--r--lang/haskell-mode.el/distinfo2
-rw-r--r--lang/haskell-mode.el/files/pkg-message.in14
-rw-r--r--lang/haskell-mode.el/pkg-descr9
4 files changed, 0 insertions, 75 deletions
diff --git a/lang/haskell-mode.el/Makefile b/lang/haskell-mode.el/Makefile
deleted file mode 100644
index af551e49414f..000000000000
--- a/lang/haskell-mode.el/Makefile
+++ /dev/null
@@ -1,50 +0,0 @@
-# Created by: Josh Elsasser <jre@vineyard.net>
-# $FreeBSD$
-
-PORTNAME= haskell-mode
-PORTVERSION= 2.9.1
-CATEGORIES= lang elisp
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Emacs lisp mode for editing haskell programs
-
-LICENSE= GPLv3
-
-OPTIONS_DEFINE= DOCS
-
-GH_ACCOUNT= haskell
-GH_COMMIT= 166ec39
-GH_TAGNAME= ${PORTVERSION:S/./_/g}
-NO_BUILD= yes
-PORTDOCS= NEWS fontlock.hs indent.hs README.md
-USE_GITHUB= yes
-
-ELISPDIR= ${PREFIX}/${PLIST_DIRS}
-ELISPFILES= ghc-core.el haskell-align-imports.el haskell-c.el \
- haskell-cabal.el haskell-checkers.el haskell-decl-scan.el \
- haskell-doc.el haskell-font-lock.el haskell-ghci.el \
- haskell-hugs.el haskell-indent.el haskell-indentation.el \
- haskell-interactive-mode.el haskell-mode.el \
- haskell-move-nested.el haskell-navigate-imports.el \
- haskell-package.el haskell-process.el haskell-session.el \
- haskell-show.el haskell-simple-indent.el haskell-site-file.el \
- haskell-sort-imports.el haskell-string.el inf-haskell.el
-
-PLIST_DIRS= share/emacs/site-lisp/${PORTNAME}/
-PLIST_FILES= ${ELISPFILES:C/^| [^ ]/${PLIST_DIRS}/g}
-SUB_FILES= pkg-message
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-do-install:
- @${MKDIR} ${ELISPDIR}
- @${INSTALL_DATA} ${ELISPFILES:S,^,${WRKSRC}/,} ${ELISPDIR}/
-
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
-.endif
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.mk>
diff --git a/lang/haskell-mode.el/distinfo b/lang/haskell-mode.el/distinfo
deleted file mode 100644
index c9c4fda710b7..000000000000
--- a/lang/haskell-mode.el/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (haskell-mode-2.9.1.tar.gz) = 90dd5590162583f099a900f2f71b06625f5e48cdce1b566fc5fd8d248c6f1242
-SIZE (haskell-mode-2.9.1.tar.gz) = 123603
diff --git a/lang/haskell-mode.el/files/pkg-message.in b/lang/haskell-mode.el/files/pkg-message.in
deleted file mode 100644
index 7f063eaca8fa..000000000000
--- a/lang/haskell-mode.el/files/pkg-message.in
+++ /dev/null
@@ -1,14 +0,0 @@
-To use haskell-mode in Emacs, add the following lines to your ~/.emacs:
-
-(load "%%PREFIX%%/share/emacs/site-lisp/haskell-mode/haskell-site-file")
-
-Add the following lines according to which modules you want to use:
-
-(add-hook 'haskell-mode-hook 'turn-on-haskell-doc-mode)
-(add-hook 'haskell-mode-hook 'turn-on-haskell-indentation)
-(add-hook 'haskell-mode-hook 'turn-on-haskell-indent)
-(add-hook 'haskell-mode-hook 'turn-on-haskell-simple-indent)
-(add-hook 'haskell-mode-hook 'font-lock-mode)
-
-Note that the three indentation modules are mutually exclusive - add at
-most one.
diff --git a/lang/haskell-mode.el/pkg-descr b/lang/haskell-mode.el/pkg-descr
deleted file mode 100644
index 0b1f221587e5..000000000000
--- a/lang/haskell-mode.el/pkg-descr
+++ /dev/null
@@ -1,9 +0,0 @@
-Haskell-mode is a major Emacs mode for editing Haskell source code. It
-provides syntax highlighting and automatic indentation and comes with
-inf-haskell which allows interaction with an inferior Haskell interactive
-loop such as the one of Hugs or GHCi.
-
-Note that if you want to use haskell-mode under XEmacs, you should
-install editors/xemacs-packages instead.
-
-WWW: http://projects.haskell.org/haskellmode-emacs/