aboutsummaryrefslogtreecommitdiff
path: root/lang/haskell-mode.el
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2010-12-01 12:55:47 +0000
committerPav Lucistnik <pav@FreeBSD.org>2010-12-01 12:55:47 +0000
commit16807364181ba7831b370112312d72dcb8745e5d (patch)
tree7d7d0340dc35f611fdcd3bee4913ff92babe492f /lang/haskell-mode.el
parentbd82c698df320f33be427687e2b7dacf6c25a302 (diff)
downloadports-16807364181ba7831b370112312d72dcb8745e5d.tar.gz
ports-16807364181ba7831b370112312d72dcb8745e5d.zip
Notes
Diffstat (limited to 'lang/haskell-mode.el')
-rw-r--r--lang/haskell-mode.el/Makefile13
-rw-r--r--lang/haskell-mode.el/distinfo5
-rw-r--r--lang/haskell-mode.el/files/pkg-message.in15
-rw-r--r--lang/haskell-mode.el/pkg-descr19
-rw-r--r--lang/haskell-mode.el/pkg-message24
5 files changed, 30 insertions, 46 deletions
diff --git a/lang/haskell-mode.el/Makefile b/lang/haskell-mode.el/Makefile
index ec128b1de2ff..e665dc6c0051 100644
--- a/lang/haskell-mode.el/Makefile
+++ b/lang/haskell-mode.el/Makefile
@@ -6,25 +6,28 @@
#
PORTNAME= haskell-mode
-PORTVERSION= 2.4
+PORTVERSION= 2.8.0
CATEGORIES= lang elisp
-MASTER_SITES= http://www.iro.umontreal.ca/~monnier/elisp/
+MASTER_SITES= http://projects.haskell.org/haskellmode-emacs/
MAINTAINER= umq@ueo.co.jp
COMMENT= An Emacs lisp mode for editing haskell programs
NO_BUILD= yes
+LICENSE= GPLv3
PORTDOCS= ChangeLog NEWS fontlock.hs indent.hs README
ELISPDIR= ${PREFIX}/${PLIST_DIRS}
-ELISPFILES= haskell-c.el haskell-cabal.el haskell-decl-scan.el \
+ELISPFILES= ghc-core.el haskell-c.el haskell-cabal.el haskell-decl-scan.el \
haskell-doc.el haskell-font-lock.el haskell-ghci.el \
- haskell-hugs.el haskell-indent.el haskell-mode.el \
- haskell-simple-indent.el haskell-site-file.el inf-haskell.el
+ haskell-hugs.el haskell-indent.el haskell-indentation.el \
+ haskell-mode.el haskell-simple-indent.el haskell-site-file.el \
+ inf-haskell.el
PLIST_DIRS= share/emacs/site-lisp/${PORTNAME}/
PLIST_FILES= ${ELISPFILES:C/^| [^ ]/${PLIST_DIRS}/g}
+SUB_FILES= pkg-message
do-install:
@${MKDIR} ${ELISPDIR}
diff --git a/lang/haskell-mode.el/distinfo b/lang/haskell-mode.el/distinfo
index d7dfde5ecec7..1b978b7a3178 100644
--- a/lang/haskell-mode.el/distinfo
+++ b/lang/haskell-mode.el/distinfo
@@ -1,3 +1,2 @@
-MD5 (haskell-mode-2.4.tar.gz) = de5ff32478154a39bea3adb3b7ce0e94
-SHA256 (haskell-mode-2.4.tar.gz) = 8549e4d3540ae105b151e18f963d420c117a06e97d0ff20f5618544e19684de8
-SIZE (haskell-mode-2.4.tar.gz) = 89256
+SHA256 (haskell-mode-2.8.0.tar.gz) = 614dc82977fe5f1b3ecc85a34897409ad6218bee0e1a88611747b1e13b79c580
+SIZE (haskell-mode-2.8.0.tar.gz) = 107284
diff --git a/lang/haskell-mode.el/files/pkg-message.in b/lang/haskell-mode.el/files/pkg-message.in
new file mode 100644
index 000000000000..3a927536cb0a
--- /dev/null
+++ b/lang/haskell-mode.el/files/pkg-message.in
@@ -0,0 +1,15 @@
+To use haskell-mode in Emacs, add the following lines to your ~/.emacs:
+
+(load "%%PREFIX%%/share/emacs/site-lisp/haskell-mode/haskell-site-file")
+
+Add the following lines according to which modules you want to use:
+
+(add-hook 'haskell-mode-hook 'turn-on-haskell-decl-scan)
+(add-hook 'haskell-mode-hook 'turn-on-haskell-doc-mode)
+(add-hook 'haskell-mode-hook 'turn-on-haskell-indentation)
+(add-hook 'haskell-mode-hook 'turn-on-haskell-indent)
+(add-hook 'haskell-mode-hook 'turn-on-haskell-simple-indent)
+(add-hook 'haskell-mode-hook 'turn-on-font-lock)
+
+Note that the three indentation modules are mutually exclusive - add at
+most one.
diff --git a/lang/haskell-mode.el/pkg-descr b/lang/haskell-mode.el/pkg-descr
index b8907056952d..0b1f221587e5 100644
--- a/lang/haskell-mode.el/pkg-descr
+++ b/lang/haskell-mode.el/pkg-descr
@@ -1,18 +1,9 @@
-An Emacs lisp mode for editing haskell programs which is very basic,
-but provides a base on which to build modules. The currently
-supported modules are:
-
- * Font Locking: Colours keywords, comments, strings, etc.
- * Declaration Scanning: Scans declarations and places them in a
- menu.
- * Documentation: Echoes types of functions or syntax of keywords
- when the cursor is idle.
- * Indentation: Provides semi-automatic intelligent indentation.
- * Simple Indentation: Provides simple indentation.
- * Hugs Interaction: Allows interaction with the Hugs interpreter.
- * GHCi Interaction: Allows interaction with the GHCi interpreter.
+Haskell-mode is a major Emacs mode for editing Haskell source code. It
+provides syntax highlighting and automatic indentation and comes with
+inf-haskell which allows interaction with an inferior Haskell interactive
+loop such as the one of Hugs or GHCi.
Note that if you want to use haskell-mode under XEmacs, you should
install editors/xemacs-packages instead.
-WWW: http://www.haskell.org/haskell-mode/
+WWW: http://projects.haskell.org/haskellmode-emacs/
diff --git a/lang/haskell-mode.el/pkg-message b/lang/haskell-mode.el/pkg-message
deleted file mode 100644
index 7cb77833751c..000000000000
--- a/lang/haskell-mode.el/pkg-message
+++ /dev/null
@@ -1,24 +0,0 @@
-To use haskell-mode in Emacs, add the following lines to your ~/.emacs:
-
-(setq auto-mode-alist
- (append auto-mode-alist
- '(("\\.[hg]s$" . haskell-mode)
- ("\\.hi$" . haskell-mode)
- ("\\.l[hg]s$" . literate-haskell-mode))))
-(autoload 'haskell-mode "haskell-mode"
- "Major mode for editing Haskell scripts." t)
-(autoload 'literate-haskell-mode "haskell-mode"
- "Major mode for editing literate Haskell scripts." t)
-
-Add the following lines according to which modules you want to use:
-
-(add-hook 'haskell-mode-hook 'turn-on-haskell-decl-scan)
-(add-hook 'haskell-mode-hook 'turn-on-haskell-doc-mode)
-(add-hook 'haskell-mode-hook 'turn-on-haskell-ghci)
-(add-hook 'haskell-mode-hook 'turn-on-haskell-hugs)
-(add-hook 'haskell-mode-hook 'turn-on-haskell-indent)
-(add-hook 'haskell-mode-hook 'turn-on-haskell-simple-indent)
-(add-hook 'haskell-mode-hook 'turn-on-font-lock)
-
-Note that the two indentation modules are mutually exclusive - add at
-most one.