aboutsummaryrefslogtreecommitdiff
path: root/lang/hiphop-php
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2012-07-18 17:06:02 +0000
committerMartin Matuska <mm@FreeBSD.org>2012-07-18 17:06:02 +0000
commitcf27911206fa29ce8a7254bf122288e71575feef (patch)
tree705693a2fd71e861b54a4ca92b8b55e72d032b8f /lang/hiphop-php
parent0f8d9d9d3f3de0ad81c66b6eb349c3fd49d4a57a (diff)
downloadports-cf27911206fa29ce8a7254bf122288e71575feef.tar.gz
ports-cf27911206fa29ce8a7254bf122288e71575feef.zip
Notes
Diffstat (limited to 'lang/hiphop-php')
-rw-r--r--lang/hiphop-php/Makefile26
-rw-r--r--lang/hiphop-php/files/LICENSE.UNICODE51
-rw-r--r--lang/hiphop-php/pkg-plist5
3 files changed, 73 insertions, 9 deletions
diff --git a/lang/hiphop-php/Makefile b/lang/hiphop-php/Makefile
index 765650eb14b6..6368effb2e48 100644
--- a/lang/hiphop-php/Makefile
+++ b/lang/hiphop-php/Makefile
@@ -1,5 +1,5 @@
# New ports collection makefile for: hiphop
-# Date created: 2012-07-18
+# Date created: 20120712
# Whom: Martin Matuska <mm@FreeBSD.org>
#
# $FreeBSD$
@@ -7,6 +7,7 @@
PORTNAME= hiphop-php
PORTVERSION= 0.0.20120716
+PORTREVISION= 1
CATEGORIES= lang devel www
MASTER_SITES= https://github.com/facebook/hiphop-php/tarball/${GITVERSION}/:main \
http://unicode.org/Public/UNIDATA/:unidata \
@@ -19,6 +20,22 @@ PATCH_SITES= http://cpp.in/dev/
MAINTAINER= mm@FreeBSD.org
COMMENT= Hiphop PHP to C++ code transformer
+LICENSE= PHP301 ZEND200 UNICODE
+LICENSE_COMB= multi
+LICENSE_NAME_UNICODE= Unicode, Inc. License Agreement
+LICENSE_NAME_ZEND200= The Zend Engine License, version 2.00
+LICENSE_FILE_PHP301= ${WRKSRC}/LICENSE.PHP
+LICENSE_FILE_UNICODE= ${FILESDIR}/LICENSE.UNICODE
+LICENSE_FILE_ZEND200= ${WRKSRC}/LICENSE.ZEND
+LICENSE_PERMS_UNICODE= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+LICENSE_PERMS_ZEND200= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+LICENSE_DISTFILES_PHP301= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
+LICENSE_DISTFILES_UNICODE= EastAsianWidth.txt \
+ 8859-1.TXT 8859-2.TXT 8859-3.TXT 8859-4.TXT 8859-5.TXT \
+ 8859-6.TXT 8859-7.TXT 8859-8.TXT 8859-9.TXT 8859-10.TXT \
+ 8859-11.TXT 8859-13.TXT 8859-14.TXT 8859-15.TXT 8859-16.TXT
+LICENSE_DISTFILES_ZEND200= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
+
LIB_DEPENDS= icudata.48:${PORTSDIR}/devel/icu \
boost_thread:${PORTSDIR}/devel/boost-libs \
tbb.4:${PORTSDIR}/devel/tbb \
@@ -122,16 +139,17 @@ post-patch:
@${REINPLACE_CMD} -e 's|%%CFLAGS%%|${_CFLAGS}|g' \
-e 's|%%CXXFLAGS%%|${_CXXFLAGS}|g' \
${WRKSRC}/CMake/HPHPSetup.cmake
+ @${REINPLACE_CMD} -e 's|LICENSE.PHP|src/version|g' \
+ ${WRKSRC}/bin/CMakeLists.base.txt
do-install:
@${MKDIR} ${DATADIR}/bin ${DATADIR}/src
@${FIND} ${WRKSRC} -type f -name '*.orig' -exec ${RM} {} \;
+ @${FIND} ${WRKSRC} -type f -name '*.bak' -exec ${RM} {} \;
@${CP} -R ${WRKSRC}/CMake ${WRKSRC}/bin ${DATADIR}
@${CP} -R ${WRKSRC}/src/runtime ${WRKSRC}/src/system \
${WRKSRC}/src/util ${DATADIR}/src
-.for file in LICENSE.PHP LICENSE.ZEND src/version
- @${INSTALL_DATA} ${WRKSRC}/${file} ${DATADIR}/${file}
-.endfor
+ @${INSTALL_DATA} ${WRKSRC}/src/version ${DATADIR}/src/version
@${INSTALL_PROGRAM} ${WRKSRC}/src/hphp/hphp ${DATADIR}/bin
@${INSTALL_PROGRAM} ${WRKSRC}/src/hphpi/hphpi ${PREFIX}/bin/hphpi
@${INSTALL_SCRIPT} ${WRKDIR}/hphp ${PREFIX}/bin/hphp
diff --git a/lang/hiphop-php/files/LICENSE.UNICODE b/lang/hiphop-php/files/LICENSE.UNICODE
new file mode 100644
index 000000000000..f6af2b5f91b6
--- /dev/null
+++ b/lang/hiphop-php/files/LICENSE.UNICODE
@@ -0,0 +1,51 @@
+UNICODE, INC. LICENSE AGREEMENT - DATA FILES AND SOFTWARE
+
+Unicode Data Files include all data files under the directories
+http://www.unicode.org/Public/, http://www.unicode.org/reports/, and
+http://www.unicode.org/cldr/data/. Unicode Data Files do not include PDF
+online code charts under the directory http://www.unicode.org/Public/.
+Software includes any source code published in the Unicode Standard or
+under the directories http://www.unicode.org/Public/,
+http://www.unicode.org/reports/, and http://www.unicode.org/cldr/data/.
+
+NOTICE TO USER: Carefully read the following legal agreement. BY
+DOWNLOADING, INSTALLING, COPYING OR OTHERWISE USING UNICODE INC.'S DATA
+FILES ("DATA FILES"), AND/OR SOFTWARE ("SOFTWARE"), YOU UNEQUIVOCALLY
+ACCEPT, AND AGREE TO BE BOUND BY, ALL OF THE TERMS AND CONDITIONS OF
+THIS AGREEMENT. IF YOU DO NOT AGREE, DO NOT DOWNLOAD, INSTALL, COPY,
+DISTRIBUTE OR USE THE DATA FILES OR SOFTWARE.
+
+COPYRIGHT AND PERMISSION NOTICE
+
+Copyright © 1991-2012 Unicode, Inc. All rights reserved. Distributed
+under the Terms of Use in http://www.unicode.org/copyright.html.
+
+Permission is hereby granted, free of charge, to any person obtaining a
+copy of the Unicode data files and any associated documentation (the
+"Data Files") or Unicode software and any associated documentation (the
+"Software") to deal in the Data Files or Software without restriction,
+including without limitation the rights to use, copy, modify, merge,
+publish, distribute, and/or sell copies of the Data Files or Software,
+and to permit persons to whom the Data Files or Software are furnished
+to do so, provided that (a) the above copyright notice(s) and this
+permission notice appear with all copies of the Data Files or Software,
+(b) both the above copyright notice(s) and this permission notice appear
+in associated documentation, and (c) there is clear notice in each
+modified Data File or in the Software as well as in the documentation
+associated with the Data File(s) or Software that the data or software
+has been modified.
+
+THE DATA FILES AND SOFTWARE ARE PROVIDED "AS IS", WITHOUT WARRANTY OF
+ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE
+WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN NO EVENT SHALL THE COPYRIGHT
+HOLDER OR HOLDERS INCLUDED IN THIS NOTICE BE LIABLE FOR ANY CLAIM, OR
+ANY SPECIAL INDIRECT OR CONSEQUENTIAL DAMAGES, OR ANY DAMAGES WHATSOEVER
+RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF
+CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
+CONNECTION WITH THE USE OR PERFORMANCE OF THE DATA FILES OR SOFTWARE.
+
+Except as contained in this notice, the name of a copyright holder shall
+not be used in advertising or otherwise to promote the sale, use or
+other dealings in these Data Files or Software without prior written
+authorization of the copyright holder.
diff --git a/lang/hiphop-php/pkg-plist b/lang/hiphop-php/pkg-plist
index 21845fbd8870..7f841bc1c34c 100644
--- a/lang/hiphop-php/pkg-plist
+++ b/lang/hiphop-php/pkg-plist
@@ -10,7 +10,6 @@ bin/hphpi
%%DATADIR%%/CMake/FindLibAfdt.cmake
%%DATADIR%%/CMake/FindLibCh.cmake
%%DATADIR%%/CMake/FindLibEvent.cmake
-%%DATADIR%%/CMake/FindLibEvent.cmake.bak
%%DATADIR%%/CMake/FindLibmemcached.cmake
%%DATADIR%%/CMake/FindLibpam.cmake
%%DATADIR%%/CMake/FindMcrypt.cmake
@@ -21,13 +20,9 @@ bin/hphpi
%%DATADIR%%/CMake/FindReadline.cmake
%%DATADIR%%/CMake/FindTBB.cmake
%%DATADIR%%/CMake/HPHPFindLibs.cmake
-%%DATADIR%%/CMake/HPHPFindLibs.cmake.bak
%%DATADIR%%/CMake/HPHPFunctions.cmake
%%DATADIR%%/CMake/HPHPSetup.cmake
-%%DATADIR%%/CMake/HPHPSetup.cmake.bak
%%DATADIR%%/CMake/Options.cmake
-%%DATADIR%%/LICENSE.PHP
-%%DATADIR%%/LICENSE.ZEND
%%DATADIR%%/bin/CMakeLists.base.txt
%%DATADIR%%/bin/apc_sample_serializer.php
%%DATADIR%%/bin/crutch.php