aboutsummaryrefslogtreecommitdiff
path: root/lang/hiphop-php
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2013-07-26 06:27:15 +0000
committerMartin Matuska <mm@FreeBSD.org>2013-07-26 06:27:15 +0000
commitfe094c1f68e48652d05214b27c637f502c7c3518 (patch)
tree6cad8ef1abb45a5a79353cc0ab1201721b8d0001 /lang/hiphop-php
parent0128c89ce7d8f9b58a6bd112cd85d8d872fe9d97 (diff)
downloadports-fe094c1f68e48652d05214b27c637f502c7c3518.tar.gz
ports-fe094c1f68e48652d05214b27c637f502c7c3518.zip
Notes
Diffstat (limited to 'lang/hiphop-php')
-rw-r--r--lang/hiphop-php/Makefile6
-rw-r--r--lang/hiphop-php/pkg-descr21
2 files changed, 11 insertions, 16 deletions
diff --git a/lang/hiphop-php/Makefile b/lang/hiphop-php/Makefile
index 59cee3834158..c978bf4f08ef 100644
--- a/lang/hiphop-php/Makefile
+++ b/lang/hiphop-php/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hiphop-php
PORTVERSION= 2.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang devel www
MASTER_SITES= https://github.com/facebook/hiphop-php/archive/:main \
http://unicode.org/Public/UNIDATA/:unidata \
@@ -14,7 +14,7 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
PATCH_SITES= http://cpp.in/dev/
MAINTAINER= mm@FreeBSD.org
-COMMENT= Hiphop PHP to C++ code transformer
+COMMENT= HipHop Virtual Machine for PHP
LICENSE= PHP301 ZEND200 UNICODE
LICENSE_COMB= multi
@@ -62,7 +62,7 @@ BUILD_DEPENDS+= bison:${PORTSDIR}/devel/bison \
${LOCALBASE}/${_EXTDIR}/lib/libcurl.a:${PORTSDIR}/ftp/curl-hiphop \
${LOCALBASE}/lib/libdwarf.a:${PORTSDIR}/devel/libdwarf
-WRKSRC= ${WRKDIR}/${PORTNAME}-HPHP-${PORTVERSION}
+WRKSRC= ${WRKDIR}/hiphop-php-HPHP-${PORTVERSION}
GNU_CONFIGURE= yes
USES= cmake gettext
diff --git a/lang/hiphop-php/pkg-descr b/lang/hiphop-php/pkg-descr
index 414c2cb7e733..90c585d1c346 100644
--- a/lang/hiphop-php/pkg-descr
+++ b/lang/hiphop-php/pkg-descr
@@ -1,15 +1,10 @@
-From the HipHop Homepage:
-
-HipHop transforms your PHP source code into highly optimized C++ and then
-compiles it with g++ to build binary files. You keep coding in simpler PHP,
-then HipHop executes your source code in a semantically equivalent manner and
-sacrifices some rarely used features - such as eval() - in exchange for
-improved performance.
-
-HipHop was developed by Facebook and was released as open source in early 2010.
-
-Facebook sees about a 50% reduction in CPU usage when serving equal amounts
-of Web traffic when compared to Apache and PHP. Facebook.s API tier can serve
-twice the traffic using 30% less CPU.
+HipHop VM (HHVM) is a new open-source virtual machine designed for executing
+programs written in PHP. HHVM uses a just-in-time compilation approach to
+achieve superior performance while maintaining the flexibility that PHP
+developers are accustomed to. HipHop VM (and before it HPHPc) has realized
+a > 5x increase in throughput for Facebook compared with Zend PHP 5.2.
+
+HipHop VM is most commonly run as a standalone server, replacing both Apache
+and mod_php.
WWW: https://github.com/facebook/hiphop-php/wiki