aboutsummaryrefslogtreecommitdiff
path: root/lang/icc7
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-01-05 20:36:33 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-01-05 20:36:33 +0000
commit41d8c3385c21ae51629c8997035eae8a9423ff6c (patch)
tree246d960cb714ce0095c452017819f6b1c64a7dfb /lang/icc7
parent5e3b0872db18497aacc353b3ef94ad8dac11183f (diff)
downloadports-41d8c3385c21ae51629c8997035eae8a9423ff6c.tar.gz
ports-41d8c3385c21ae51629c8997035eae8a9423ff6c.zip
Notes
Diffstat (limited to 'lang/icc7')
-rw-r--r--lang/icc7/Makefile25
-rw-r--r--lang/icc7/pkg-plist3
2 files changed, 0 insertions, 28 deletions
diff --git a/lang/icc7/Makefile b/lang/icc7/Makefile
index da6428d43d8f..8ec353b5d9e2 100644
--- a/lang/icc7/Makefile
+++ b/lang/icc7/Makefile
@@ -45,12 +45,6 @@ EXTRACT_AFTER_ARGS= | tar -xf - \
ICCCFGVAL!= ${UNAME} -r | ${SED} -e 's/\..*//'
-.if ( ${OSVERSION} < 502108 )
-PLIST_SUB+= STDARG_H="" SYS_CDEFS_H=""
-.else
-PLIST_SUB+= STDARG_H="@comment " SYS_CDEFS_H="@comment "
-.endif
-
.for file in ${DISTNAME}
.if !exists(${DISTDIR}/${DIST_SUBDIR}/${file}${EXTRACT_SUFX})
IGNORE= "Go to Intel Premier Support, https://premier.intel.com, to obtain ${DISTFILES}. Product updates such as this compiler are posted regularly on Premier Support. You must have a license to obtain access to Premier Support. If you do not already have a license go to ${ICC_SITE} to review licensing options \(evaluation, commercial, and free non-commercial\) and obtain a license. Put ${DISTFILES} into ${DISTDIR} and run make again"
@@ -107,42 +101,23 @@ post-patch:
@${REINPLACE_CMD} -i "" -e 's:-Xlinker -rpath -Xlinker <INSTALLDIR>/${COMPILERDIR}/ia32/lib::g' \
${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
@${ECHO_CMD} -e "-Qlocation,ld,${PREFIX}/intel/${COMPILERDIR}/ia32/bin/ldwrapper\n\n-wr1125\n-we140\n\n-Ulinux\n-U__linux__\n-U__linux\n-U__gnu_linux__\n\n-D__FreeBSD__=${ICCCFGVAL}\n-D__ELF__=1\n" >>${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
-.if ( ${OSVERSION} >= 500039 )
@${ECHO_CMD} -e "-D__wchar_t=__ct_rune_t\n" >>${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
-.endif
-.if ( ${OSVERSION} >= 502108 )
@${ECHO_CMD} -e "-restrict\n" >>${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
-.endif
@${CHMOD} a-x,g-w ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
.endfor
# C++ hack for icpc
@${ECHO_CMD} -e "\n-I${PREFIX}/include/stlport\n-Qoption,ld,-CPLUSPLUS\n" >>${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/icpc.cfg
@cd ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/ && ${LN} -s icc.cfg iccbin.cfg && ${LN} -s icpc.cfg icpcbin.cfg
-# Hack while there's no support for icc in the stdarg.h of FreeBSD.
-.if ( ${OSVERSION} < 502108 )
- @${CP} ${FILESDIR}/stdarg.h ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/include
-.else
@${RM} -rf ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/include/sys
-.endif
-.if ( ${OSVERSION} >= 500042 )
OBJCOPY_OPS= --redefine-sym stdin=__stdinp \
--redefine-sym stdout=__stdoutp \
--redefine-sym stderr=__stderrp
-.endif
do-build:
# Fix unresolved references
@cd ${WRKSRC} && ${CC} ${CFLAGS} -c ${FILESDIR}/assert_fail.c \
${FILESDIR}/errno_location.c ${FILESDIR}/mcount.S
-.if ( ${OSVERSION} < 502101 )
- @cd ${WRKSRC} && ${CC} ${CFLAGS} -c ${FILESDIR}/cxa_atexit.c
-.endif
-.if ( ${OSVERSION} < 500042 )
- @${CC} ${CFLAGS} -c -o ${WRKSRC}/stdin.o ${FILESDIR}/stdin.c
- @${CC} ${CFLAGS} -c -o ${WRKSRC}/stdout.o ${FILESDIR}/stdout.c
- @${CC} ${CFLAGS} -c -o ${WRKSRC}/stderr.o ${FILESDIR}/stderr.c
-.endif
.for i in libcxa.a libimf.a libirc.a libircmt.a libunwind.a
@${OBJCOPY} --redefine-sym __sigsetjmp=sigsetjmp \
${OBJCOPY_OPS} \
diff --git a/lang/icc7/pkg-plist b/lang/icc7/pkg-plist
index c52cc5ba4f03..715a18422517 100644
--- a/lang/icc7/pkg-plist
+++ b/lang/icc7/pkg-plist
@@ -1124,9 +1124,6 @@ intel/%%COMPILERDIR%%/ia32/include/pgouser.h
intel/%%COMPILERDIR%%/ia32/include/pmmintrin.h
intel/%%COMPILERDIR%%/ia32/include/proto.h
intel/%%COMPILERDIR%%/ia32/include/sse2mmx.h
-%%STDARG_H%%intel/%%COMPILERDIR%%/ia32/include/stdarg.h
-%%SYS_CDEFS_H%%intel/%%COMPILERDIR%%/ia32/include/sys/cdefs.h
-%%SYS_CDEFS_H%%@dirrm intel/%%COMPILERDIR%%/ia32/include/sys
intel/%%COMPILERDIR%%/ia32/include/typeinfo
intel/%%COMPILERDIR%%/ia32/include/xmmintrin.h
intel/%%COMPILERDIR%%/ia32/include/xmtx.h