aboutsummaryrefslogtreecommitdiff
path: root/lang/icc7
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2004-03-13 10:33:18 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2004-03-13 10:33:18 +0000
commitbaa8612f1ddaa3e387fadb28ca60660b05f7042a (patch)
treead4a6c797a9629a1f665788d26f3d2ec8bd9fc8e /lang/icc7
parent2c8ba2f7ff0a340b70e33f8b558429876e4ece13 (diff)
downloadports-baa8612f1ddaa3e387fadb28ca60660b05f7042a.tar.gz
ports-baa8612f1ddaa3e387fadb28ca60660b05f7042a.zip
Notes
Diffstat (limited to 'lang/icc7')
-rw-r--r--lang/icc7/Makefile20
-rw-r--r--lang/icc7/files/stdarg.h4
-rw-r--r--lang/icc7/pkg-plist8
3 files changed, 23 insertions, 9 deletions
diff --git a/lang/icc7/Makefile b/lang/icc7/Makefile
index 824856ecae56..248a0542e248 100644
--- a/lang/icc7/Makefile
+++ b/lang/icc7/Makefile
@@ -7,7 +7,7 @@
PORTNAME= icc7
PORTVERSION= 7.1.035
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang linux devel
MASTER_SITES=
DISTNAME= l_cc_pc_${PORTVERSION}
@@ -27,7 +27,6 @@ CONFLICTS= linux_devtools* ifc*
USE_LINUX= yes
USE_REINPLACE= yes
-USE_SIZE= yes
NO_WRKSUBDIR= yes
NO_FILTER_SHLIBS= yes
@@ -50,7 +49,11 @@ EXTRACT_AFTER_ARGS= | tar -xf - \
ICCCFGVAL!= ${UNAME} -r | ${SED} -e 's/\..*//'
-OBJCOPY?= /usr/bin/objcopy
+.if ( ${OSVERSION} < 502108 )
+PLIST_SUB+= STDARG_H="" SYS_CDEFS_H=""
+.else
+PLIST_SUB+= STDARG_H="@comment " SYS_CDEFS_H="@comment "
+.endif
.for file in ${DISTNAME}
.if !exists(${DISTDIR}/${DIST_SUBDIR}/${file}${EXTRACT_SUFX})
@@ -90,7 +93,7 @@ pre-patch:
@${CHMOD} a-x ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/Errormatch.txt
# Use the Linux ABI for the binaries
.for i in iccbin iccfilt icid icpcbin icpi mcpcom profmerge proforder xiar xild
- @brandelf -t Linux ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
+ @${BRANDELF} -t Linux ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
.endfor
post-patch:
@@ -112,16 +115,23 @@ post-patch:
@${REINPLACE_CMD} -i "" -e 's:-Xlinker -rpath -Xlinker <INSTALLDIR>/${COMPILERDIR}/ia32/lib::g' \
${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
@${ECHO_CMD} -e "-Qlocation,ld,${PREFIX}/intel/${COMPILERDIR}/ia32/bin/ldwrapper\n\n-wr1125\n-we140\n\n-Ulinux\n-U__linux__\n-U__linux\n-U__gnu_linux__\n\n-D__FreeBSD__=${ICCCFGVAL}\n-D__ELF__=1\n" >>${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
-.if ${OSVERSION} >= 500039
+.if ( ${OSVERSION} >= 500039 )
@${ECHO_CMD} -e "-D__wchar_t=__ct_rune_t\n" >>${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
.endif
+.if ( ${OSVERSION} >= 502108 )
+ @${ECHO_CMD} -e "-restrict\n" >>${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
+.endif
@${CHMOD} a-x,g-w ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
.endfor
# C++ hack for icpc
@${ECHO_CMD} -e "\n-I${PREFIX}/include/stlport\n-Qoption,ld,-CPLUSPLUS\n" >>${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/icpc.cfg
@cd ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/ && ${LN} -s icc.cfg iccbin.cfg && ${LN} -s icpc.cfg icpcbin.cfg
# Hack while there's no support for icc in the stdarg.h of FreeBSD.
+.if ( ${OSVERSION} < 502108 )
@${CP} ${FILESDIR}/stdarg.h ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/include
+.else
+ @${RM} -rf ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/include/sys
+.endif
.if ( ${OSVERSION} >= 470101 && ${OSVERSION} < 500000 ) || \
( ${OSVERSION} >= 500042 )
diff --git a/lang/icc7/files/stdarg.h b/lang/icc7/files/stdarg.h
index c1d8b38de58c..e2f40091f821 100644
--- a/lang/icc7/files/stdarg.h
+++ b/lang/icc7/files/stdarg.h
@@ -1,3 +1,5 @@
+#ifndef __INTEL_COMPILER_STDARG_H_
+#define __INTEL_COMPILER_STDARG_H_
#include_next <stdarg.h>
@@ -7,3 +9,5 @@
#define va_copy(dest, src) ((dest) = (src))
#endif
#endif
+
+#endif /* !__INTEL_COMPILER_STDARG_H_ */
diff --git a/lang/icc7/pkg-plist b/lang/icc7/pkg-plist
index 67426a5a00ab..4965911ad588 100644
--- a/lang/icc7/pkg-plist
+++ b/lang/icc7/pkg-plist
@@ -1124,9 +1124,9 @@ intel/%%COMPILERDIR%%/ia32/include/pgouser.h
intel/%%COMPILERDIR%%/ia32/include/pmmintrin.h
intel/%%COMPILERDIR%%/ia32/include/proto.h
intel/%%COMPILERDIR%%/ia32/include/sse2mmx.h
-intel/%%COMPILERDIR%%/ia32/include/stdarg.h
-intel/%%COMPILERDIR%%/ia32/include/sys/cdefs.h
-@dirrm intel/%%COMPILERDIR%%/ia32/include/sys
+%%STDARG_H%%intel/%%COMPILERDIR%%/ia32/include/stdarg.h
+%%SYS_CDEFS_H%%intel/%%COMPILERDIR%%/ia32/include/sys/cdefs.h
+%%SYS_CDEFS_H%%@dirrm intel/%%COMPILERDIR%%/ia32/include/sys
intel/%%COMPILERDIR%%/ia32/include/typeinfo
intel/%%COMPILERDIR%%/ia32/include/xmmintrin.h
intel/%%COMPILERDIR%%/ia32/include/xmtx.h
@@ -1354,5 +1354,5 @@ intel/%%COMPILERDIR%%/ia32/lib/libunwind.a
%%PORTDOCS%%@dirrm intel/%%COMPILERDIR%%/training/templ_im
%%PORTDOCS%%@dirrm intel/%%COMPILERDIR%%/training
@dirrm intel/%%COMPILERDIR%%
-@unexec rmdir %D/intel/licenses >/dev/null 2>&1 || echo '*** license directory (%D/intel/licenses/) not removed, it may contain a license'
+@unexec rmdir %D/intel/licenses >/dev/null 2>&1 || echo '*** License directory (%D/intel/licenses/) not removed, it may contain a license.'
@unexec rmdir %D/intel >/dev/null 2>&1 || true