aboutsummaryrefslogtreecommitdiff
path: root/lang/icc
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2004-05-07 11:54:55 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2004-05-07 11:54:55 +0000
commit453e18e24e909a8d0118bd18ce8023667c30e00b (patch)
tree142612ede5f0c14c878405a4479fc3a6912d9e10 /lang/icc
parent9e82039785b1ec299cb6075e27765299734e948f (diff)
downloadports-453e18e24e909a8d0118bd18ce8023667c30e00b.tar.gz
ports-453e18e24e909a8d0118bd18ce8023667c30e00b.zip
Notes
Diffstat (limited to 'lang/icc')
-rw-r--r--lang/icc/Makefile1
-rw-r--r--lang/icc/files/ld.c4
2 files changed, 4 insertions, 1 deletions
diff --git a/lang/icc/Makefile b/lang/icc/Makefile
index ea9557e1e9bd..5a8df6113e98 100644
--- a/lang/icc/Makefile
+++ b/lang/icc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= icc
PORTVERSION= 8.0.066
+PORTREVISION= 1
CATEGORIES= lang linux devel
MASTER_SITES=
DISTNAME= l_cc_pc_${PORTVERSION:C/\.p.+$//}
diff --git a/lang/icc/files/ld.c b/lang/icc/files/ld.c
index 66420cebfeae..2f135697e1d5 100644
--- a/lang/icc/files/ld.c
+++ b/lang/icc/files/ld.c
@@ -184,7 +184,9 @@ main(int argc, char *argv[], char *envp[])
for (i = 0; i < argc; i++) {
if (ARGCMP(i, "-CPLUSPLUS") || ARGCMP(i, "-MT") ||
- ARGCMP(i, "-PIC"))
+ ARGCMP(i, "-PIC") ||
+ (ARGCMP(i, "-m") && i<argc-1 && ARGCMP(i+1, "elf_i386")) ||
+ (ARGCMP(i, "elf_i386") && i != 0 && ARGCMP(i-1, "-m")))
continue;
/* prepend "-melf_i386" to the commandline */