aboutsummaryrefslogtreecommitdiff
path: root/lang/intercal
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2006-10-08 22:04:47 +0000
committerStanislav Sedov <stas@FreeBSD.org>2006-10-08 22:04:47 +0000
commit3a9d54a05ea0f1620a2aacab387758ddeb171ec2 (patch)
tree866d4590063ef45aad82b5e985381d815d58bb06 /lang/intercal
parent937da00324acc6473c020869f0e01365c0ec1632 (diff)
downloadports-3a9d54a05ea0f1620a2aacab387758ddeb171ec2.tar.gz
ports-3a9d54a05ea0f1620a2aacab387758ddeb171ec2.zip
Notes
Diffstat (limited to 'lang/intercal')
-rw-r--r--lang/intercal/Makefile10
-rw-r--r--lang/intercal/files/patch-perpetrate.c31
2 files changed, 40 insertions, 1 deletions
diff --git a/lang/intercal/Makefile b/lang/intercal/Makefile
index 9cf631b069ab..0ad85d971c04 100644
--- a/lang/intercal/Makefile
+++ b/lang/intercal/Makefile
@@ -7,14 +7,22 @@
PORTNAME= intercal
PORTVERSION= 0.24
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://www.catb.org/~esr/intercal/
-MAINTAINER= ssedov@mbsd.msk.ru
+MAINTAINER= stas@FreeBSD.org
COMMENT= The C-INTERCAL compiler, ick, and supporting libraries
GNU_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS} -D_POSIX_SOURCE"
+post-patch:
+#
+# Respect PREFIX
+#
+ @${REINPLACE_CMD} -E -e "s,/usr/local,${PREFIX},g" \
+ ${WRKSRC}/perpetrate.c
+
.include <bsd.port.mk>
diff --git a/lang/intercal/files/patch-perpetrate.c b/lang/intercal/files/patch-perpetrate.c
new file mode 100644
index 000000000000..0995780edb0c
--- /dev/null
+++ b/lang/intercal/files/patch-perpetrate.c
@@ -0,0 +1,31 @@
+--- perpetrate.c.orig Sun Mar 9 03:24:35 2003
++++ perpetrate.c Mon Oct 9 01:56:53 2006
+@@ -125,7 +125,7 @@
+ tuple *tp;
+ atom *op;
+ int c, i;
+- char *includedir, *libdir, *getenv();
++ char *includedir, *libdir, *loclibdir, *getenv();
+ FILE *ifp, *ofp;
+ int maxabstain, nextcount, bugline;
+ bool needsyslib, firstfile;
+@@ -136,6 +136,8 @@
+ libdir = ICKLIBDIR;
+ if (!(compiler = getenv("CC")))
+ compiler = CC;
++
++ loclibdir = "/usr/local/lib";
+
+ while ((c = getopt(argc, argv, "bcdtOC@")) != EOF)
+ {
+@@ -498,8 +500,8 @@
+ if (!compile_only)
+ {
+ (void) sprintf(buf2,
+- "%s %s -I%s -L%s -lick -o %s",
+- compiler, buf, includedir, libdir,
++ "%s %s -I%s -L%s -L%s -lick -o %s",
++ compiler, buf, includedir, libdir, loclibdir,
+ argv[optind]);
+ (void) system(buf2);
+ (void) unlink(buf);