aboutsummaryrefslogtreecommitdiff
path: root/lang/io/Makefile
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-04-06 19:47:16 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-04-06 19:47:16 +0000
commit85cdc704743756c2966a53a7ccc6f77d359809e7 (patch)
tree48879f9b3fb4a7b68b0728fa1c77e699098a6547 /lang/io/Makefile
parentce85feeed07f9e011b27a2509dd9eca1ed84b860 (diff)
downloadports-85cdc704743756c2966a53a7ccc6f77d359809e7.tar.gz
ports-85cdc704743756c2966a53a7ccc6f77d359809e7.zip
Notes
Diffstat (limited to 'lang/io/Makefile')
-rw-r--r--lang/io/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/lang/io/Makefile b/lang/io/Makefile
index d975cc4199ed..3b19a526f047 100644
--- a/lang/io/Makefile
+++ b/lang/io/Makefile
@@ -11,11 +11,10 @@ COMMENT= Small prototype-based programming language
LICENSE= BSD3CLAUSE
-CONFLICTS= io-devel-[0-9]*
-
BROKEN_armv6= fails to compile: ucontext.h: expected parameter declarator
BROKEN_armv7= fails to compile: Coro.c:392:2: no member named 'arm_r0' in 'mcontext_t'
-BROKEN_powerpc64= fails to build: unrecognized command line option -msse2
+
+CONFLICTS= io-devel-[0-9]*
USES= cmake:noninja compiler:c11 ssl
@@ -34,6 +33,13 @@ OPTIONS_SUB= yes
.include "${.CURDIR}/Makefile.addons"
+.include <bsd.port.pre.mk>
+
+# disable sse on non-x86 archs
+.if ${ARCH} != amd64 && ${ARCH} != i386
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-CMakeLists.txt
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's/^[ ]*add_subdirectory/#&/' \
${WRKSRC}/addons/CMakeLists.txt
@@ -61,4 +67,4 @@ do-test:
cd ${BUILD_WRKSRC} && \
./_build/binaries/io ${WRKSRC}/libs/iovm/tests/correctness/run.io
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>