aboutsummaryrefslogtreecommitdiff
path: root/lang/itcl/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-12-26 14:19:04 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-12-26 14:19:04 +0000
commit35fa93e4edc58b1ecc4ad1ad17948772d5092971 (patch)
tree027e5f50ec8f47e2b556be8f84d38c0187d2cfe3 /lang/itcl/Makefile
parenta567364f441931b5f88a66956ad7936c55daa896 (diff)
Updates to use tcl84.
Bump PORTREVISION and add tcl84 to CATEGORIES. PR: N/A (direct mail) Submitted by: Pedro F. Giffuni <giffunip (at) yahoo.com>
Notes
Notes: svn path=/head/; revision=152104
Diffstat (limited to 'lang/itcl/Makefile')
-rw-r--r--lang/itcl/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/lang/itcl/Makefile b/lang/itcl/Makefile
index 172364d17076..4943bd12fede 100644
--- a/lang/itcl/Makefile
+++ b/lang/itcl/Makefile
@@ -7,7 +7,8 @@
PORTNAME= itcl
PORTVERSION= ${MAJOR}.${MINOR}.1
-CATEGORIES= lang
+PORTREVISION= 1
+CATEGORIES= lang tcl84
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=incrtcl
DISTNAME= itcl${PORTVERSION}
@@ -16,13 +17,13 @@ EXTRACT_SUFX= _src.tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= [incr Tcl] (A.K.A. "itcl")
-LIB_DEPENDS= tcl83:${PORTSDIR}/lang/tcl83
+LIB_DEPENDS= tcl84:${PORTSDIR}/lang/tcl84
WRKSRC= ${WRKDIR}/${DISTNAME}/itcl
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
-PKGINSTALL= ${PORTSDIR}/lang/tcl83/pkg-install.tclsh
-PKGDEINSTALL= ${PORTSDIR}/lang/tcl83/pkg-deinstall.tclsh
+PKGINSTALL= ${PORTSDIR}/lang/tcl84/pkg-install.tclsh
+PKGDEINSTALL= ${PORTSDIR}/lang/tcl84/pkg-deinstall.tclsh
MAKE_ENV+= ${PLIST_SUB} \
SHLIB_MAJOR=${SHLIB_MAJOR} SHLIB_MINOR=${SHLIB_MINOR}
@@ -54,7 +55,7 @@ post-patch:
post-build test:
cd ${WRKSRC} && ${SETENV} ITCL_LIBRARY=${WRKSRC}/library \
- ${PREFIX}/bin/tclsh8.3 tests/all.tcl
+ ${PREFIX}/bin/tclsh8.4 tests/all.tcl
post-install:
${INSTALL_DATA} ${WRKSRC}/doc/*.n ${PREFIX}/man/mann/