aboutsummaryrefslogtreecommitdiff
path: root/lang/itcl4
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-08-29 14:32:18 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-08-29 14:32:18 +0000
commit782b56aef84c4a09c19108124bbbf0b174cb9552 (patch)
treef965ecffcdb645ac8af80787c1d67d947487ec6f /lang/itcl4
parenta9b944817b54efc0ba94603c1440f44b86ff3fbb (diff)
downloadports-782b56aef84c4a09c19108124bbbf0b174cb9552.tar.gz
ports-782b56aef84c4a09c19108124bbbf0b174cb9552.zip
Notes
Diffstat (limited to 'lang/itcl4')
-rw-r--r--lang/itcl4/Makefile20
-rw-r--r--lang/itcl4/distinfo2
-rw-r--r--lang/itcl4/files/patch-Makefile.in27
-rw-r--r--lang/itcl4/pkg-descr5
-rw-r--r--lang/itcl4/pkg-plist33
5 files changed, 87 insertions, 0 deletions
diff --git a/lang/itcl4/Makefile b/lang/itcl4/Makefile
new file mode 100644
index 000000000000..1edbb88eeca1
--- /dev/null
+++ b/lang/itcl4/Makefile
@@ -0,0 +1,20 @@
+# Created by: gahr
+# $FreeBSD$
+
+PORTNAME= itcl4
+PORTVERSION= 4.0.1
+CATEGORIES= lang
+MASTER_SITES= SF/incrtcl/%5Bincr%20Tcl_Tk%5D-4-source/itcl%20${PORTVERSION}/
+DISTNAME= itcl${PORTVERSION}
+
+MAINTAINER= tcltk@FreeBSD.org
+COMMENT= Object-oriented extension to Tcl [incr Tcl]
+
+USES+= tcl:86
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-tcl=${TCL_LIBDIR} \
+ --with-tclinclude=${TCL_INCLUDEDIR} \
+ --includedir=${PREFIX}/include/itcl${PORTVERSION:R}
+PLIST_SUB+= PKGVER=${PORTVERSION}
+
+.include <bsd.port.mk>
diff --git a/lang/itcl4/distinfo b/lang/itcl4/distinfo
new file mode 100644
index 000000000000..e1fd5a09b54c
--- /dev/null
+++ b/lang/itcl4/distinfo
@@ -0,0 +1,2 @@
+SHA256 (itcl4.0.1.tar.gz) = d0a844bc4998a329fb2457f4a1838afb1261bfd27e3f373346e3379a253a6372
+SIZE (itcl4.0.1.tar.gz) = 434455
diff --git a/lang/itcl4/files/patch-Makefile.in b/lang/itcl4/files/patch-Makefile.in
new file mode 100644
index 000000000000..f1f824d3fbb9
--- /dev/null
+++ b/lang/itcl4/files/patch-Makefile.in
@@ -0,0 +1,27 @@
+--- Makefile.in.orig 2014-08-02 18:11:59.564717000 +0200
++++ Makefile.in 2014-08-29 16:09:56.000000000 +0200
+@@ -93,7 +93,7 @@
+ INSTALL_PROGRAM = ${INSTALL} -m 755
+ INSTALL_DATA = ${INSTALL} -m 644
+ INSTALL_SCRIPT = ${INSTALL_PROGRAM}
+-INSTALL_LIBRARY = ${INSTALL_DATA}
++INSTALL_LIBRARY = ${INSTALL_DATA} -s
+
+ PACKAGE_NAME = @PACKAGE_NAME@
+ PACKAGE_VERSION = @PACKAGE_VERSION@
+@@ -222,11 +222,12 @@
+ @$(INSTALL_DATA_DIR) $(DESTDIR)$(mandir)/mann
+ @echo "Installing documentation in $(DESTDIR)$(mandir)"
+ @cd $(srcdir)/doc; for i in *.n; do \
++ sfxname=`basename $$i | sed -e 's|.n$$|.i4|'`; \
+ echo "Installing $$i"; \
+- rm -f $(DESTDIR)$(mandir)/mann/`basename $$i`; \
++ rm -f $(DESTDIR)$(mandir)/mann/$$sfxname; \
+ sed -e '/man\.macros/r man.macros' -e '/man\.macros/d' \
+- $$i > $(DESTDIR)$(mandir)/mann/$$i; \
+- chmod 444 $(DESTDIR)$(mandir)/mann/$$i; \
++ $$i > $(DESTDIR)$(mandir)/mann/$$sfxname; \
++ chmod 444 $(DESTDIR)$(mandir)/mann/$$sfxname; \
+ done
+
+ test: binaries libraries
diff --git a/lang/itcl4/pkg-descr b/lang/itcl4/pkg-descr
new file mode 100644
index 000000000000..46b503e4082e
--- /dev/null
+++ b/lang/itcl4/pkg-descr
@@ -0,0 +1,5 @@
+[incr Tcl] is the most widely used O-O system for Tcl. The name is a play on
+C++, and [incr Tcl] provides a similar object model, including multiple
+inheritence and public and private classes and variables.
+
+http://core.tcl.tk/itcl
diff --git a/lang/itcl4/pkg-plist b/lang/itcl4/pkg-plist
new file mode 100644
index 000000000000..3ae3e3c1eef5
--- /dev/null
+++ b/lang/itcl4/pkg-plist
@@ -0,0 +1,33 @@
+include/itcl4.0/itcl.h
+include/itcl4.0/itcl2TclOO.h
+include/itcl4.0/itclDecls.h
+include/itcl4.0/itclInt.h
+include/itcl4.0/itclIntDecls.h
+include/itcl4.0/itclMigrate2TclCore.h
+include/itcl4.0/itclTclIntStubsFcn.h
+lib/itcl%%PKGVER%%/itcl.tcl
+lib/itcl%%PKGVER%%/itclConfig.sh
+lib/itcl%%PKGVER%%/itclHullCmds.tcl
+lib/itcl%%PKGVER%%/itclWidget.tcl
+lib/itcl%%PKGVER%%/libitcl%%PKGVER%%.so
+lib/itcl%%PKGVER%%/libitclstub%%PKGVER%%.a
+lib/itcl%%PKGVER%%/pkgIndex.tcl
+man/mann/body.i4.gz
+man/mann/class.i4.gz
+man/mann/code.i4.gz
+man/mann/configbody.i4.gz
+man/mann/delete.i4.gz
+man/mann/ensemble.i4.gz
+man/mann/find.i4.gz
+man/mann/is.i4.gz
+man/mann/itcl.i4.gz
+man/mann/itclcomponent.i4.gz
+man/mann/itcldelegate.i4.gz
+man/mann/itclextendedclass.i4.gz
+man/mann/itcloption.i4.gz
+man/mann/itclvars.i4.gz
+man/mann/itclwidget.i4.gz
+man/mann/local.i4.gz
+man/mann/scope.i4.gz
+@dirrmtry lib/itcl%%PKGVER%%
+@dirrmtry include/itcl4.0