aboutsummaryrefslogtreecommitdiff
path: root/lang/jruby/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2016-09-01 13:09:24 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2016-09-01 13:09:24 +0000
commit0a59cf3b92722399d38e3eca0190c9ce46eae671 (patch)
treeddbd0d276b48c250329cab0522da5ed54639abe7 /lang/jruby/Makefile
parent09ea4d656b560480140be7eff646c31dcdc2c30d (diff)
downloadports-0a59cf3b92722399d38e3eca0190c9ce46eae671.tar.gz
ports-0a59cf3b92722399d38e3eca0190c9ce46eae671.zip
Notes
Diffstat (limited to 'lang/jruby/Makefile')
-rw-r--r--lang/jruby/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/lang/jruby/Makefile b/lang/jruby/Makefile
index 1521a517945f..d5258053ec47 100644
--- a/lang/jruby/Makefile
+++ b/lang/jruby/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= jruby
-PORTVERSION= 1.7.22
+PORTVERSION= 1.7.26
CATEGORIES= lang ruby java
MASTER_SITES= http://jruby.org.s3.amazonaws.com/downloads/${PORTVERSION}/
DISTNAME= ${PORTNAME}-bin-${PORTVERSION}
@@ -31,6 +31,9 @@ PLIST_SUB+= PORTNAME=${PORTNAME} PORTVERSION=${PORTVERSION} JRUBY_HOME=${JRUBY_H
OPTIONS_DEFINE= DOCS EXAMPLES
+PORTDOCS= *
+PORTEXAMPLES= *
+
.include <bsd.port.pre.mk>
pre-patch:
@@ -70,8 +73,9 @@ do-install:
@${ECHO_MSG} " [ DONE ]"
@${ECHO_MSG} -n ">> Installing symlinks in ${STAGEDIR}${PREFIX}/bin..."
- @${LN} -sf ${JRUBY_HOME}/bin/jruby ${STAGEDIR}${PREFIX}/bin/jruby
- @${LN} -sf ${JRUBY_HOME}/bin/jirb ${STAGEDIR}${PREFIX}/bin/jirb
+.for f in jruby jirb jgem
+ @${LN} -sf ${JRUBY_HOME}/bin/${f} ${STAGEDIR}${PREFIX}/bin/${f}
+.endfor
@${ECHO_MSG} " [ DONE ]"
@${ECHO_MSG} -n ">> Stripping shared libraries for jnr-ffi"