aboutsummaryrefslogtreecommitdiff
path: root/lang/js_of_ocaml
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-03-27 12:29:54 +0000
committerJohn Marino <marino@FreeBSD.org>2014-03-27 12:29:54 +0000
commitf41e7b99796fb503e23725d783248fbbcfe324f9 (patch)
tree3f80555c002395cd721711b725c73f2dffe25dde /lang/js_of_ocaml
parent557659d9bb0b1aa51e3e08010f52c967ef2fac70 (diff)
downloadports-f41e7b99796fb503e23725d783248fbbcfe324f9.tar.gz
ports-f41e7b99796fb503e23725d783248fbbcfe324f9.zip
Notes
Diffstat (limited to 'lang/js_of_ocaml')
-rw-r--r--lang/js_of_ocaml/Makefile31
-rw-r--r--lang/js_of_ocaml/distinfo2
-rw-r--r--lang/js_of_ocaml/files/patch-Makefile14
-rw-r--r--lang/js_of_ocaml/files/patch-Makefile.conf13
-rw-r--r--lang/js_of_ocaml/pkg-descr4
5 files changed, 64 insertions, 0 deletions
diff --git a/lang/js_of_ocaml/Makefile b/lang/js_of_ocaml/Makefile
new file mode 100644
index 000000000000..e87c3030a7fb
--- /dev/null
+++ b/lang/js_of_ocaml/Makefile
@@ -0,0 +1,31 @@
+# Created by: Jaap Boender <jaapb@kerguelen.org>
+# $FreeBSD$
+
+PORTNAME= js_of_ocaml
+PORTVERSION= 1.3.2
+CATEGORIES= lang
+MASTER_SITES= http://ocsigen.org/download/
+
+MAINTAINER= jaapb@kerguelen.org
+COMMENT= OCaml to JavaScript compiler
+
+BUILD_DEPENDS= ocaml-lwt>=2.3.0:${PORTSDIR}/devel/ocaml-lwt \
+ ${SA_DIR}/deriving-ocsigen/deriving.a:${PORTSDIR}/devel/ocaml-deriving-ocsigen
+RUN_DEPENDS= ocaml-lwt>=2.3.0:${PORTSDIR}/devel/ocaml-lwt \
+ ${SA_DIR}/deriving-ocsigen/deriving.a:${PORTSDIR}/devel/ocaml-deriving-ocsigen
+
+SA_DIR= ${PREFIX}/${OCAML_SITELIBDIR}
+
+USES= gmake
+USE_OCAML= yes
+USE_OCAML_FINDLIB= yes
+USE_OCAML_LDCONFIG= yes
+USE_OCAMLFIND_PLIST= yes
+
+PLIST_FILES+= bin/js_of_ocaml
+
+MAKE_ENV+= BINDIR=${STAGEDIR}${PREFIX}/bin \
+ DESTDIR=${STAGEDIR} \
+ OCAML_SITELIBDIR=${PREFIX}/lib/ocaml/site-lib
+
+.include <bsd.port.mk>
diff --git a/lang/js_of_ocaml/distinfo b/lang/js_of_ocaml/distinfo
new file mode 100644
index 000000000000..56c1bf19e1d9
--- /dev/null
+++ b/lang/js_of_ocaml/distinfo
@@ -0,0 +1,2 @@
+SHA256 (js_of_ocaml-1.3.2.tar.gz) = 5996d2a9bc32121186e1964af557bb411eb5a27aa155d2c6a8a144ee5f3d0c36
+SIZE (js_of_ocaml-1.3.2.tar.gz) = 1901593
diff --git a/lang/js_of_ocaml/files/patch-Makefile b/lang/js_of_ocaml/files/patch-Makefile
new file mode 100644
index 000000000000..8b7fec7186e1
--- /dev/null
+++ b/lang/js_of_ocaml/files/patch-Makefile
@@ -0,0 +1,14 @@
+$NetBSD: patch-Makefile,v 1.2 2012/12/14 14:40:24 jaapb Exp $
+
+Install to DESTDIR
+--- Makefile.orig 2012-12-07 19:39:02.000000000 +0000
++++ Makefile
+@@ -31,7 +31,7 @@ include Makefile.filelist
+
+ VERSION := $(shell head -n 1 VERSION)
+ install:
+- ocamlfind install -patch-version ${VERSION} $(LIBRARY) lib/META $(INTF) $(IMPL) $(OTHERS) $(DOC)
++ ocamlfind install -ldconf ignore -destdir ${DESTDIR}${OCAML_SITELIBDIR} -patch-version ${VERSION} $(LIBRARY) lib/META $(INTF) $(IMPL) $(OTHERS) $(DOC)
+ install -d -m 755 $(BINDIR)
+ install $(BIN) $(BINDIR)
+
diff --git a/lang/js_of_ocaml/files/patch-Makefile.conf b/lang/js_of_ocaml/files/patch-Makefile.conf
new file mode 100644
index 000000000000..d2bddd6f2273
--- /dev/null
+++ b/lang/js_of_ocaml/files/patch-Makefile.conf
@@ -0,0 +1,13 @@
+$NetBSD: patch-Makefile.conf,v 1.1 2012/07/11 15:35:06 wiz Exp $
+
+Have BINDIR be determined from package Makefile
+--- Makefile.conf.orig 2011-11-30 14:25:06.000000000 +0000
++++ Makefile.conf
+@@ -1,6 +1,6 @@
+
+ # Where binaries are installed:
+-BINDIR := /usr/local/bin
++# BINDIR := /usr/local/bin
+
+ ####
+
diff --git a/lang/js_of_ocaml/pkg-descr b/lang/js_of_ocaml/pkg-descr
new file mode 100644
index 000000000000..fa7201fefe3f
--- /dev/null
+++ b/lang/js_of_ocaml/pkg-descr
@@ -0,0 +1,4 @@
+Js_of_ocaml is a compiler of OCaml bytecode to Javascript. It makes it
+possible to run Ocaml programs in a Web browser.
+
+WWW: http://ocsigen.org/js_of_ocaml/