aboutsummaryrefslogtreecommitdiff
path: root/lang/lafontaine/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-10-23 09:10:45 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-10-23 09:10:45 +0000
commit64f24e84ebe9a2d34c44f210b515438f6cef2939 (patch)
treee455c1fc645b9afcb9464a09dcb6601140fd92b8 /lang/lafontaine/Makefile
parent566e7e2a5d9e543f689186761fad59eef9775921 (diff)
downloadports-64f24e84ebe9a2d34c44f210b515438f6cef2939.tar.gz
ports-64f24e84ebe9a2d34c44f210b515438f6cef2939.zip
Notes
Diffstat (limited to 'lang/lafontaine/Makefile')
-rw-r--r--lang/lafontaine/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/lang/lafontaine/Makefile b/lang/lafontaine/Makefile
index e7757b196852..a2d5a41ccd65 100644
--- a/lang/lafontaine/Makefile
+++ b/lang/lafontaine/Makefile
@@ -9,15 +9,26 @@
PORTNAME= lafontaine
PORTVERSION= 0.3R3
CATEGORIES= lang
-MASTER_SITES= http://www.freesoftware.fsf.org/lafontaine/archives/
+MASTER_SITES= http://www.nongnu.org/lafontaine/archives/
DISTNAME= ${PORTNAME}-${PORTVERSION}-20020715
MAINTAINER= ports@FreeBSD.org
-USE_BZIP2= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
USE_GNOMENG= yes
-USE_GNOME= gtk12 gdkpixbuf
+USE_GNOME= gdkpixbuf
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|pixmaps/[\$$]PACKAGE|\$$PACKAGE|g ; \
+ s|-O3|\$$CFLAGS|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|"\./pixmaps/|PIXMAPDIR "/|g' ${WRKSRC}/src/callbacks.c
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|/share/pixmaps|/share|g'
.include <bsd.port.mk>