aboutsummaryrefslogtreecommitdiff
path: root/lang/libjit/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-08-09 08:27:31 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-08-09 08:27:31 +0000
commit93184cdab1c5642a513d9930ff348502a7b6dc64 (patch)
treebd35096bcfe63c4668ea2b80ffda6d6c11894cc3 /lang/libjit/Makefile
parent9c2f4f169f24f75ba1d3332545a60a23fc027122 (diff)
downloadports-93184cdab1c5642a513d9930ff348502a7b6dc64.tar.gz
ports-93184cdab1c5642a513d9930ff348502a7b6dc64.zip
Notes
Diffstat (limited to 'lang/libjit/Makefile')
-rw-r--r--lang/libjit/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/lang/libjit/Makefile b/lang/libjit/Makefile
index e42c2f7ad25c..091bb624543e 100644
--- a/lang/libjit/Makefile
+++ b/lang/libjit/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libjit
-PORTVERSION= 0.0.2
+PORTVERSION= 0.0.4
CATEGORIES= lang
MASTER_SITES= http://www.southern-storm.com.au/download/
@@ -14,10 +14,13 @@ MAINTAINER= ahze@ahze.net
COMMENT= Libjit implements Just-In-Time compilation functionality
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+USE_INC_LIBTOOL_VER=13
+USE_REINPLACE= yes
+
+INSTALLS_SHLIB= yes
+
INFO= libjit
MAN3= libjit.3
-INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
@@ -25,4 +28,10 @@ INSTALLS_SHLIB= yes
BROKEN= "Does not compile on amd64"
.endif
+post-configure:
+.if ${OSVERSION} >= 502123
+ @${REINPLACE_CMD} -e 's|$$pic_flag -DPIC||' \
+ ${WRKSRC}/libtool
+.endif
+
.include <bsd.port.post.mk>