aboutsummaryrefslogtreecommitdiff
path: root/lang/libjit
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-04-29 08:30:56 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-04-29 08:30:56 +0000
commitc645a7ed351cb75699bab1963cc699d0c0af10ac (patch)
treef58d9acc5166a918b463a742c121e508d5c8a66e /lang/libjit
parent388c6e73b80098310c12aaeceaff640a3b88fc72 (diff)
downloadports-c645a7ed351cb75699bab1963cc699d0c0af10ac.tar.gz
ports-c645a7ed351cb75699bab1963cc699d0c0af10ac.zip
Notes
Diffstat (limited to 'lang/libjit')
-rw-r--r--lang/libjit/Makefile21
-rw-r--r--lang/libjit/distinfo2
-rw-r--r--lang/libjit/files/patch-aa12
-rw-r--r--lang/libjit/files/patch-ab12
-rw-r--r--lang/libjit/files/patch-ac12
-rw-r--r--lang/libjit/files/patch-ad12
-rw-r--r--lang/libjit/pkg-descr12
-rw-r--r--lang/libjit/pkg-plist23
8 files changed, 106 insertions, 0 deletions
diff --git a/lang/libjit/Makefile b/lang/libjit/Makefile
new file mode 100644
index 000000000000..0b63a153e2c6
--- /dev/null
+++ b/lang/libjit/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: libjit
+# Date created: 2004-04-27
+# Whom: michael johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libjit
+PORTVERSION= 0.0.0f
+CATEGORIES= lang
+MASTER_SITES= http://www.southern-storm.com.au/download/
+
+MAINTAINER= ahze@ahze.net
+COMMENT= Libjit implements Just-In-Time compilation functionality
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+INFO= libjit
+MAN3= libjit.3
+
+.include <bsd.port.mk>
diff --git a/lang/libjit/distinfo b/lang/libjit/distinfo
new file mode 100644
index 000000000000..97ae14da1c33
--- /dev/null
+++ b/lang/libjit/distinfo
@@ -0,0 +1,2 @@
+MD5 (libjit-0.0.0f.tar.gz) = 74ec58a39c3d46e1455295c80931c596
+SIZE (libjit-0.0.0f.tar.gz) = 409251
diff --git a/lang/libjit/files/patch-aa b/lang/libjit/files/patch-aa
new file mode 100644
index 000000000000..ccdf238c61c2
--- /dev/null
+++ b/lang/libjit/files/patch-aa
@@ -0,0 +1,12 @@
+--- jit/jit-apply.c.orig Tue Apr 27 00:21:55 2004
++++ jit/jit-apply.c Tue Apr 27 00:23:21 2004
+@@ -23,6 +23,9 @@
+ #include "jit-apply-rules.h"
+ #include "jit-apply-func.h"
+ #include "jit-cache.h"
++#ifdef __FreeBSD__
++ #include <stdlib.h>
++#endif
+ #if HAVE_ALLOCA_H
+ #include <alloca.h>
+ #endif
diff --git a/lang/libjit/files/patch-ab b/lang/libjit/files/patch-ab
new file mode 100644
index 000000000000..fe737eb5a0b1
--- /dev/null
+++ b/lang/libjit/files/patch-ab
@@ -0,0 +1,12 @@
+--- jit/jit-insn.c.orig Tue Apr 27 00:22:44 2004
++++ jit/jit-insn.c Tue Apr 27 00:23:09 2004
+@@ -21,6 +21,9 @@
+ #include "jit-internal.h"
+ #include "jit-rules.h"
+ #include <config.h>
++#ifdef __FreeBSD__
++ #include <stdlib.h>
++#endif
+ #if HAVE_ALLOCA_H
+ #include <alloca.h>
+ #endif
diff --git a/lang/libjit/files/patch-ac b/lang/libjit/files/patch-ac
new file mode 100644
index 000000000000..032207cb8851
--- /dev/null
+++ b/lang/libjit/files/patch-ac
@@ -0,0 +1,12 @@
+--- jit/jit-interp.cpp.orig Tue Apr 27 00:23:50 2004
++++ jit/jit-interp.cpp Tue Apr 27 00:24:18 2004
+@@ -30,6 +30,9 @@
+ #include "jit-rules.h"
+ #include "jit-memory.h"
+ #include <config.h>
++#ifdef __FreeBSD__
++ #include <stdlib.h>
++#endif
+ #if HAVE_ALLOCA_H
+ #include <alloca.h>
+ #endif
diff --git a/lang/libjit/files/patch-ad b/lang/libjit/files/patch-ad
new file mode 100644
index 000000000000..9d8002bf8846
--- /dev/null
+++ b/lang/libjit/files/patch-ad
@@ -0,0 +1,12 @@
+--- tools/gen-apply.c.orig Tue Apr 27 00:26:20 2004
++++ tools/gen-apply.c Tue Apr 27 00:26:40 2004
+@@ -22,6 +22,9 @@
+ #include "jit-apply-func.h"
+ #include <stdio.h>
+ #include <config.h>
++#ifdef __FreeBSD__
++ #include <stdlib.h>
++#endif
+ #if HAVE_ALLOCA_H
+ #include <alloca.h>
+ #endif
diff --git a/lang/libjit/pkg-descr b/lang/libjit/pkg-descr
new file mode 100644
index 000000000000..bd6bc12a6dff
--- /dev/null
+++ b/lang/libjit/pkg-descr
@@ -0,0 +1,12 @@
+The libjit library implements Just-In-Time compilation functionality. Unlike
+other JIT's, this one is designed to be independent of any particular virtual
+machine bytecode format or language. The hope is that Free Software projects
+can get a leg-up on proprietry VM vendors by using this library rather than
+spending large amounts of time writing their own JIT from scratch.
+
+This JIT is also designed to be portable to multiple archictures. If you run
+libjit on a machine for which a native code generator is not yet available,
+then libjit will fall back to interpreting the code. This way, you don't need
+to write your own interpreter for your bytecode format if you don't want to.
+
+WWW: http://www.southern-storm.com.au/libjit.html
diff --git a/lang/libjit/pkg-plist b/lang/libjit/pkg-plist
new file mode 100644
index 000000000000..3b815b0eafdf
--- /dev/null
+++ b/lang/libjit/pkg-plist
@@ -0,0 +1,23 @@
+include/jit/jit-apply.h
+include/jit/jit-block.h
+include/jit/jit-common.h
+include/jit/jit-context.h
+include/jit/jit-defs.h
+include/jit/jit-dump.h
+include/jit/jit-elf.h
+include/jit/jit-except.h
+include/jit/jit-function.h
+include/jit/jit-init.h
+include/jit/jit-insn.h
+include/jit/jit-intrinsic.h
+include/jit/jit-meta.h
+include/jit/jit-opcode.h
+include/jit/jit-plus.h
+include/jit/jit-type.h
+include/jit/jit-util.h
+include/jit/jit-value.h
+include/jit/jit-walk.h
+include/jit/jit.h
+lib/libjit.a
+lib/libjitplus.a
+@dirrm include/jit