aboutsummaryrefslogtreecommitdiff
path: root/lang/libobjc2/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2010-10-13 16:41:24 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2010-10-13 16:41:24 +0000
commita3c396937177907ee0c1c6180ac27f5e3b1c447f (patch)
tree50dba99db5805d04191036f23ca90326e4c8f75e /lang/libobjc2/Makefile
parentef559f3868d92829d45721f385480e0d088cb6f5 (diff)
Notes
Diffstat (limited to 'lang/libobjc2/Makefile')
-rw-r--r--lang/libobjc2/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/lang/libobjc2/Makefile b/lang/libobjc2/Makefile
new file mode 100644
index 000000000000..783e0985faee
--- /dev/null
+++ b/lang/libobjc2/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: libobjc2
+# Date created: 7 October 2010
+# Whom: Pete French <pete@twisted.org.uk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libobjc2
+PORTVERSION= 1.0
+CATEGORIES= lang devel gnustep
+MASTER_SITES= http://download.gna.org/gnustep/
+
+MAINTAINER= pete@twisted.org.uk
+COMMENT= Replacement Objective-C runtime supporting Obj-C 2 features
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+
+OPTIONS= LIBDISPATCH "Build with libdispatch from ports" Off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_LIBDISPATCH)
+LIB_DEPENDS+= dispatch.0:${PORTSDIR}/devel/libdispatch
+MAKE_ARGS+= -DWITHOUT_TOYDISPATCH
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if (${ARCH} == i386) || (${ARCH} == i486)
+CFLAGS+= -march=i586
+.endif
+
+.include <bsd.port.post.mk>