aboutsummaryrefslogtreecommitdiff
path: root/lang/librep
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-11-23 11:34:04 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-11-23 11:34:04 +0000
commitef7fd9a68a48312535d30f0cfd3efa1c08816d9c (patch)
tree0b4a9acf8dbdc6fdb69af1c8a73c1cedf6ba7c4a /lang/librep
parent46891d102c8d4397063376e162106c13eb683364 (diff)
downloadports-ef7fd9a68a48312535d30f0cfd3efa1c08816d9c.tar.gz
ports-ef7fd9a68a48312535d30f0cfd3efa1c08816d9c.zip
Notes
Diffstat (limited to 'lang/librep')
-rw-r--r--lang/librep/Makefile30
-rw-r--r--lang/librep/distinfo4
-rw-r--r--lang/librep/files/patch-src__lispmach.h11
3 files changed, 12 insertions, 33 deletions
diff --git a/lang/librep/Makefile b/lang/librep/Makefile
index 2d37020fe069..85577ea7f8f7 100644
--- a/lang/librep/Makefile
+++ b/lang/librep/Makefile
@@ -2,11 +2,10 @@
# $FreeBSD$
PORTNAME= librep
-PORTVERSION= 0.92.3
-PORTREVISION= 1
+PORTVERSION= 0.92.4
CATEGORIES= lang elisp gnome
-MASTER_SITES= http://download.tuxfamily.org/librep/%SUBDIR%/
-MASTER_SITE_SUBDIR= . Archive
+MASTER_SITES= http://download.tuxfamily.org/librep/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Emacs Lisp like runtime library
@@ -15,12 +14,13 @@ LICENSE= GPLv2
LIB_DEPENDS= libgdbm.so:${PORTSDIR}/databases/gdbm \
libffi.so:${PORTSDIR}/devel/libffi \
- libgmp.so:${PORTSDIR}/math/gmp
+ libgmp.so:${PORTSDIR}/math/gmp
RUN_DEPENDS= gtar:${PORTSDIR}/archivers/gtar
USE_CSTD= gnu89
-USES= gettext gmake libtool makeinfo pathfix pkgconfig readline tar:xz shebangfix
+USES= gettext gmake libtool makeinfo pathfix pkgconfig readline \
+ shebangfix tar:xz
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-aclocaldir=${PREFIX}/share/aclocal \
--with-stack-direction=-1
@@ -35,19 +35,9 @@ LDFLAGS+= -L${LOCALBASE}/lib -pthread
INFO= librep
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == ia64
-BROKEN= Does not build on ia64
-.endif
-
post-patch:
- @${REINPLACE_CMD} -e \
- '/GDBM_LIBS/s|"-lgdbm"|"$$LIBS -lgdbm"|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e \
- 's|/share/man/|/man/|g' ${WRKSRC}/man/Makefile.in
-
-pre-install:
- ${FIND} ${WRKSRC} -name "*.so" -exec ${STRIP_CMD} {} \;
+ @${REINPLACE_CMD} -e 's|share/man|man|' ${WRKSRC}/man/Makefile.in
+ @${REINPLACE_CMD} -E 's|(INSTALL_PROGRAM\))( [^-])|\1 -m 755\2|' \
+ ${WRKSRC}/src/Makefile.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/librep/distinfo b/lang/librep/distinfo
index d53979f5d285..33f0f205f11e 100644
--- a/lang/librep/distinfo
+++ b/lang/librep/distinfo
@@ -1,2 +1,2 @@
-SHA256 (librep-0.92.3.tar.xz) = 45c98a5bbdfde4f1d98e3839b319d9ae15857d2d1ae8e3838d9a18d53f3e8b85
-SIZE (librep-0.92.3.tar.xz) = 607128
+SHA256 (librep_0.92.4.tar.xz) = 45b0c970c903c50bbc49d65526d2109a1e1663f61823b7151f12797189a82709
+SIZE (librep_0.92.4.tar.xz) = 651216
diff --git a/lang/librep/files/patch-src__lispmach.h b/lang/librep/files/patch-src__lispmach.h
deleted file mode 100644
index e682b7b5e21a..000000000000
--- a/lang/librep/files/patch-src__lispmach.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/lispmach.h.orig
-+++ src/lispmach.h
-@@ -475,7 +475,7 @@
- #ifdef __arm__
- #define PC_REG asm("r9")
- #define SP_REG asm("r8")
--#define SLOTS_REG asm("r7")
-+#define SLOTS_REG asm("r10")
- #endif
- #endif
-