aboutsummaryrefslogtreecommitdiff
path: root/lang/mdk/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-01 06:13:47 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-01 06:13:47 +0000
commit42d7c88d390eeb982f610b74a4ce002fc55120dd (patch)
treed9395d8df7a52d58722efc6e1fdcea18c0d245ac /lang/mdk/Makefile
parent343542edf96191e7e01a787ea57bcde421176e21 (diff)
downloadports-42d7c88d390eeb982f610b74a4ce002fc55120dd.tar.gz
ports-42d7c88d390eeb982f610b74a4ce002fc55120dd.zip
Notes
Diffstat (limited to 'lang/mdk/Makefile')
-rw-r--r--lang/mdk/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/lang/mdk/Makefile b/lang/mdk/Makefile
index 1dfbe9a6e560..ff5bbf34715b 100644
--- a/lang/mdk/Makefile
+++ b/lang/mdk/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= mdk
-PORTVERSION= 0.5
-PORTREVISION= 1
+PORTVERSION= 1.0
CATEGORIES= lang gnome
MASTER_SITES= ${MASTER_SITE_GNU} \
${MASTER_SITE_SOURCEFORGE}
@@ -16,15 +15,15 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ijliao@FreeBSD.org
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
- intl.2:${PORTSDIR}/devel/gettext \
- guile.9:${PORTSDIR}/lang/guile
-
USE_X_PREFIX= yes
USE_GNOME= yes
-USE_LIBTOOL= yes
-CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt" \
+ MAKEINFO="makeinfo --no-split"
+
+post-extract:
+ @${RM} -f ${WRKSRC}/doc/*.info
.include <bsd.port.mk>