aboutsummaryrefslogtreecommitdiff
path: root/lang/mit-scheme/Makefile
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>2000-03-01 01:25:13 +0000
committerSatoshi Asami <asami@FreeBSD.org>2000-03-01 01:25:13 +0000
commit97ff3e6b38d5e995a9b1ffa1acb85126a3d3acd3 (patch)
treefc0496163511c04010dc8212051774722c578b1d /lang/mit-scheme/Makefile
parent1b847a8684330844d038ed222d0cfa8d1b6155a7 (diff)
Notes
Diffstat (limited to 'lang/mit-scheme/Makefile')
-rw-r--r--lang/mit-scheme/Makefile28
1 files changed, 19 insertions, 9 deletions
diff --git a/lang/mit-scheme/Makefile b/lang/mit-scheme/Makefile
index 42b8808700fe..3d73f670f3ca 100644
--- a/lang/mit-scheme/Makefile
+++ b/lang/mit-scheme/Makefile
@@ -1,21 +1,31 @@
-# New ports collection makefile for: MIT-Scheme
-# Version required: 7.3
-# Date created: Mar 26 1995
-# Whom: jmacd@FreeBSD.org
+# New ports collection makefile for: MIT-Scheme
+# Version required: 7.5.2
+# Date created: Mar 26 1995
+# Whom: jmacd@FreeBSD.org
#
# $FreeBSD$
#
-DISTNAME= mit-scheme
-PKGNAME= mit-scheme-7.3
+DISTNAME= scheme-7.5.2-ix86-freebsd
+PKGNAME= mit-scheme-7.5.3
CATEGORIES= lang
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-DISTFILES= scheme-microcode+dist-7.3-freebsd.tgz
+MASTER_SITES= ftp://ftp.swiss.ai.mit.edu/pub/scheme-7.5/
MAINTAINER= jmacd@FreeBSD.org
-BROKEN_ELF= yes
+ONLY_FOR_ARCH= i386
USE_XLIB= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/scheme ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/bchscheme ${PREFIX}/bin
+ ${TAR} -C ${WRKSRC}/lib -cf - mit-scheme | \
+ ${TAR} -C ${PREFIX}/lib --unlink -xf -
+ ${CHMOD} -R ${SHAREMODE} ${PREFIX}/lib/mit-scheme
+ find ${PREFIX}/lib/mit-scheme -type f -exec \
+ ${CHOWN} ${SHAREOWN}:${SHAREGRP} ${PREFIX}/lib/mit-scheme \;
.include <bsd.port.mk>