aboutsummaryrefslogtreecommitdiff
path: root/lang/mono/Makefile
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2010-06-01 12:41:30 +0000
committerRomain Tartière <romain@FreeBSD.org>2010-06-01 12:41:30 +0000
commit5c809510227e264f4ab23c92c1af146897974e8f (patch)
treebbc686a376c7c469beb062572a7062657211c4f3 /lang/mono/Makefile
parent76fcccf45033fac91efa53e1624554b93abdfbc0 (diff)
Notes
Diffstat (limited to 'lang/mono/Makefile')
-rw-r--r--lang/mono/Makefile50
1 files changed, 24 insertions, 26 deletions
diff --git a/lang/mono/Makefile b/lang/mono/Makefile
index 1bfcdadc630f..8e92d76a6180 100644
--- a/lang/mono/Makefile
+++ b/lang/mono/Makefile
@@ -7,32 +7,30 @@
#
PORTNAME= mono
-PORTVERSION= 2.4.3.1
-PORTREVISION= 2
+PORTVERSION= 2.6.4
CATEGORIES= lang
MASTER_SITES= http://ftp.novell.com/pub/mono/sources/${PORTNAME}/
MAINTAINER= mono@FreeBSD.org
COMMENT= An open source implementation of .NET Development Framework
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
+ bash:${PORTSDIR}/shells/bash
USE_BZIP2= yes
USE_BISON= build
USE_GNOME= gnomehack glib20
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:22
USE_PERL5_BUILD= yes
-LIBTOOLFILES= configure libgc/configure
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
- PTHREAD_LIBS="${PTHREAD_LIBS}"
-MAKE_ARGS= EXTERNAL_MCS=false
USE_GETTEXT= yes
-MAKE_JOBS_UNSAFE=yes
-OPTIONS= MOON "Enable Moonlight Profile (2.1 Alpha)" on
+# Moonlight is installed as part of www/moonlight
+CONFIGURE_ARGS= --with-moonlight=no
+
+OPTIONS= PROFILE2 "Enable the 2.0 mono profile" on \
+ PROFILE4 "Enable the 4.0 mono profile (experimental)" off
# Set location for .wapi creation.
MONO_SHARED_DIR=${WRKDIR}
@@ -43,7 +41,7 @@ MONO_SHARED_DIR=${WRKDIR}
MAKE_ENV= MONO_SHARED_DIR="${MONO_SHARED_DIR}" \
LC_ALL=C
-ONLY_FOR_ARCHS= i386 amd64 powerpc
+ONLY_FOR_ARCHS= i386 amd64 ppc
MAN1= al.1 cert2spc.1 certmgr.1 chktrust.1 cilc.1 csharp.1 disco.1 \
dtd2xsd.1 gacutil.1 genxs.1 httpcfg.1 ilasm.1 jay.1 lc.1 \
@@ -54,37 +52,37 @@ MAN1= al.1 cert2spc.1 certmgr.1 chktrust.1 cilc.1 csharp.1 disco.1 \
mono-xmltool.1 mono.1 monodis.1 monodocer.1 monodocs2html.1 \
monolinker.1 monop.1 monostyle.1 mozroots.1 oldmono.1 \
permview.1 prj2make.1 resgen.1 secutil.1 setreg.1 sgen.1 \
- signcode.1 sn.1 soapsuds.1 sqlsharp.1 wsdl.1 xbuild.1 xsd.1
+ signcode.1 sn.1 soapsuds.1 sqlsharp.1 wsdl.1 xsd.1
MAN5= mdoc.5 mono-config.5
.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64"
-MAKE_ARGS+= MONO_GENERIC_SHARING=none #https://bugzilla.novell.com/show_bug.cgi?id=434457
+.if defined(WITH_PROFILE2) && !defined(WITHOUT_PROFILE2)
+CONFIGURE_ARGS+=--with-profile2=yes
+PLIST_SUB+= PROFILE2=""
+.else
+CONFIGURE_ARGS+=--with-profile2=no
+PLIST_SUB+= PROFILE2="@comment "
.endif
-.if defined(WITH_MOON) && !defined(WITHOUT_MOON)
-CONFIGURE_ARGS+= --with-moonlight
-PLIST_SUB+= MOON=""
+.if defined(WITH_PROFILE4) && !defined(WITHOUT_PROFILE4)
+CONFIGURE_ARGS+=--with-profile4=yes
+PLIST_SUB+= PROFILE4=""
.else
-CONFIGURE_ARGS+= --without-moonlight
-PLIST_SUB+= MOON="@comment "
+CONFIGURE_ARGS+=--with-profile4=no
+PLIST_SUB+= PROFILE4="@comment "
.endif
pre-everything::
@${CAT} ${PKGMESSAGE}
post-patch:
- @${REINPLACE_CMD} -e 's|libgamin-1.so.0|libgamin-1.so.1|g' \
- ${WRKSRC}/mcs/class/System/System.IO/FAMWatcher.cs
@${REINPLACE_CMD} -e 's|^#!/bin/bash|#!/bin/sh|g' \
${WRKSRC}/mcs/class/Managed.Windows.Forms/build-csproj \
${WRKSRC}/mcs/class/Managed.Windows.Forms/build-csproj2k5 \
- ${WRKSRC}/mcs/class/Mono.WebBrowser/build-csproj2k5 \
- ${WRKSRC}/mcs/class/Mono.Cairo/Samples/gtk/compile.sh \
- ${WRKSRC}/mcs/class/Mono.Cairo/Samples/png/compile.sh \
- ${WRKSRC}/mcs/class/Mono.Cairo/Samples/win32/compile.sh \
- ${WRKSRC}/mcs/class/Mono.Cairo/Samples/x11/compile.sh
+ ${WRKSRC}/mcs/class/Mono.WebBrowser/build-csproj2k5
+ @${FIND} ${WRKSRC} -name '*.sh' | ${XARGS} ${REINPLACE_CMD} \
+ -e 's|^#!/bin/bash|#!/bin/sh|g'
tests: build
@${ECHO_MSG} "===> Running mono regression tests"