aboutsummaryrefslogtreecommitdiff
path: root/lang/mono
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2018-06-18 14:10:57 +0000
committerMark Felder <feld@FreeBSD.org>2018-06-18 14:10:57 +0000
commit8c5039e5b4ae872d232267c5b3cf46a9ca3c9985 (patch)
tree64c896430a29ff54ec356adc0c4e89d65f95d507 /lang/mono
parente1d0ad37671cbe397bcc89e69d8b078e4741e2e2 (diff)
downloadports-8c5039e5b4ae872d232267c5b3cf46a9ca3c9985.tar.gz
ports-8c5039e5b4ae872d232267c5b3cf46a9ca3c9985.zip
Notes
Diffstat (limited to 'lang/mono')
-rw-r--r--lang/mono/Makefile8
-rw-r--r--lang/mono/files/patch-scripts_mono-heapviz11
2 files changed, 15 insertions, 4 deletions
diff --git a/lang/mono/Makefile b/lang/mono/Makefile
index 276a19ae95c6..c627ea32e155 100644
--- a/lang/mono/Makefile
+++ b/lang/mono/Makefile
@@ -3,10 +3,10 @@
PORTNAME= mono
PORTVERSION= 5.10.1.47
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
-MASTER_SITES= https://download.mono-project.com/sources/mono/:mono
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:mono
+MASTER_SITES= https://download.mono-project.com/sources/mono/
+DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= mono@FreeBSD.org
COMMENT= Open source implementation of .NET Development Framework
@@ -36,7 +36,7 @@ MONOLITE_VERSION= 1051000004
X11_USES= display:test
USES= autoreconf bison compiler:c11 cpe gettext gmake iconv libtool \
- pathfix perl5 python shebangfix tar:bzip2
+ pathfix perl5 python:2.7 shebangfix tar:bzip2
USE_PERL5= build
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/lang/mono/files/patch-scripts_mono-heapviz b/lang/mono/files/patch-scripts_mono-heapviz
new file mode 100644
index 000000000000..fc44982f44f8
--- /dev/null
+++ b/lang/mono/files/patch-scripts_mono-heapviz
@@ -0,0 +1,11 @@
+--- scripts/mono-heapviz.orig 2018-01-18 17:41:54 UTC
++++ scripts/mono-heapviz
+@@ -7,7 +7,7 @@
+
+ from __future__ import print_function
+ import sys, os
+-import Image, ImageDraw
++from PIL import Image, ImageDraw
+ from xml.sax import ContentHandler, make_parser
+ from xml.sax.handler import feature_namespaces
+ from optparse import OptionParser