aboutsummaryrefslogtreecommitdiff
path: root/lang/mono
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-05-26 13:32:32 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-05-26 13:32:32 +0000
commit87e16ac3ef51c000593292f5b83089174e0d61ba (patch)
tree5e4d8ba9ed5deea32f9e18bd2efefcef2b854996 /lang/mono
parent469f5c376588ad2eb1809c296ff32388acf62225 (diff)
downloadports-87e16ac3ef51c000593292f5b83089174e0d61ba.tar.gz
ports-87e16ac3ef51c000593292f5b83089174e0d61ba.zip
Notes
Diffstat (limited to 'lang/mono')
-rw-r--r--lang/mono/bsd.mono.mk58
1 files changed, 0 insertions, 58 deletions
diff --git a/lang/mono/bsd.mono.mk b/lang/mono/bsd.mono.mk
deleted file mode 100644
index c5564d825111..000000000000
--- a/lang/mono/bsd.mono.mk
+++ /dev/null
@@ -1,58 +0,0 @@
-# New ports collection makefile for: Mono and it's consumers
-# Date created: 15 October 2005
-# Whom: Tom McLaughlin <tmclaugh@FreeBSD.org>
-#
-# bsd.mono.mk: accomodate the peculiarities of building C# ports within
-# the FreeBSD ports system.
-#
-# $FreeBSD$
-#
-
-# USE_NANT - If set, the port uses nant.
-# USE_NANT - If set "contrib", the port uses nantcontrib.
-# NANT - Set to path of Nant.
-
-# Set the location of the .wapi directory so we write to a location we
-# can always assume to be writable.
-MONO_SHARED_DIR=${WRKDIR}
-CONFIGURE_ENV+=MONO_SHARED_DIR="${MONO_SHARED_DIR}"
-MAKE_ENV+=MONO_SHARED_DIR="${MONO_SHARED_DIR}"
-
-# Set the location that webaps served by XSP should use.
-XSP_DOCROOT=${PREFIX}/www/xsp
-
-# gac utilities
-GACUTIL=${LOCALBASE}/bin/gacutil /root ${PREFIX}/lib/ /gacdir ${PREFIX}/lib
-GACUTIL_INSTALL=${GACUTIL} /i
-GACUTIL_INSTALL_PACKAGE=${GACUTIL} /i /package 1.0 /package 2.0
-
-# Dependencies
-
-.if defined(USE_NANT)
-BUILD_DEPENDS+= nant:${PORTSDIR}/devel/nant
-.if ${USE_NANT}=="contrib"
-BUILD_DEPENDS+= ${LOCALBASE}/share/NAnt/bin/NAnt.Contrib.Tests.dll:${PORTSDIR}/devel/nantcontrib
-.endif
-.endif
-
-# Miscellaneous overridable commands:
-
-NANT?= nant
-NANT_INSTALL_TARGET?= install
-
-# Build
-.if defined(USE_NANT)
-.if !target(do-build)
-do-build:
- @(cd ${BUILD_WRKSRC}; ${SETENV} MONO_SHARED_DIR="${MONO_SHARED_DIR}" ${NANT} ${NANT_FLAGS})
-.endif
-.endif
-
-
-# Install
-.if defined(USE_NANT)
-.if !target(do-install)
-do-install:
- @(cd ${INSTALL_WRKSRC}; ${SETENV} MONO_SHARED_DIR="${MONO_SHARED_DIR}" ${NANT} ${NANT_FLAGS} -D:prefix="${PREFIX}" ${NANT_INSTALL_TARGET})
-.endif
-.endif