aboutsummaryrefslogtreecommitdiff
path: root/lang/mono
diff options
context:
space:
mode:
authorTom McLaughlin <tmclaugh@FreeBSD.org>2006-10-07 17:39:36 +0000
committerTom McLaughlin <tmclaugh@FreeBSD.org>2006-10-07 17:39:36 +0000
commitda532990da38c09b7f01d548b4a862702569dabf (patch)
treee274b618cba3a08240a64355f30862239fdeac80 /lang/mono
parent393d0c1f2da7a28455ab6824ae907c682820257e (diff)
downloadports-da532990da38c09b7f01d548b4a862702569dabf.tar.gz
ports-da532990da38c09b7f01d548b4a862702569dabf.zip
Notes
Diffstat (limited to 'lang/mono')
-rw-r--r--lang/mono/Makefile5
-rw-r--r--lang/mono/bsd.mono.mk40
-rw-r--r--lang/mono/distinfo6
3 files changed, 43 insertions, 8 deletions
diff --git a/lang/mono/Makefile b/lang/mono/Makefile
index 2773a79353ba..77d9d672cd55 100644
--- a/lang/mono/Makefile
+++ b/lang/mono/Makefile
@@ -3,12 +3,11 @@
# Whom: Yukihiro Nakai <nakai@FreeBSD.org>
#
# $FreeBSD$
-# $Id: Makefile,v 1.58 2006/04/15 02:00:25 tmclau02 Exp $
+# $Id: Makefile,v 1.62 2006/10/07 02:36:33 tmclau02 Exp $
#
PORTNAME= mono
-PORTVERSION= 1.1.13.6
-PORTREVISION= 1
+PORTVERSION= 1.1.13.8.1
CATEGORIES= lang
MASTER_SITES= http://www.go-mono.com/sources/mono-1.1/ \
${MASTER_SITE_LOCAL}
diff --git a/lang/mono/bsd.mono.mk b/lang/mono/bsd.mono.mk
index 5c0f24f58281..7b20be853f3c 100644
--- a/lang/mono/bsd.mono.mk
+++ b/lang/mono/bsd.mono.mk
@@ -6,16 +6,20 @@
# the FreeBSD ports system.
#
# $FreeBSD$
-# $Id: bsd.mono.mk,v 1.12 2006/04/05 02:38:44 tmclau02 Exp $
+# $Id: bsd.mono.mk,v 1.15 2006/07/05 04:22:22 tmclau02 Exp $
#
+# USE_NANT - If set, the port uses nant.
+# USE_NANT - If set "contrib", the port uses nantcontrib.
+# NANT - Set to path of Nant.
+
# Set the location of the .wapi directory so we write to a location we
# can always assume to be writable.
MONO_SHARED_DIR=${WRKDIR}
CONFIGURE_ENV+=MONO_SHARED_DIR="${MONO_SHARED_DIR}"
MAKE_ENV+=MONO_SHARED_DIR="${MONO_SHARED_DIR}"
-# Set the location that webaps served bp XSP should use.
+# Set the location that webaps served by XSP should use.
XSP_DOCROOT=${PREFIX}/www/xsp
# Clean up the semaphore produced by the .wapi
@@ -24,3 +28,35 @@ pre-clean: mono-semdel
mono-semdel:
@${SETENV} G_DEBUG="" MONO_SHARED_DIR="${MONO_SHARED_DIR}" ${LOCALBASE}/bin/mono-semdel 2> /dev/null || true
+
+
+# Dependencies
+
+.if defined(USE_NANT)
+BUILD_DEPENDS+= nant:${PORTSDIR}/devel/nant
+.if ${USE_NANT}=="contrib"
+BUILD_DEPENDS+= ${LOCALBASE}/share/NAnt/bin/NAnt.Contrib.Tests.dll:${PORTSDIR}/devel/nantcontrib
+.endif
+.endif
+
+# Miscellaneous overridable commands:
+
+NANT?= nant
+NANT_INSTALL_TARGET?= install
+
+# Build
+.if defined(USE_NANT)
+.if !target(do-build)
+do-build:
+ @(cd ${BUILD_WRKSRC}; ${SETENV} MONO_SHARED_DIR="${MONO_SHARED_DIR}" ${NANT} ${NANT_FLAGS})
+.endif
+.endif
+
+
+# Install
+.if defined(USE_NANT)
+.if !target(do-install)
+do-install:
+ @(cd ${INSTALL_WRKSRC}; ${SETENV} MONO_SHARED_DIR="${MONO_SHARED_DIR}" ${NANT} ${NANT_FLAGS} -D:prefix="${PREFIX}" ${NANT_INSTALL_TARGET})
+.endif
+.endif
diff --git a/lang/mono/distinfo b/lang/mono/distinfo
index 4bbacf66ebda..f814ea46707e 100644
--- a/lang/mono/distinfo
+++ b/lang/mono/distinfo
@@ -1,3 +1,3 @@
-MD5 (mono-1.1.13.6.tar.gz) = 330cc66c6a44525950daf10c4f17c10e
-SHA256 (mono-1.1.13.6.tar.gz) = ec60e3b670752c3453dfe8b76af0c1a17d60e81c842b375af7d3966d84329ea6
-SIZE (mono-1.1.13.6.tar.gz) = 18217583
+MD5 (mono-1.1.13.8.1.tar.gz) = 473c24c4be17b8e71393bc96bbda4bca
+SHA256 (mono-1.1.13.8.1.tar.gz) = 841cd62de1f61fefd17190dcc744e03f49c495039cc2088627ede9d9d825e21a
+SIZE (mono-1.1.13.8.1.tar.gz) = 17758715