aboutsummaryrefslogtreecommitdiff
path: root/lang/moscow_ml
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-11-03 13:12:44 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-11-03 13:12:44 +0000
commit7ddb770fa87f6041c66a388dc2a6aeee5e5352c1 (patch)
tree7f0924da91fa92b46ceb95fa1ccf0dd93b207fb3 /lang/moscow_ml
parent0598ae5c6551428d6621af660398377439267d22 (diff)
downloadports-7ddb770fa87f6041c66a388dc2a6aeee5e5352c1.tar.gz
ports-7ddb770fa87f6041c66a388dc2a6aeee5e5352c1.zip
Support gdbm (bump PORTREVISION)
Notes
Notes: svn path=/head/; revision=147121
Diffstat (limited to 'lang/moscow_ml')
-rw-r--r--lang/moscow_ml/Makefile4
-rw-r--r--lang/moscow_ml/files/patch-dynlibs::Makefile4
-rw-r--r--lang/moscow_ml/files/patch-dynlibs_mgdbm_Makefile25
-rw-r--r--lang/moscow_ml/files/pkg-message.in5
-rw-r--r--lang/moscow_ml/pkg-plist1
5 files changed, 35 insertions, 4 deletions
diff --git a/lang/moscow_ml/Makefile b/lang/moscow_ml/Makefile
index ea60c9a58aac..ba5a19c0e2f0 100644
--- a/lang/moscow_ml/Makefile
+++ b/lang/moscow_ml/Makefile
@@ -7,6 +7,7 @@
PORTNAME= moscow_ml
PORTVERSION= 2.01
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://www.dina.kvl.dk/~sestoft/mosml/
DISTNAME= mos201src
@@ -14,7 +15,8 @@ DISTNAME= mos201src
MAINTAINER= ports@FreeBSD.org
COMMENT= Moscow ML, a lightweight implementation of Standard ML
-LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4 \
+ gdbm.3:${PORTSDIR}/databases/gdbm
RESTRICTED= Restrictions on for-profit distribution.
diff --git a/lang/moscow_ml/files/patch-dynlibs::Makefile b/lang/moscow_ml/files/patch-dynlibs::Makefile
index 24c1429572dc..34f68ae4b2a3 100644
--- a/lang/moscow_ml/files/patch-dynlibs::Makefile
+++ b/lang/moscow_ml/files/patch-dynlibs::Makefile
@@ -15,7 +15,7 @@
+ #cd interface; make INCDIR=../../runtime
+ cd intinf; make INCDIR=../../runtime
+ #cd mgd; make INCDIR=../../runtime
-+ #cd mgdbm; make INCDIR=../../runtime
++ cd mgdbm; make INCDIR=../../runtime
+ #cd mmysql; make INCDIR=../../runtime
+ #cd mpq; make INCDIR=../../runtime
+ cd mregex; make INCDIR=../../runtime
@@ -33,7 +33,7 @@
- cd munix; make install
+ cd intinf; make INCDIR=../../runtime install
+ #cd mgd; make INCDIR=../../runtime install
-+ #cd mgdbm; make INCDIR=../../runtime install
++ cd mgdbm; make INCDIR=../../runtime install
+ #cd mmysql; make INCDIR=../../runtime install
+ #cd mpq; make INCDIR=../../runtime install
+ cd mregex; make INCDIR=../../runtime install
diff --git a/lang/moscow_ml/files/patch-dynlibs_mgdbm_Makefile b/lang/moscow_ml/files/patch-dynlibs_mgdbm_Makefile
new file mode 100644
index 000000000000..7992fdf8dbf2
--- /dev/null
+++ b/lang/moscow_ml/files/patch-dynlibs_mgdbm_Makefile
@@ -0,0 +1,25 @@
+
+$FreeBSD$
+
+--- dynlibs/mgdbm/Makefile.orig
++++ dynlibs/mgdbm/Makefile
+@@ -5,8 +5,8 @@
+
+ # Where to find GDBM header file and compiled library
+
+-GDBMLIBDIR=${HOME}/c/gdbm-1.7.3
+-GDBMINCDIR=${HOME}/c/gdbm-1.7.3
++GDBMLIBDIR=${LOCALBASE}/lib
++GDBMINCDIR=${LOCALBASE}/include
+ #GDBMLIBDIR=/usr/lib
+ #GDBMINCDIR=/usr/include
+
+@@ -25,7 +25,7 @@
+ $(CC) $(CFLAGS) -c -o mgdbm.o mgdbm.c
+
+ libmgdbm.so: mgdbm.o
+- $(DYNLD) -o libmgdbm.so mgdbm.o ${GDBMLIBDIR}/libgdbm.a
++ $(DYNLD) -o libmgdbm.so mgdbm.o -L${GDBMLIBDIR} -lgdbm
+
+ test:
+ mosml -P full testgdbm.sml
diff --git a/lang/moscow_ml/files/pkg-message.in b/lang/moscow_ml/files/pkg-message.in
index b71eb3621980..684c0803adf5 100644
--- a/lang/moscow_ml/files/pkg-message.in
+++ b/lang/moscow_ml/files/pkg-message.in
@@ -10,10 +10,13 @@ Bugs & Incompatibilities
1. Some C-libraries depending on other ports were not built. As a
consequence, the structures
- Gdbm, Gdimage, Mysql and Postgres
+ Gdimage, Mysql and Postgres
will fail to load.
+Note that this port is build with LD_RUN_PATH=%%PREFIX%%/lib/mosml,
+so you do not need set LD_LIBRARY_PATH to use any of the dynlibs.
+
2. The Regex structure now considers the empty string an invalid
regular expression. Certain GNU regex 0.12 specific performance hacks
could not be brought to work under FreeBSD, so expect a performance
diff --git a/lang/moscow_ml/pkg-plist b/lang/moscow_ml/pkg-plist
index 499a3436151b..4ce1aa80cb26 100644
--- a/lang/moscow_ml/pkg-plist
+++ b/lang/moscow_ml/pkg-plist
@@ -455,6 +455,7 @@ lib/mosml/Word8Vector.uo
lib/mosml/camlrunm
lib/mosml/header
lib/mosml/helpsigs.val
+lib/mosml/libmgdbm.so
lib/mosml/libmgmp.so
lib/mosml/libmregex.so
lib/mosml/libmsocket.so