aboutsummaryrefslogtreecommitdiff
path: root/lang/munger/Makefile
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2007-09-02 19:02:03 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2007-09-02 19:02:03 +0000
commit598e062ad81822026c67a43bb0053389cb761a3e (patch)
tree4f33d75432757929f7d742d4b83f40eea1f824d0 /lang/munger/Makefile
parenteff6ec1faee3855542c2b3c071c713a071194a54 (diff)
Notes
Diffstat (limited to 'lang/munger/Makefile')
-rw-r--r--lang/munger/Makefile25
1 files changed, 2 insertions, 23 deletions
diff --git a/lang/munger/Makefile b/lang/munger/Makefile
index d887458b0a71..a3ca73e7dafd 100644
--- a/lang/munger/Makefile
+++ b/lang/munger/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= munger
-PORTVERSION= 4.137
+PORTVERSION= 4.138
CATEGORIES= lang
MASTER_SITES= http://www.mammothcheese.ca/
@@ -18,10 +18,7 @@ DATADIR= ${PREFIX}/share/${PORTNAME}-${PORTVERSION}
MAN1= munger.1
MANCOMPRESSED= yes
-OPTIONS= FCGI "include FastCGI interface" on \
- SQL "include SQLite interface" on \
- TERM "include character-I/O functions" on \
- BN "include bignum support" off \
+OPTIONS= SQL "include SQLite interface" on \
DKNS "install Dickens text editor" off
USE_LDCONFIG= yes
@@ -33,19 +30,6 @@ USE_SQLITE= 3
MAKE_ARGS+= -DWITH_SQL
.endif
-.if !defined(WITHOUT_FCGI)
-LIB_DEPENDS+= fcgi.0:${PORTSDIR}/www/fcgi
-MAKE_ARGS+= -DWITH_FCGI
-.endif
-
-.if !defined(WITHOUT_TERM)
-MAKE_ARGS+= -DWITH_TERM
-.endif
-
-.if defined(WITH_BN)
-MAKE_ARGS+= -DWITH_BN
-.endif
-
.if defined(WITH_DKNS)
MAKE_ARGS+= -DWITH_DKNS
MAN1+= dkns.1
@@ -54,9 +38,4 @@ PLIST_SUB+= DKNS_BIN="bin/dkns"
PLIST_SUB+= DKNS_BIN="${DATADIR:S,^${PREFIX}/,,}/dkns.munger"
.endif
-post-build:
-.if !defined(WITHOUT_FCGI)
- @${CAT} ${PKGMESSAGE}
-.endif
-
.include <bsd.port.post.mk>