aboutsummaryrefslogtreecommitdiff
path: root/lang/neko
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2009-08-11 02:19:32 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2009-08-11 02:19:32 +0000
commitc6bd05c788ab2801f338577164279bed00d108f4 (patch)
tree3fcaddb6b971e8ce092209c6ad79cc027b56ae7d /lang/neko
parentd291df97ea6db9b3fb6427dce8034de137a1a283 (diff)
downloadports-c6bd05c788ab2801f338577164279bed00d108f4.tar.gz
ports-c6bd05c788ab2801f338577164279bed00d108f4.zip
Notes
Diffstat (limited to 'lang/neko')
-rw-r--r--lang/neko/Makefile22
-rw-r--r--lang/neko/distinfo6
-rw-r--r--lang/neko/files/patch-libs_mod_tora_protocol.c49
-rw-r--r--lang/neko/pkg-plist1
4 files changed, 24 insertions, 54 deletions
diff --git a/lang/neko/Makefile b/lang/neko/Makefile
index fe99bfe52ff2..c3d7383c137f 100644
--- a/lang/neko/Makefile
+++ b/lang/neko/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= neko
-PORTVERSION= 1.8.0
-PORTREVISION= 1
+PORTVERSION= 1.8.1
CATEGORIES= lang
MASTER_SITES= http://nekovm.org/_media/
@@ -22,6 +21,7 @@ USE_GMAKE= yes
OPTIONS= APACHE13 "Build with mod_neko for Apache 1.3.x" off \
APACHE22 "Build with mod_neko for Apache 2.2.x" off \
MYSQL4 "Build with MySQL 4.x library" off \
+ MYSQL5 "Build with MySQL 5.x library" off \
SQLITE3 "Build with Sqlite 3.x SQL library" off \
PCRE "Build with PCRE library" on \
GTK2 "Build with Gtk 2.x UI library" on
@@ -37,6 +37,10 @@ CFLAGS+= -I${WRKSRC} -I${LOCALBASE}/include
LDFLAGS+= -L${BC_DIR}/.libs -L${LOCALBASE}/lib
LIBKEYNAME=
+.if defined(WITH_APACHE13) && defined(WITH_APACHE22)
+IGNORE= option APACHE13 and APACHE22 conflict
+.endif
+
.if defined(WITH_APACHE13)
BUILD_DEPENDS+= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
RUN_DEPENDS+= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
@@ -57,6 +61,10 @@ LIBKEYNAME+= mod_neko2 mod_tora2
PLIST_SUB+= APACHE22="@comment "
.endif
+.if defined(WITH_MYSQL4) && defined(WITH_MYSQL5)
+IGNORE= option MYSQL4 and MYSQL5 conflict
+.endif
+
.if defined(WITH_MYSQL4)
BUILD_DEPENDS+= mysql:${PORTSDIR}/databases/mysql41-client
RUN_DEPENDS+= mysql:${PORTSDIR}/databases/mysql41-client
@@ -67,6 +75,16 @@ LIBKEYNAME+= mysql
PLIST_SUB+= MYSQL4="@comment "
.endif
+.if defined(WITH_MYSQL5)
+BUILD_DEPENDS+= mysql:${PORTSDIR}/databases/mysql51-client
+RUN_DEPENDS+= mysql:${PORTSDIR}/databases/mysql51-client
+CFLAGS+= -I${LOCALBASE}/include/mysql
+PLIST_SUB+= MYSQL5=
+.else
+LIBKEYNAME+= mysql5
+PLIST_SUB+= MYSQL5="@comment "
+.endif
+
.if defined(WITH_SQLITE3)
BUILD_DEPENDS+= sqlite3:${PORTSDIR}/databases/sqlite3
RUN_DEPENDS+= sqlite3:${PORTSDIR}/databases/sqlite3
diff --git a/lang/neko/distinfo b/lang/neko/distinfo
index f45b3eb02963..7399fa885e0c 100644
--- a/lang/neko/distinfo
+++ b/lang/neko/distinfo
@@ -1,3 +1,3 @@
-MD5 (neko-1.8.0.tar.gz) = b41da79e6f976818ab64805e9ba7298c
-SHA256 (neko-1.8.0.tar.gz) = 7a71c9cf3177c14e5afc114f060d43c4056cca8afa80ab08bdc76b83fdf803d3
-SIZE (neko-1.8.0.tar.gz) = 402210
+MD5 (neko-1.8.1.tar.gz) = 0e2029465a49e1da929f0e254c017701
+SHA256 (neko-1.8.1.tar.gz) = a51f861959056d02d46f8e7d0a59c9c154f371ceec16d4c4b0e93ff1f391775b
+SIZE (neko-1.8.1.tar.gz) = 438047
diff --git a/lang/neko/files/patch-libs_mod_tora_protocol.c b/lang/neko/files/patch-libs_mod_tora_protocol.c
deleted file mode 100644
index ba1c4fd68676..000000000000
--- a/lang/neko/files/patch-libs_mod_tora_protocol.c
+++ /dev/null
@@ -1,49 +0,0 @@
---- libs/mod_tora/protocol.c.orig 2009-06-19 17:15:56.000000000 +0900
-+++ libs/mod_tora/protocol.c 2009-06-19 17:17:33.000000000 +0900
-@@ -37,7 +37,7 @@
- cursor++; \
- }
-
--static int pwrite( mcontext *c, const char *buf, int len ) {
-+static int _pwrite( mcontext *c, const char *buf, int len ) {
- while( len > 0 ) {
- int k = send(c->sock,buf,len,MSG_NOSIGNAL);
- if( k <= 0 ) return 0;
-@@ -47,7 +47,7 @@
- return 1;
- }
-
--static int pread( mcontext *c, char *buf, int len ) {
-+static int _pread( mcontext *c, char *buf, int len ) {
- while( len > 0 ) {
- int k = recv(c->sock,buf,len,MSG_NOSIGNAL);
- if( k <= 0 ) return 0;
-@@ -63,8 +63,8 @@
- h[1] = (unsigned char)len;
- h[2] = (unsigned char)(len >> 8);
- h[3] = (unsigned char)(len >> 16);
-- pwrite(c,(char*)h,4);
-- pwrite(c,str,len);
-+ _pwrite(c,(char*)h,4);
-+ _pwrite(c,str,len);
- }
-
- static void psend( mcontext *c, proto_code code, const char *str ) {
-@@ -329,7 +329,7 @@
- int buflen = BUFSIZE;
- *exc = 0;
- while( true ) {
-- if( !pread(c,header,4) )
-+ if( !_pread(c,header,4) )
- ABORT("Connection Closed");
- len = header[1] | (header[2] << 8) | (header[3] << 16);
- if( buflen <= len ) {
-@@ -338,7 +338,7 @@
- free(buf);
- buf = (char*)malloc(buflen);
- }
-- if( !pread(c,buf,len) )
-+ if( !_pread(c,buf,len) )
- ABORT("Connection Closed");
- buf[len] = 0;
- switch( *header ) {
diff --git a/lang/neko/pkg-plist b/lang/neko/pkg-plist
index 3fda5b89e5f8..13a379595e82 100644
--- a/lang/neko/pkg-plist
+++ b/lang/neko/pkg-plist
@@ -11,6 +11,7 @@ lib/neko/zlib.ndll
%%APACHE22%%lib/neko/mod_neko2.ndll
%%APACHE22%%lib/neko/mod_tora2.ndll
%%MYSQL4%%lib/neko/mysql.ndll
+%%MYSQL5%%lib/neko/mysql5.ndll
%%SQLITE3%%lib/neko/sqlite.ndll
%%PCRE%%lib/neko/regexp.ndll
%%GTK2%%lib/neko/ui.ndll