aboutsummaryrefslogtreecommitdiff
path: root/lang/nickle/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-10-18 23:53:23 +0000
committerSteve Wills <swills@FreeBSD.org>2018-10-18 23:53:23 +0000
commit7a38e6ecf2ee32629149a577f1f2645d57fb38a3 (patch)
treea34ac0893e1521a015cb1630dae6ef5be271af54 /lang/nickle/Makefile
parent9fcb9007376fcb525429fa9a93e6f9cf640fe2f6 (diff)
downloadports-7a38e6ecf2ee32629149a577f1f2645d57fb38a3.tar.gz
ports-7a38e6ecf2ee32629149a577f1f2645d57fb38a3.zip
Notes
Diffstat (limited to 'lang/nickle/Makefile')
-rw-r--r--lang/nickle/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/lang/nickle/Makefile b/lang/nickle/Makefile
index c044c01126ef..26f69e8fff7a 100644
--- a/lang/nickle/Makefile
+++ b/lang/nickle/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= nickle
-PORTVERSION= 2.81
+PORTVERSION= 2.82
CATEGORIES= lang
MASTER_SITES= http://www.nickle.org/release/
@@ -10,9 +10,12 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Numeric-oriented programming language
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
USES= gmake ncurses readline
+
GNU_CONFIGURE= yes
+PORTEXAMPLES= *
# Nickle now has bindings which are likely to pull in libraries that need
# libpthread. Link to it now explicitly, or it wouldn't work at runtime.
@@ -24,13 +27,9 @@ post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS/s|examples|| ; s| -O2||' \
${WRKSRC}/Makefile.in
-post-install:
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- (cd ${WRKSRC}/examples && ${FIND} . ! \( -name "*Makefile*" -or \
- -name "*.sgml" \) | ${CPIO} -pdm -L \
- -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${EXAMPLESDIR})
- @${FIND} ${STAGEDIR}${EXAMPLESDIR} -type d | ${XARGS} ${CHMOD} a+rx
- @${FIND} ${STAGEDIR}${EXAMPLESDIR} -type f | ${XARGS} ${CHMOD} \
- ${SHAREMODE}
+ ${FIND} ${WRKSRC}/examples -name 'Makefile*' -exec ${RM} {} +
+ cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . "${STAGEDIR}${EXAMPLESDIR}"
.include <bsd.port.mk>