aboutsummaryrefslogtreecommitdiff
path: root/lang/ocaml/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-03-24 17:52:28 +0000
committerSteve Price <steve@FreeBSD.org>1999-03-24 17:52:28 +0000
commitd23e804a4833ebf8a43a3895a34f439d1a92d13f (patch)
treeb2e1023cdb0896d3e48f5333ed1ddb32a89aa366 /lang/ocaml/Makefile
parentbaaa8fa5f6e3e8ad0401a695377d15a09ad1d9ac (diff)
downloadports-d23e804a4833ebf8a43a3895a34f439d1a92d13f.tar.gz
ports-d23e804a4833ebf8a43a3895a34f439d1a92d13f.zip
Notes
Diffstat (limited to 'lang/ocaml/Makefile')
-rw-r--r--lang/ocaml/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/lang/ocaml/Makefile b/lang/ocaml/Makefile
index 67d65c48db69..2217bd03e558 100644
--- a/lang/ocaml/Makefile
+++ b/lang/ocaml/Makefile
@@ -3,34 +3,39 @@
# Date created: 24 December 1996
# Whom: Kiriyama Kazuhiko <kiri@kiri.toba-cmt.ac.jp>
#
-# $Id: Makefile,v 1.3 1998/02/21 15:46:28 steve Exp $
+# $Id: Makefile,v 1.4 1998/11/28 09:07:13 asami Exp $
#
-DISTNAME= ocaml-1.07
+DISTNAME= ocaml-2.02
CATEGORIES= lang
-MASTER_SITES= ftp://ftp.kurims.kyoto-u.ac.jp/pub/lang/caml-light/ \
- ftp://ftp.inria.fr/lang/caml-light/
+MASTER_SITES= ftp://ftp.inria.fr/lang/caml-light/ \
+ ftp://ftp.kurims.kyoto-u.ac.jp/pub/lang/caml-light/
DISTFILES= ${DISTNAME}.tar.gz ${DOCFILES}
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}-refman.html${EXTRACT_SUFX}
-MAINTAINER= kiri@kiri.toba-cmt.ac.jp
+MAINTAINER= ortmann@isl.net
USE_XLIB= yes
HAS_CONFIGURE= yes
USE_GMAKE= yes
ALL_TARGET= world bootstrap opt
+# targets not yet working (due to Elf) ==> ocamlc.opt ocamlopt.opt
+
MAN1= ocaml.1 ocamlc.1 ocamlcp.1 ocamldep.1 ocamllex.1 \
- ocamlopt.1 ocamlprof.1 ocamlrun.1 ocamlyacc.1
+ ocamlopt.1 ocamlprof.1 ocamlrun.1 ocamlyacc.1 ocamlmktop.1
+# manpages not yet installing (due to Elf) ==> ocamlc.opt.1 ocamlopt.opt.1
CONFIGURE_ENV= PREFIX=${PREFIX} X11BASE=${X11BASE} BATCH=${BATCH}
.if !defined(NOPORTDOCS)
-DOCFILES= ${DISTNAME}-refman.html.tar.gz
+DOCFILES= ${DISTNAME}-refman.html.tar.gz ${DISTNAME}-refman.ps.gz
.endif
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/ocaml/html
@cd ${WRKDIR}/htmlman; ${INSTALL_DATA} * ${PREFIX}/share/doc/ocaml/html
+ @cp ${DISTDIR}/${DISTNAME}-refman.ps.gz ${PREFIX}/share/doc/ocaml
.endif
@strip ${PREFIX}/bin/ocamlrun ${PREFIX}/bin/ocamlyacc