aboutsummaryrefslogtreecommitdiff
path: root/lang/ocaml/files
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2003-12-06 00:05:05 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2003-12-06 00:05:05 +0000
commitb56504f9274dbaa19f0e4357d4ae80f51f8704a6 (patch)
treedb32539c03ae98a4e0b6c0bf47542401a6eb937a /lang/ocaml/files
parent7caa6ea81991b8bfb1286dd60be354545457fe9a (diff)
Notes
Diffstat (limited to 'lang/ocaml/files')
-rw-r--r--lang/ocaml/files/patch-camlp4-man::Makefile34
-rw-r--r--lang/ocaml/files/patch-ocamldoc::Makefile16
-rw-r--r--lang/ocaml/files/patch-stack_overflow15
3 files changed, 26 insertions, 39 deletions
diff --git a/lang/ocaml/files/patch-camlp4-man::Makefile b/lang/ocaml/files/patch-camlp4-man::Makefile
index f76e5f3ec611..193781dd4bb6 100644
--- a/lang/ocaml/files/patch-camlp4-man::Makefile
+++ b/lang/ocaml/files/patch-camlp4-man::Makefile
@@ -1,19 +1,21 @@
---- camlp4/man/Makefile.orig Fri Jul 19 16:53:49 2002
-+++ camlp4/man/Makefile Fri Aug 2 00:07:34 2002
-@@ -14,14 +14,8 @@
- get_promote:
+--- camlp4/man/Makefile.orig Sat Nov 22 17:30:44 2003
++++ camlp4/man/Makefile Sat Nov 22 04:48:25 2003
+@@ -3,7 +3,6 @@
+ include ../config/Makefile
- install:
-- -$(MKDIR) $(MANDIR)/man1
-- -cp $(TARGET) $(MANDIR)/man1/.
-- -cd $(MANDIR)/man1; rm -f camlp4o.1; ln -s $(TARGET) camlp4o.1
-- -cd $(MANDIR)/man1; rm -f camlp4r.1; ln -s $(TARGET) camlp4r.1
-- -cd $(MANDIR)/man1; rm -f mkcamlp4.1; ln -s $(TARGET) mkcamlp4.1
-- -cd $(MANDIR)/man1; rm -f ocpp.1; ln -s $(TARGET) ocpp.1
-- -cd $(MANDIR)/man1; rm -f camlp4o.opt.1; ln -s $(TARGET) camlp4o.opt.1
-- -cd $(MANDIR)/man1; rm -f camlp4r.opt.1; ln -s $(TARGET) camlp4r.opt.1
-+ -$(MKDIR) $(MANDIR)/man1
-+ -cp $(TARGET) $(MANDIR)/man1/.
+ TARGET=camlp4.1
+-ALIASES=camlp4o.1 camlp4r.1 mkcamlp4.1 ocpp.1 camlp4o.opt.1 camlp4r.opt.1
+
+ all: $(TARGET)
+
+@@ -18,10 +17,6 @@
+ if test -n '$(MANDIR)'; then \
+ $(MKDIR) $(MANDIR)/man1 ; \
+ cp $(TARGET) $(MANDIR)/man1/. ; \
+- for i in $(ALIASES); do \
+- rm -f $(MANDIR)/man1/$$i; \
+- echo '.so man1/$(TARGET)' > $(MANDIR)/man1/$$i; \
+- done; \
+ fi
camlp4.1: camlp4.1.tpl
- sed -e "s'LIBDIR'$(LIBDIR)'g" camlp4.1.tpl > camlp4.1
diff --git a/lang/ocaml/files/patch-ocamldoc::Makefile b/lang/ocaml/files/patch-ocamldoc::Makefile
index dbcc9a59e684..544893e26311 100644
--- a/lang/ocaml/files/patch-ocamldoc::Makefile
+++ b/lang/ocaml/files/patch-ocamldoc::Makefile
@@ -1,21 +1,21 @@
---- ocamldoc/Makefile.orig Fri Aug 2 00:25:13 2002
-+++ ocamldoc/Makefile Fri Aug 2 01:36:33 2002
+--- ocamldoc/Makefile.orig Sat Nov 22 17:38:34 2003
++++ ocamldoc/Makefile Sat Nov 22 04:34:14 2003
@@ -40,7 +40,7 @@
OCAMLDOC_LIBA=odoc_info.a
INSTALL_LIBDIR=$(OCAMLLIB)/ocamldoc
INSTALL_BINDIR=$(OCAMLBIN)
--INSTALL_MANODIR=$(MANDIR)/mano
+-INSTALL_MANODIR=$(MANDIR)/man3
+INSTALL_MANODIR=$(MANDIR)/mann
- INSTALL_MLIS=odoc_info.mli odoc_args.mli
+ INSTALL_MLIS=odoc_info.mli
INSTALL_CMIS=$(INSTALL_MLIS:.mli=.cmi)
-@@ -275,7 +275,9 @@
- $(CP) ocamldoc.sty ocamldoc.hva *.cmi $(GENERATORS) $(OCAMLDOC_LIBCMA) $(INSTALL_LIBDIR)
+@@ -281,7 +281,9 @@
+ $(CP) ocamldoc.hva *.cmi $(GENERATORS) $(OCAMLDOC_LIBCMA) $(INSTALL_LIBDIR)
$(CP) $(INSTALL_MLIS) $(INSTALL_CMIS) $(INSTALL_LIBDIR)
if test -d $(INSTALL_MANODIR); then : ; else $(MKDIR) $(INSTALL_MANODIR); fi
- $(CP) stdlib_man/* $(INSTALL_MANODIR)
-+ for f in stdlib_man/*;do \
-+ $(CP) $$f $(INSTALL_MANODIR)/`basename $$f .o`.n;\
++ for f in stdlib_man/*; do \
++ $(CP) $$f $(INSTALL_MANODIR)/`basename $$f .3o`.n; \
+ done
installopt:
diff --git a/lang/ocaml/files/patch-stack_overflow b/lang/ocaml/files/patch-stack_overflow
deleted file mode 100644
index a9f951b363bc..000000000000
--- a/lang/ocaml/files/patch-stack_overflow
+++ /dev/null
@@ -1,15 +0,0 @@
---- configure.orig Tue Mar 18 22:40:03 2003
-+++ configure Tue Mar 18 22:40:38 2003
-@@ -962,9 +962,9 @@
-
- case "$arch,$model,$system" in
- i386,*,*)
-- case "$host" in # Check for FreeBSD 4.5 bug
-- *-*-freebsd*|*-*-openbsd*) check_pthread=yes ;;
-- *) check_pthread=no ;;
-+ case "$host" in
-+ *-*-openbsd*) check_pthread=yes ;;
-+ *) check_pthread=no ;;
- esac
- if ./runtest -DTARGET_$arch -DSYS_$system stackov.c \
- && test $check_pthread = no || cclibs="-pthread $cclibs" \