aboutsummaryrefslogtreecommitdiff
path: root/lang/ocaml
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-08-12 20:06:45 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-08-12 20:06:45 +0000
commit75d568f62c19bf520e85df2aa1467f8ffd067e75 (patch)
tree2acfe3a1df21abefb43561afe96fca2c63711463 /lang/ocaml
parentdc70f71aa4b0e29281db86b7c5ee59d414ed060e (diff)
downloadports-75d568f62c19bf520e85df2aa1467f8ffd067e75.tar.gz
ports-75d568f62c19bf520e85df2aa1467f8ffd067e75.zip
Notes
Diffstat (limited to 'lang/ocaml')
-rw-r--r--lang/ocaml/Makefile23
-rw-r--r--lang/ocaml/distinfo6
-rw-r--r--lang/ocaml/pkg-plist16
3 files changed, 34 insertions, 11 deletions
diff --git a/lang/ocaml/Makefile b/lang/ocaml/Makefile
index 157ce603f184..6e6c60fd30ae 100644
--- a/lang/ocaml/Makefile
+++ b/lang/ocaml/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ocaml
-PORTVERSION= 3.01
+PORTVERSION= 3.02
CATEGORIES= lang
MASTER_SITES= http://caml.inria.fr/distrib/ \
ftp://ftp.inria.fr/lang/caml-light/ \
@@ -16,8 +16,12 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}-refman.html${EXTRACT_SUFX}
MAINTAINER= patrick@watson.org
+WITH_TK= yes
+
.if defined(WITH_TK)
PLIST_SUB+= LABLTK:=""
+BUILD_DEPENDS+= ${LOCALBASE}/include/tcl8.3:${PORTSDIR}/lang/tcl83
+BUILD_DEPENDS+= ${LOCALBASE}/include/tk8.3:${PORTSDIR}/x11-toolkits/tk83
LIB_DEPENDS= tk83.1:${PORTSDIR}/x11-toolkits/tk83
.else
PLIST_SUB+= LABLTK:="@comment "
@@ -25,7 +29,7 @@ PLIST_SUB+= LABLTK:="@comment "
USE_XLIB= yes
HAS_CONFIGURE= yes
-ALL_TARGET= world bootstrap opt opt.opt
+ALL_TARGET= world opt opt.opt
.if ${MACHINE_ARCH} != "i386"
PLIST_SUB+= PROF:="@comment "
@@ -51,12 +55,17 @@ DOCFILES= ${DISTNAME}-refman.html.tar.gz ${DISTNAME}-refman.ps.gz
.endif
post-install:
- @${MKDIR} ${PREFIX}/share/doc/ocaml
- ${INSTALL_DATA} ${WRKSRC}/LICENSE ${PREFIX}/share/doc/ocaml/
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/LICENSE ${DOCSDIR}/
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/ocaml/html
- @cd ${WRKDIR}/htmlman; ${INSTALL_DATA} * ${PREFIX}/share/doc/ocaml/html
- @${CP} ${DISTDIR}/${DISTNAME}-refman.ps.gz ${PREFIX}/share/doc/ocaml
+ @${MKDIR} ${DOCSDIR}/html
+ @cd ${WRKDIR}/htmlman; ${INSTALL_DATA} * ${DOCSDIR}/html
+ @${CP} ${DISTDIR}/${DISTNAME}-refman.ps.gz ${DOCSDIR}
+.endif
+.if defined(WITH_TK)
+ @${MKDIR} ${PREFIX}/share/examples/ocaml
+ @${MKDIR} ${PREFIX}/share/examples/ocaml/labltk
+ @cd ${WRKSRC}/otherlibs/labltk/example; ${INSTALL_DATA} * ${PREFIX}/share/examples/ocaml/labltk
.endif
@strip ${PREFIX}/bin/ocamlrun ${PREFIX}/bin/ocamlyacc
diff --git a/lang/ocaml/distinfo b/lang/ocaml/distinfo
index f13a96235af7..decb44e96297 100644
--- a/lang/ocaml/distinfo
+++ b/lang/ocaml/distinfo
@@ -1,3 +1,3 @@
-MD5 (ocaml-3.01.tar.gz) = 9359b1d827dcbd40a9321ed389d6a54b
-MD5 (ocaml-3.01-refman.html.tar.gz) = ae2e0e385600a6987ecdf1a50dafab53
-MD5 (ocaml-3.01-refman.ps.gz) = f8a0b2892f66884480a4a393a1ca241d
+MD5 (ocaml-3.02.tar.gz) = 2184258b41d3975648a4ebbb615c5046
+MD5 (ocaml-3.02-refman.html.tar.gz) = b2aeaa11f3ba48d59deb3fe1693606d4
+MD5 (ocaml-3.02-refman.ps.gz) = 6dc24a8b1f98b91e7ab8ecd34a90d59c
diff --git a/lang/ocaml/pkg-plist b/lang/ocaml/pkg-plist
index 1f9baeb0c78e..425495973dbf 100644
--- a/lang/ocaml/pkg-plist
+++ b/lang/ocaml/pkg-plist
@@ -188,7 +188,9 @@ lib/ocaml/condition.mli
lib/ocaml/mutex.mli
lib/ocaml/thread.mli
lib/ocaml/libgraphics.a
+lib/ocaml/graphicsX11.mli
lib/ocaml/graphics.mli
+lib/ocaml/graphicsX11.cmi
lib/ocaml/graphics.cmi
lib/ocaml/graphics.cma
lib/ocaml/libmldbm.a
@@ -394,6 +396,16 @@ lib/ocaml/dbm.cmx
%%LABLTK:%%lib/ocaml/labltk/fileselect.cmx
%%LABLTK:%%lib/ocaml/labltk/libjpf.a
%%LABLTK:%%lib/ocaml/labltk/libjpf.cmxa
+%%LABLTK:%%share/examples/ocaml/labltk/Lambda2.back.gif
+%%LABLTK:%%share/examples/ocaml/labltk/Makefile
+%%LABLTK:%%share/examples/ocaml/labltk/README
+%%LABLTK:%%share/examples/ocaml/labltk/calc.ml
+%%LABLTK:%%share/examples/ocaml/labltk/clock.ml
+%%LABLTK:%%share/examples/ocaml/labltk/demo.ml
+%%LABLTK:%%share/examples/ocaml/labltk/eyes.ml
+%%LABLTK:%%share/examples/ocaml/labltk/hello.ml
+%%LABLTK:%%share/examples/ocaml/labltk/hello.tcl
+%%LABLTK:%%share/examples/ocaml/labltk/tetris.ml
share/doc/ocaml/LICENSE
share/doc/ocaml/html/contents_motif.gif
share/doc/ocaml/html/index.html
@@ -478,10 +490,12 @@ share/doc/ocaml/html/manual074.html
share/doc/ocaml/html/manual075.html
share/doc/ocaml/html/next_motif.gif
share/doc/ocaml/html/previous_motif.gif
-share/doc/ocaml/ocaml-3.01-refman.ps.gz
+share/doc/ocaml/ocaml-3.02-refman.ps.gz
@dirrm share/doc/ocaml/html
@dirrm share/doc/ocaml
@dirrm lib/ocaml/caml
@dirrm lib/ocaml/threads
%%LABLTK:%%@dirrm lib/ocaml/labltk
+%%LABLTK:%%@dirrm share/examples/ocaml/labltk
+%%LABLTK:%%@dirrm share/examples/ocaml
@dirrm lib/ocaml