aboutsummaryrefslogtreecommitdiff
path: root/lang/onyx
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2014-08-29 12:41:40 +0000
committerWen Heping <wen@FreeBSD.org>2014-08-29 12:41:40 +0000
commit9d83c39a9fa71197baf0965714a696cf340fc451 (patch)
tree60a75493f86aecd35a12472236d02d1e750474be /lang/onyx
parent1ab88a2deb9aa235f028300c6bc7e366927f56c3 (diff)
downloadports-9d83c39a9fa71197baf0965714a696cf340fc451.tar.gz
ports-9d83c39a9fa71197baf0965714a696cf340fc451.zip
- Stage support
- Add LICENSE - Pass maintainership to submitter PR: 193018 Submitted by: Muhammad Moinur Rahman <5u623l20@gmail.com>
Notes
Notes: svn path=/head/; revision=366505
Diffstat (limited to 'lang/onyx')
-rw-r--r--lang/onyx/Makefile43
-rw-r--r--lang/onyx/files/pkg-message.in1
-rw-r--r--lang/onyx/pkg-message1
-rw-r--r--lang/onyx/pkg-plist357
4 files changed, 220 insertions, 182 deletions
diff --git a/lang/onyx/Makefile b/lang/onyx/Makefile
index 0bee4fce20c5..e1b7bcde4089 100644
--- a/lang/onyx/Makefile
+++ b/lang/onyx/Makefile
@@ -3,31 +3,32 @@
PORTNAME= onyx
PORTVERSION= 5.1.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang
MASTER_SITES= http://www.canonware.com/download/onyx/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= 5u623l20@gmail.com
COMMENT= Embeddable stack-based threaded interpreted language
+LICENSE= BSD2CLAUSE
+
BUILD_DEPENDS= cook:${PORTSDIR}/devel/cook
LIB_DEPENDS= libedit.so:${PORTSDIR}/devel/libedit \
libpcre.so:${PORTSDIR}/devel/pcre
-USES= tar:bzip2
+USES= tar:bzip2 shebangfix
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libedit-prefix=${LOCALBASE} \
--with-pcre-prefix=${LOCALBASE}
USE_LDCONFIG= yes
+SUB_FILES= pkg-message
+OPTIONS_DEFINE= DOCS
PLIST_SUB= ONYX_VERSION=${PORTVERSION}
-MAN1= onyx.1 onyx_config.1
-
-NO_STAGE= yes
-
BROKEN_ia64= Coredump during build on ia64
+.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@@ -35,10 +36,28 @@ do-build:
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} cook)
do-install:
- @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} cook install)
-
-post-install:
- @${STRIP_CMD} ${PREFIX}/bin/onyx
- @${CAT} ${PKGMESSAGE}
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/onyx/bin/onyx ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/onyx_config/bin/onyx_config ${STAGEDIR}${PREFIX}/bin
+ ${LN} -sf bin/onyx ${STAGEDIR}${PREFIX}/bin/${PORTNAME}-${PORTVERSION}
+ ${LN} -sf bin/onyx_config ${STAGEDIR}${PREFIX}/bin/${PORTNAME}_config-${PORTVERSION}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/include/libonyx
+ ${INSTALL_DATA} ${WRKSRC}/lib/libonyx/include/libonyx/*.h ${STAGEDIR}${PREFIX}/include/libonyx
+ ${INSTALL_LIB} ${WRKSRC}/lib/libonyx/lib/libonyx.a ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_LIB} ${WRKSRC}/lib/libonyx/lib/libonyx.so ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_LIB} ${WRKSRC}/lib/libonyx/lib/libonyx.so.13 ${STAGEDIR}${PREFIX}/lib
+ ${MKDIR} ${STAGEDIR}${DATADIR}/nx/modclopt
+ ${INSTALL_DATA} ${WRKSRC}/mod/modclopt/nx/modclopt/*.nx ${STAGEDIR}${DATADIR}/nx/modclopt
+ ${MKDIR} ${STAGEDIR}${DATADIR}/libonyx
+ ${INSTALL_DATA} ${WRKSRC}/lib/libonyx/src/libonyx_init.nx ${STAGEDIR}${DATADIR}/libonyx
+ ${MKDIR} ${STAGEDIR}${DATADIR}/nx/modprompt
+ ${INSTALL_DATA} ${WRKSRC}/mod/modprompt/nx/modprompt/modprompt.nx ${STAGEDIR}${DATADIR}/nx/modprompt
+ ${INSTALL_MAN} ${WRKSRC}/bin/onyx/man/man1/onyx.1 ${STAGEDIR}${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/bin/onyx_config/man/man1/onyx_config.1 ${STAGEDIR}${PREFIX}/man/man1
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/html
+ (cd ${WRKSRC}/doc/html/onyx && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}/html)
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/pdf
+ ${INSTALL_DATA} ${WRKSRC}/doc/pdf/onyx/onyx.pdf ${STAGEDIR}${DOCSDIR}/pdf
+.endif
.include <bsd.port.mk>
diff --git a/lang/onyx/files/pkg-message.in b/lang/onyx/files/pkg-message.in
new file mode 100644
index 000000000000..3cdc3fbbe79d
--- /dev/null
+++ b/lang/onyx/files/pkg-message.in
@@ -0,0 +1 @@
+See %%DOCSDIR%% for documentation in HTML and PDF formats.
diff --git a/lang/onyx/pkg-message b/lang/onyx/pkg-message
deleted file mode 100644
index 7a0ebf4f74e7..000000000000
--- a/lang/onyx/pkg-message
+++ /dev/null
@@ -1 +0,0 @@
-See ${PREFIX}/share/doc/onyx/ for documentation in HTML and PDF formats.
diff --git a/lang/onyx/pkg-plist b/lang/onyx/pkg-plist
index b3787f44b238..de2692a300f4 100644
--- a/lang/onyx/pkg-plist
+++ b/lang/onyx/pkg-plist
@@ -5,7 +5,9 @@ bin/onyx_config-%%ONYX_VERSION%%
include/libonyx/ch.h
include/libonyx/cnd.h
include/libonyx/dch.h
+include/libonyx/envdict_l.h
include/libonyx/gcdict.h
+include/libonyx/gcdict_l.h
include/libonyx/libonyx.h
include/libonyx/libonyx_defs.h
include/libonyx/mb.h
@@ -13,210 +15,227 @@ include/libonyx/mem.h
include/libonyx/mq.h
include/libonyx/mtx.h
include/libonyx/nx.h
+include/libonyx/nx_l.h
include/libonyx/nxa.h
+include/libonyx/nxa_l.h
include/libonyx/nxm.h
include/libonyx/nxn.h
include/libonyx/nxo.h
include/libonyx/nxo_array.h
+include/libonyx/nxo_array_l.h
include/libonyx/nxo_boolean.h
include/libonyx/nxo_class.h
+include/libonyx/nxo_class_l.h
include/libonyx/nxo_condition.h
+include/libonyx/nxo_condition_l.h
include/libonyx/nxo_dict.h
+include/libonyx/nxo_dict_l.h
include/libonyx/nxo_file.h
+include/libonyx/nxo_file_l.h
include/libonyx/nxo_fino.h
include/libonyx/nxo_handle.h
+include/libonyx/nxo_handle_l.h
include/libonyx/nxo_instance.h
+include/libonyx/nxo_instance_l.h
include/libonyx/nxo_integer.h
+include/libonyx/nxo_l.h
include/libonyx/nxo_mark.h
include/libonyx/nxo_mutex.h
+include/libonyx/nxo_mutex_l.h
include/libonyx/nxo_name.h
+include/libonyx/nxo_name_l.h
include/libonyx/nxo_no.h
include/libonyx/nxo_null.h
include/libonyx/nxo_operator.h
+include/libonyx/nxo_operator_l.h
include/libonyx/nxo_pmark.h
include/libonyx/nxo_real.h
include/libonyx/nxo_regex.h
+include/libonyx/nxo_regex_l.h
include/libonyx/nxo_regsub.h
+include/libonyx/nxo_regsub_l.h
include/libonyx/nxo_stack.h
+include/libonyx/nxo_stack_l.h
include/libonyx/nxo_string.h
+include/libonyx/nxo_string_l.h
include/libonyx/nxo_thread.h
+include/libonyx/nxo_thread_l.h
+include/libonyx/origin_l.h
include/libonyx/ql.h
include/libonyx/qr.h
include/libonyx/qs.h
include/libonyx/systemdict.h
+include/libonyx/systemdict_l.h
include/libonyx/thd.h
include/libonyx/tsd.h
include/libonyx/xep.h
lib/libonyx.a
lib/libonyx.so
lib/libonyx.so.13
-share/doc/onyx
-share/doc/onyx-%%ONYX_VERSION%%/html/contents.png
-share/doc/onyx-%%ONYX_VERSION%%/html/img1.png
-share/doc/onyx-%%ONYX_VERSION%%/html/img10.png
-share/doc/onyx-%%ONYX_VERSION%%/html/img11.png
-share/doc/onyx-%%ONYX_VERSION%%/html/img12.png
-share/doc/onyx-%%ONYX_VERSION%%/html/img13.png
-share/doc/onyx-%%ONYX_VERSION%%/html/img14.png
-share/doc/onyx-%%ONYX_VERSION%%/html/img15.png
-share/doc/onyx-%%ONYX_VERSION%%/html/img2.png
-share/doc/onyx-%%ONYX_VERSION%%/html/img3.png
-share/doc/onyx-%%ONYX_VERSION%%/html/img4.png
-share/doc/onyx-%%ONYX_VERSION%%/html/img5.png
-share/doc/onyx-%%ONYX_VERSION%%/html/img6.png
-share/doc/onyx-%%ONYX_VERSION%%/html/img7.png
-share/doc/onyx-%%ONYX_VERSION%%/html/img8.png
-share/doc/onyx-%%ONYX_VERSION%%/html/img9.png
-share/doc/onyx-%%ONYX_VERSION%%/html/index.html
-share/doc/onyx-%%ONYX_VERSION%%/html/index.png
-share/doc/onyx-%%ONYX_VERSION%%/html/next.png
-share/doc/onyx-%%ONYX_VERSION%%/html/next_g.png
-share/doc/onyx-%%ONYX_VERSION%%/html/node1.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node10.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node100.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node101.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node102.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node103.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node104.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node105.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node106.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node107.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node108.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node109.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node11.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node110.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node111.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node112.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node113.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node114.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node115.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node116.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node117.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node118.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node119.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node12.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node120.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node121.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node122.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node123.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node124.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node13.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node14.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node15.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node16.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node17.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node18.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node19.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node2.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node20.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node21.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node22.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node23.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node24.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node25.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node26.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node27.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node28.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node29.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node3.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node30.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node31.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node32.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node33.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node34.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node35.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node36.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node37.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node38.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node39.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node4.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node40.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node41.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node42.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node43.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node44.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node45.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node46.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node47.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node48.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node49.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node5.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node50.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node51.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node52.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node53.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node54.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node55.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node56.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node57.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node58.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node59.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node6.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node60.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node61.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node62.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node63.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node64.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node65.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node66.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node67.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node68.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node69.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node7.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node70.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node71.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node72.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node73.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node74.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node75.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node76.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node77.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node78.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node79.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node8.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node80.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node81.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node82.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node83.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node84.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node85.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node86.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node87.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node88.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node89.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node9.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node90.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node91.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node92.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node93.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node94.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node95.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node96.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node97.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node98.html
-share/doc/onyx-%%ONYX_VERSION%%/html/node99.html
-share/doc/onyx-%%ONYX_VERSION%%/html/onyx.css
-share/doc/onyx-%%ONYX_VERSION%%/html/onyx.html
-share/doc/onyx-%%ONYX_VERSION%%/html/prev.png
-share/doc/onyx-%%ONYX_VERSION%%/html/prev_g.png
-share/doc/onyx-%%ONYX_VERSION%%/html/up.png
-share/doc/onyx-%%ONYX_VERSION%%/html/up_g.png
-share/doc/onyx-%%ONYX_VERSION%%/pdf/onyx.pdf
-share/onyx
-share/onyx-%%ONYX_VERSION%%/libonyx/libonyx_init.nx
-share/onyx-%%ONYX_VERSION%%/nx/modclopt/clopt.nx
-share/onyx-%%ONYX_VERSION%%/nx/modclopt/modclopt.nx
-share/onyx-%%ONYX_VERSION%%/nx/modclopt/modclopt_defs.nx
-share/onyx-%%ONYX_VERSION%%/nx/modprompt/modprompt.nx
-share/onyx-%%ONYX_VERSION%%/nx/modprompt/modprompt_defs.nx
-share/onyx-%%ONYX_VERSION%%/nxm/modprompt.nxm
-@dirrm share/onyx-%%ONYX_VERSION%%/nxm
-@dirrm share/onyx-%%ONYX_VERSION%%/nx/modprompt
-@dirrm share/onyx-%%ONYX_VERSION%%/nx/modclopt
-@dirrm share/onyx-%%ONYX_VERSION%%/nx
-@dirrm share/onyx-%%ONYX_VERSION%%/libonyx
-@dirrm share/onyx-%%ONYX_VERSION%%
-@dirrm share/doc/onyx-%%ONYX_VERSION%%/pdf
-@dirrm share/doc/onyx-%%ONYX_VERSION%%/html
-@dirrm share/doc/onyx-%%ONYX_VERSION%%
+man/man1/onyx.1.gz
+man/man1/onyx_config.1.gz
+%%PORTDOCS%%%%DOCSDIR%%/html/contents.png
+%%PORTDOCS%%%%DOCSDIR%%/html/img1.png
+%%PORTDOCS%%%%DOCSDIR%%/html/img10.png
+%%PORTDOCS%%%%DOCSDIR%%/html/img11.png
+%%PORTDOCS%%%%DOCSDIR%%/html/img12.png
+%%PORTDOCS%%%%DOCSDIR%%/html/img13.png
+%%PORTDOCS%%%%DOCSDIR%%/html/img14.png
+%%PORTDOCS%%%%DOCSDIR%%/html/img15.png
+%%PORTDOCS%%%%DOCSDIR%%/html/img2.png
+%%PORTDOCS%%%%DOCSDIR%%/html/img3.png
+%%PORTDOCS%%%%DOCSDIR%%/html/img4.png
+%%PORTDOCS%%%%DOCSDIR%%/html/img5.png
+%%PORTDOCS%%%%DOCSDIR%%/html/img6.png
+%%PORTDOCS%%%%DOCSDIR%%/html/img7.png
+%%PORTDOCS%%%%DOCSDIR%%/html/img8.png
+%%PORTDOCS%%%%DOCSDIR%%/html/img9.png
+%%PORTDOCS%%%%DOCSDIR%%/html/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/index.png
+%%PORTDOCS%%%%DOCSDIR%%/html/next.png
+%%PORTDOCS%%%%DOCSDIR%%/html/next_g.png
+%%PORTDOCS%%%%DOCSDIR%%/html/node1.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node10.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node100.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node101.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node102.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node103.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node104.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node105.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node106.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node107.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node108.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node109.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node11.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node110.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node111.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node112.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node113.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node114.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node115.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node116.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node117.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node118.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node119.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node12.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node120.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node121.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node122.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node123.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node124.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node13.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node14.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node15.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node16.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node17.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node18.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node19.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node2.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node20.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node21.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node22.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node23.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node24.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node25.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node26.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node27.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node28.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node29.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node30.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node31.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node32.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node33.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node34.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node35.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node36.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node37.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node38.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node39.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node4.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node40.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node41.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node42.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node43.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node44.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node45.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node46.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node47.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node48.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node49.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node5.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node50.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node51.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node52.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node53.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node54.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node55.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node56.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node57.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node58.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node59.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node6.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node60.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node61.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node62.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node63.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node64.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node65.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node66.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node67.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node68.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node69.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node7.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node70.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node71.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node72.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node73.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node74.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node75.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node76.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node77.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node78.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node79.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node8.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node80.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node81.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node82.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node83.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node84.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node85.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node86.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node87.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node88.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node89.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node9.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node90.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node91.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node92.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node93.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node94.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node95.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node96.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node97.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node98.html
+%%PORTDOCS%%%%DOCSDIR%%/html/node99.html
+%%PORTDOCS%%%%DOCSDIR%%/html/onyx.css
+%%PORTDOCS%%%%DOCSDIR%%/html/onyx.html
+%%PORTDOCS%%%%DOCSDIR%%/html/prev.png
+%%PORTDOCS%%%%DOCSDIR%%/html/prev_g.png
+%%PORTDOCS%%%%DOCSDIR%%/html/up.png
+%%PORTDOCS%%%%DOCSDIR%%/html/up_g.png
+%%PORTDOCS%%%%DOCSDIR%%/pdf/onyx.pdf
+%%DATADIR%%/libonyx/libonyx_init.nx
+%%DATADIR%%/nx/modclopt/clopt.nx
+%%DATADIR%%/nx/modclopt/modclopt.nx
+%%DATADIR%%/nx/modclopt/modclopt_defs.nx
+%%DATADIR%%/nx/modprompt/modprompt.nx
+@dirrm %%DATADIR%%/nx/modprompt
+@dirrm %%DATADIR%%/nx/modclopt
+@dirrm %%DATADIR%%/nx
+@dirrm %%DATADIR%%/libonyx
+@dirrm %%DATADIR%%
+@dirrm %%PORTDOCS%%%%DOCSDIR%%/pdf
+@dirrm %%PORTDOCS%%%%DOCSDIR%%/html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/libonyx