aboutsummaryrefslogtreecommitdiff
path: root/lang/onyx
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-04-30 16:55:22 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-04-30 16:55:22 +0000
commitfd1bb952c78d4ef00c068b6358573860d3e42716 (patch)
tree50a2e468564f8b293f18a82534bf2e1f1d85d268 /lang/onyx
parentee4b32ebad093abb32e2b2c43ca3f860da4a9e1e (diff)
downloadports-fd1bb952c78d4ef00c068b6358573860d3e42716.tar.gz
ports-fd1bb952c78d4ef00c068b6358573860d3e42716.zip
Notes
Diffstat (limited to 'lang/onyx')
-rw-r--r--lang/onyx/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/lang/onyx/Makefile b/lang/onyx/Makefile
index 0bde731ff3d8..429aeea98e86 100644
--- a/lang/onyx/Makefile
+++ b/lang/onyx/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= cook:${PORTSDIR}/devel/cook
LIB_DEPENDS= libedit.so:${PORTSDIR}/devel/libedit \
libpcre.so:${PORTSDIR}/devel/pcre
-USES= desthack tar:bzip2
+USES= tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libedit-prefix=${LOCALBASE} \
--with-pcre-prefix=${LOCALBASE}
@@ -22,6 +22,10 @@ USE_LDCONFIG= yes
PLIST_SUB= ONYX_VERSION=${PORTVERSION}
+MAN1= onyx.1 onyx_config.1
+
+NO_STAGE= yes
+
BROKEN_ia64= Coredump during build on ia64
post-patch:
@@ -31,7 +35,10 @@ do-build:
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} cook)
do-install:
- @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} DESTDIR=${STAGEDIR} cook install)
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} cook install)
+
+post-install:
@${STRIP_CMD} ${PREFIX}/bin/onyx
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>