aboutsummaryrefslogtreecommitdiff
path: root/lang/oo2c/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-06-30 02:56:21 +0000
committerWill Andrews <will@FreeBSD.org>2000-06-30 02:56:21 +0000
commit42563e847721311865cff6975a8997b77af07cb7 (patch)
tree19697bb98ee7c4cbd609c0b7a6fe1e293b84df87 /lang/oo2c/Makefile
parent6366da82198eed4f47579c432319bdba58266e77 (diff)
downloadports-42563e847721311865cff6975a8997b77af07cb7.tar.gz
ports-42563e847721311865cff6975a8997b77af07cb7.zip
Notes
Diffstat (limited to 'lang/oo2c/Makefile')
-rw-r--r--lang/oo2c/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/lang/oo2c/Makefile b/lang/oo2c/Makefile
new file mode 100644
index 000000000000..98b68d4feb3e
--- /dev/null
+++ b/lang/oo2c/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: OO2C
+# Date created: December 17, 1999
+# Whom: Oliver Breuninger <ob@seicom.NET>
+#
+# $FreeBSD$
+
+PORTNAME= oo2c
+PORTVERSION= 1.5.2
+CATEGORIES= lang
+MASTER_SITES= http://www.uni-kl.de/OOC/files/oo2c/ \
+ ftp://ftp.de.uu.net/pub/programming/languages/oberon/www.uni-kl.de/OOC/files/oo2c/ \
+ http://reality.sgi.com/boehm_mti/gc_source/
+DISTNAME= ${PORTNAME}_32-${PORTVERSION}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} gc4.14.tar.gz
+
+MAINTAINER= ob@seicom.NET
+
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= INSTALL_SCRIPT="${INSTALL_SCRIPT}"
+MAN1= oo2c.1 oob.1 ooef.1 oocn.1 oowhereis.1
+
+post-extract:
+ @${MV} ${WRKDIR}/gc ${WRKSRC}/gc
+
+post-install:
+ @${INSTALL_SCRIPT} ${FILESDIR}/oo2 ${PREFIX}/bin
+
+.include <bsd.port.mk>