aboutsummaryrefslogtreecommitdiff
path: root/lang/opa
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2012-06-12 17:29:53 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2012-06-12 17:29:53 +0000
commit6a6e4b7cf502d4a61393ce96a656816c4ace009e (patch)
treea323e44a0cb02fbd5b36f0b500e756f82dae132b /lang/opa
parent0ea57d7af52d60d31153e555cd76d3c2e670e93d (diff)
Notes
Diffstat (limited to 'lang/opa')
-rw-r--r--lang/opa/Makefile1
-rw-r--r--lang/opa/files/patch-build_myocamlbuild_prefix.ml9
2 files changed, 6 insertions, 4 deletions
diff --git a/lang/opa/Makefile b/lang/opa/Makefile
index effe7040f1da..bf218ed6d7da 100644
--- a/lang/opa/Makefile
+++ b/lang/opa/Makefile
@@ -7,6 +7,7 @@
PORTNAME= opa
PORTVERSION= 0.9.3.${GITVER}
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://download.opalang.org/tar-gz/
DISTNAME= ${PORTNAME}_v${GITVER}
diff --git a/lang/opa/files/patch-build_myocamlbuild_prefix.ml b/lang/opa/files/patch-build_myocamlbuild_prefix.ml
index df2f00681056..27ca1da9ce6b 100644
--- a/lang/opa/files/patch-build_myocamlbuild_prefix.ml
+++ b/lang/opa/files/patch-build_myocamlbuild_prefix.ml
@@ -1,5 +1,5 @@
---- build/myocamlbuild_prefix.ml.orig 2012-06-11 16:17:49.000000000 -0500
-+++ build/myocamlbuild_prefix.ml 2012-06-11 16:25:48.000000000 -0500
+--- build/myocamlbuild_prefix.ml.orig 2012-06-12 12:21:51.000000000 -0500
++++ build/myocamlbuild_prefix.ml 2012-06-12 12:25:27.000000000 -0500
@@ -325,7 +325,13 @@
let sedexpr =
Printf.sprintf "s/^\\?HAS_(%s)://; /HAS_.*:/d" tags
@@ -21,9 +21,10 @@
- (* In the memory.c in FreeBSD part that uses kvm_getprocs() required link with -lkvm. *)
if is_fbsd then
+- flag ["use_stubs"; "link"] (S[A "-cclib";A "-lkvm"]);
+ (* In the memory.c in FreeBSD part that uses kvm_getprocs() required
-+ link with -lkvm. *)
- flag ["use_stubs"; "link"] (S[A "-cclib";A "-lkvm"]);
++ link with -lkvm. The stubs needs to be compiled with -liconv too. *)
++ flag ["use_stubs"; "link"] (S[A "-cclib";A "-lkvm";A"-ccopt";A "-L/usr/local/lib";A "-cclib";A "-liconv"]);
+ (* Build with converters/libiconv port, which it installs in the
+ /usr/local by default *)
+ flag ["iconv"; "compile"] (S[A"-I";A "/usr/local/include"]);