aboutsummaryrefslogtreecommitdiff
path: root/lang/open-cobol-devel/Makefile
diff options
context:
space:
mode:
authorcvs2svn <cvs2svn@FreeBSD.org>2006-04-07 10:38:30 +0000
committercvs2svn <cvs2svn@FreeBSD.org>2006-04-07 10:38:30 +0000
commitb47be74084057e3550b8723eae1dbc0f7c0d2fa5 (patch)
tree82e808f1c6023ffd99af5a14a44b649fd49d587e /lang/open-cobol-devel/Makefile
parent503c7f7052756548d3712a6b0f3fb6d32ddbb8e9 (diff)
downloadports-b47be74084057e3550b8723eae1dbc0f7c0d2fa5.tar.gz
ports-b47be74084057e3550b8723eae1dbc0f7c0d2fa5.zip
This commit was manufactured by cvs2svn to create tag 'RELEASE_6_1_0'.release/6.1.0
Notes
Notes: svn path=/head/; revision=159032 svn path=/tags/RELEASE_6_1_0/; revision=159033; tag=release/6.1.0
Diffstat (limited to 'lang/open-cobol-devel/Makefile')
-rw-r--r--lang/open-cobol-devel/Makefile55
1 files changed, 0 insertions, 55 deletions
diff --git a/lang/open-cobol-devel/Makefile b/lang/open-cobol-devel/Makefile
deleted file mode 100644
index 68f510d3b6d6..000000000000
--- a/lang/open-cobol-devel/Makefile
+++ /dev/null
@@ -1,55 +0,0 @@
-# ex:ts=8
-# Ports collection makefile for: open-cobol
-# Date created: Aug 6, 2002
-# Whom: ijliao
-#
-# $FreeBSD$
-#
-
-PORTNAME= open-cobol
-PORTVERSION= 0.32
-PORTREVISION= 1
-CATEGORIES= lang
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= An open-source COBOL compiler
-
-LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
-
-USE_GETOPT_LONG=yes
-USE_REINPLACE= yes
-USE_AUTOTOOLS= libltdl:15
-GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-INSTALLS_SHLIB= yes
-
-INFO= open-cobol
-
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
-
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's|^SUBDIRS = lib |SUBDIRS = |g' \
- ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's|$$(top_builddir)/lib/libsupport\.a||g' \
- ${WRKSRC}/cobc/Makefile.in
-
-.if defined(MAINTAINER_MODE)
-test: build
- (cd ${WRKSRC}/tests; \
- ./syntax; \
- ./run)
-.endif
-
-.include <bsd.port.mk>