aboutsummaryrefslogtreecommitdiff
path: root/lang/open-cobol/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-08-06 13:09:46 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-08-06 13:09:46 +0000
commit828b2e2e855e7774d59497fa92db02e8265f2ee3 (patch)
tree4dc2f4f6bbe5b3b497ea209b29cc0a5f98beefee /lang/open-cobol/Makefile
parent1352cda2c654307840f2ee8003eda05d0e9c4b6a (diff)
Notes
Diffstat (limited to 'lang/open-cobol/Makefile')
-rw-r--r--lang/open-cobol/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/lang/open-cobol/Makefile b/lang/open-cobol/Makefile
new file mode 100644
index 000000000000..c2489b35bdaa
--- /dev/null
+++ b/lang/open-cobol/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: open-cobol
+# Date created: Aug 6, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= open-cobol
+PORTVERSION= 0.9.7
+CATEGORIES= lang
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= intl:${PORTSDIR}/devel/gettext \
+ iconv:${PORTSDIR}/converters/libiconv \
+ gnugetopt:${PORTSDIR}/devel/libgnugetopt \
+ db4:${PORTSDIR}/databases/db4 \
+ gmp.6:${PORTSDIR}/math/libgmp4
+
+USE_REINPLACE= yes
+USE_BISON= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt -lintl"
+CONFIGURE_ARGS= --with-readline
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|-ldb|-ldb4|g" ${WRKSRC}/configure
+
+.include <bsd.port.mk>