aboutsummaryrefslogtreecommitdiff
path: root/lang/open-cobol/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-11-23 18:58:35 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-11-23 18:58:35 +0000
commita974bbd8dd5d248923f9f3c059f3cd85e278e2e7 (patch)
tree405dbb815829ea6f321f2e694a6a02c283dcc944 /lang/open-cobol/Makefile
parent40797d26e7ebd8feae7ddba4fdc66b002c195f60 (diff)
downloadports-a974bbd8dd5d248923f9f3c059f3cd85e278e2e7.tar.gz
ports-a974bbd8dd5d248923f9f3c059f3cd85e278e2e7.zip
Notes
Diffstat (limited to 'lang/open-cobol/Makefile')
-rw-r--r--lang/open-cobol/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/lang/open-cobol/Makefile b/lang/open-cobol/Makefile
index 464e51801862..2284db4b5e37 100644
--- a/lang/open-cobol/Makefile
+++ b/lang/open-cobol/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= open-cobol
-PORTVERSION= 0.23
-PORTREVISION= 1
+PORTVERSION= 0.30
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,10 +19,10 @@ LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
USE_LIBLTDL= yes
USE_GETOPT_LONG= yes
-GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+USE_LIBTOOL_VER= 15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --with-readline
INSTALLS_SHLIB= yes
INFO= open-cobol
@@ -36,8 +35,13 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.else
USE_GETTEXT= yes
-LDFLAGS+= -lintl
PLIST_SUB+= NLS=""
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|^SUBDIRS = lib |SUBDIRS = |g' \
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|$$(top_builddir)/lib/libsupport\.a||g' \
+ ${WRKSRC}/cobc/Makefile.in
+
.include <bsd.port.mk>