aboutsummaryrefslogtreecommitdiff
path: root/lang/p2c
diff options
context:
space:
mode:
authorJean-Marc Zucconi <jmz@FreeBSD.org>1999-12-22 21:38:13 +0000
committerJean-Marc Zucconi <jmz@FreeBSD.org>1999-12-22 21:38:13 +0000
commit76ef98be9f71a67bf6622ff785ed47f7591d8e3f (patch)
tree3f0b2c0f6790f2399ae5ae976f69733693e68981 /lang/p2c
parentfaa6c11e198e706a2dd60037af9d7842373a6072 (diff)
downloadports-76ef98be9f71a67bf6622ff785ed47f7591d8e3f.tar.gz
ports-76ef98be9f71a67bf6622ff785ed47f7591d8e3f.zip
Notes
Diffstat (limited to 'lang/p2c')
-rw-r--r--lang/p2c/files/patch-cc22
-rw-r--r--lang/p2c/files/patch-tc109
2 files changed, 131 insertions, 0 deletions
diff --git a/lang/p2c/files/patch-cc b/lang/p2c/files/patch-cc
new file mode 100644
index 000000000000..dd25bbcbf853
--- /dev/null
+++ b/lang/p2c/files/patch-cc
@@ -0,0 +1,22 @@
+*** src/Makefile.orig Wed Dec 15 14:55:32 1999
+--- src/Makefile Wed Dec 15 14:56:48 1999
+***************
+*** 37,44 ****
+ #MANFILE = p2c.man.inst
+
+ # Compiler options
+! CC = cc # you may wish to use gcc here instead
+! OPT = # -O # uncomment this for optimization
+ DEB = # -g # uncomment this for debugging
+ DEFS = # place other -D types of things here
+ CFLAGS = $(OPT) $(DEB) $(DEFS)
+--- 37,44 ----
+ #MANFILE = p2c.man.inst
+
+ # Compiler options
+! CC ?= cc # you may wish to use gcc here instead
+! OPT = $(CFLAGS) # uncomment this for optimization
+ DEB = # -g # uncomment this for debugging
+ DEFS = # place other -D types of things here
+ CFLAGS = $(OPT) $(DEB) $(DEFS)
+
diff --git a/lang/p2c/files/patch-tc b/lang/p2c/files/patch-tc
new file mode 100644
index 000000000000..63824957d02d
--- /dev/null
+++ b/lang/p2c/files/patch-tc
@@ -0,0 +1,109 @@
+*** src/p2clib.c.orig Wed Dec 15 14:38:38 1999
+--- src/p2clib.c Wed Dec 15 14:42:12 1999
+***************
+*** 890,896 ****
+ {
+ #ifndef NO_TIME
+ struct tm *tm;
+! long clock;
+
+ time(&clock);
+ tm = localtime(&clock);
+--- 890,896 ----
+ {
+ #ifndef NO_TIME
+ struct tm *tm;
+! time_t clock;
+
+ time(&clock);
+ tm = localtime(&clock);
+***************
+*** 908,914 ****
+ Void VAXdate(s)
+ char *s;
+ {
+! long clock;
+ char *c;
+ int i;
+ static int where[] = {8, 9, 0, 4, 5, 6, 0, 20, 21, 22, 23};
+--- 908,914 ----
+ Void VAXdate(s)
+ char *s;
+ {
+! time_t clock;
+ char *c;
+ int i;
+ static int where[] = {8, 9, 0, 4, 5, 6, 0, 20, 21, 22, 23};
+***************
+*** 924,930 ****
+ Void VAXtime(s)
+ char *s;
+ {
+! long clock;
+ char *c;
+ int i;
+
+--- 924,930 ----
+ Void VAXtime(s)
+ char *s;
+ {
+! time_t clock;
+ char *c;
+ int i;
+
+*** src/trans.c.orig Wed Dec 15 14:33:23 1999
+--- src/trans.c Wed Dec 15 14:44:29 1999
+***************
+*** 575,581 ****
+ # endif
+ #endif
+
+! Static long starting_time;
+
+ Static void openlogfile()
+ {
+--- 575,581 ----
+ # endif
+ #endif
+
+! Static time_t starting_time;
+
+ Static void openlogfile()
+ {
+***************
+*** 608,614 ****
+
+ void closelogfile()
+ {
+! long ending_time;
+
+ if (logf) {
+ fprintf(logf, "\n\n");
+--- 608,614 ----
+
+ void closelogfile()
+ {
+! time_t ending_time;
+
+ if (logf) {
+ fprintf(logf, "\n\n");
+*** src/makeproto.c.orig Wed Dec 15 15:00:46 1999
+--- src/makeproto.c Wed Dec 15 15:01:58 1999
+***************
+*** 157,163 ****
+ char argdecls[MAXARGS][256], argnames[MAXARGS][80];
+ char *cp, *cp2, *cp3;
+ int i, j, pos, len, thistab, numstars, whichf, nargs, incomment, errors = 0;
+! long li;
+ int typetab = 15, argtab = 30, width = 80, usenames = 0, usemacros = 0;
+ int useextern = 0, staticness = -1, hasheader = 0, useifdefs = 0;
+ int stupid = 1, firstdecl;
+--- 157,163 ----
+ char argdecls[MAXARGS][256], argnames[MAXARGS][80];
+ char *cp, *cp2, *cp3;
+ int i, j, pos, len, thistab, numstars, whichf, nargs, incomment, errors = 0;
+! time_t li;
+ int typetab = 15, argtab = 30, width = 80, usenames = 0, usemacros = 0;
+ int useextern = 0, staticness = -1, hasheader = 0, useifdefs = 0;
+ int stupid = 1, firstdecl;
+