aboutsummaryrefslogtreecommitdiff
path: root/lang/p5-Interpolation/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-12-08 09:31:45 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-12-08 09:31:45 +0000
commit4c28441c5df27936a5cfd601f428d5df777f07ce (patch)
tree26d59d506d386691b769cf2c12a08e60495d00a0 /lang/p5-Interpolation/Makefile
parent39e0053cb09f17f2f70fb0669a569f4ffe8b885a (diff)
downloadports-4c28441c5df27936a5cfd601f428d5df777f07ce.tar.gz
ports-4c28441c5df27936a5cfd601f428d5df777f07ce.zip
Notes
Diffstat (limited to 'lang/p5-Interpolation/Makefile')
-rw-r--r--lang/p5-Interpolation/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/lang/p5-Interpolation/Makefile b/lang/p5-Interpolation/Makefile
new file mode 100644
index 000000000000..e8cc67c35ed8
--- /dev/null
+++ b/lang/p5-Interpolation/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: lang/p5-Interpolation
+# Date created: 08 December 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Interpolation
+PORTVERSION= 0.70
+CATEGORIES= lang perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/J/JE/JENDA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Implement arbitrary string interpolation semantics for Perl
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/HTML/Entities.pm:${PORTSDIR}/www/p5-HTML-Parser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Interpolation.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>